Summenprodukt mit MTRANS und INDEX

Bild

Betrifft: Summenprodukt mit MTRANS und INDEX
von: Hans
Geschrieben am: 23.06.2015 10:21:51

Hallo zusammen,
ich verwende folgende Formel als Matrixformel (geschweifte Klammer):
=SUMMENPRODUKT(('[Mappe1.xlsx]Tabelle1'!$C$9:$C$1503=MTRANS(INDEX($C$5:$C$73;VERGLEICH(B1;$B$5:$B$73; 0))))*'[Mappe1.xlsx]Tabelle1'!$Q$9:$Q$1503)
Anstatt MTRANS direkt auf einen konkreten Zellbereich zu setzen, möchte ich dass über die Indexformel mehrere Werte in Abhängigkeit eines definierten Wertes ausgegeben werden (hier B1).
die Indexformel akzeptiert aber immer nur den ersten, gefundenen Wert.
Ich wäre super dankbar, falls mir jemand mit der Lösung helfen könnte...
Grüße
Hans

Bild

Betrifft: Reverse engineering anhand der Formel...
von: ransi
Geschrieben am: 23.06.2015 11:04:18
HAllo,
...kann ich nicht.

=SUMMENPRODUKT(('[Mappe1.xlsx]Tabelle1'!$C$9:$C$1503=MTRANS(INDEX($C$5:$C$73;VERGLEICH(B1;$B$5:$ _
B$73; 0))))*'[Mappe1.xlsx]Tabelle1'!$Q$9:$Q$1503)
Anstatt MTRANS direkt auf einen konkreten Zellbereich zu setzen, möchte ich dass über die Indexformel mehrere Werte in Abhängigkeit eines definierten Wertes ausgegeben werden (hier B1).
Boah...
Zeig uns doch mal bitte was wo steht und was wo wann wie berechnet werden soll.
Am besten mit einer kleinen Beispieltabelle.
ransi

Bild

Betrifft: AW: Reverse engineering anhand der Formel...
von: Hans
Geschrieben am: 24.06.2015 08:41:49
https://www.herber.de/bbs/user/98420.xlsx

Bild

Betrifft: Das liegt an VERGLEICH, der findet stets nur ...
von: Luc:-?
Geschrieben am: 23.06.2015 11:10:45
…den 1.Wert (oder keinen → #NV), Hans!
Gruß, Luc :-?

Besser informiert mit …

Bild

Betrifft: VERGLEICH() kann mehr als nur den 1.Wert finden...
von: der neopa C
Geschrieben am: 23.06.2015 11:18:30
Hallo Luc,
... natürlich nur nicht in der Form, wie Hans ihn genutzt hat.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: und wie würde die Form aussehen
von: Daniel
Geschrieben am: 23.06.2015 11:55:13
in der der Vergleich das kann?
gruß Daniel

Bild

Betrifft: indem schon das Suchkriterium eine Matrix ist. owT
von: der neopa C
Geschrieben am: 23.06.2015 12:11:12
Gruß Werner
.. , - ...

Bild

Betrifft: Das nutzt doch nur etwas, wenn mehrere ...
von: Luc:-?
Geschrieben am: 23.06.2015 13:18:46
verschiedene Werte gesucht wdn sollen, Werner,
nichts aber, wenn's um alle Auftreten nur eines Wertes geht. Hierzu müsste ja wohl die Suchmatrix in Abhängigkeit vom letzten Suchergebnis modifiziert wdn.
Gruß, Luc :-?

Bild

Betrifft: doch, in dem spez. Fall hilft das so ....
von: der neopa C
Geschrieben am: 23.06.2015 13:55:32
Hallo Luc,
.. und zwar so, wie ich die Formelvorstellung von Hans interpretieren konnte.
Mit meinem Vorschlag finde ich zunächst alle Zellen, wo in Spalte B5:B73 der eine Wert aus B1 evtl. auch mehrfach vorkommen kann. Dem zugeordnet können in den Nachbarzellen der Spalte C verschiedene Werte stehen. Diese und nur diese müssen aus [Mappe1.xlsx]Tabelle1!C9:C1503 in die {SUMME()-Auswertung} einfliesen. Die anderen sind durch meine Formel einfach auf 0 fixiert.
Gruß Werner
.. , - ...

Bild

Betrifft: Nun gur, spezieller Fall, aber das ändert doch ...
von: Luc:-?
Geschrieben am: 23.06.2015 14:01:28
…nichts an der Richtigkeit der Grundaussage, Werner,
höchstens an deren hiesiger ProblemRelevanz, wie es nun den Anschein hat… ;-)
Luc :-?

Bild

Betrifft: es gibt aber auch den allgemeinen Fall ...
von: der neopa C
Geschrieben am: 23.06.2015 14:43:41
Hallo Luc,
... da sowohl das Suchkriterium als auch die Suchmatrix eine Matrix sein kann.
Ich hab übrigens nicht geschrieben, dass Deine Aussage (das VERGLEICH() nur den 1. Wert findet) falsch ist. Ich hab nur geschrieben, dass VERGLEICH() mehr kann, als nur den 1. Wert finden oder nicht.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: es gibt aber auch den allgemeinen Fall ...
von: Daniel
Geschrieben am: 23.06.2015 16:08:55
stimmt, es kann auch den letzten Wert finden.
Gruß Daniel

Bild

Betrifft: soll ich nun weinen oder lachen? ...
von: der neopa C
Geschrieben am: 23.06.2015 17:25:17
Hallo Daniel,
... ich entscheide mich fürs Lachen.
Du hast ja mit Deiner letzten Aussage (oder sollte ich besser schreiben "Spitzfindigkeit") nicht völlig Unrecht. Doch zum Verständnis für evtl. Mitleser trägt Dein Beitrag möglicherweise auch nicht gerade bei. Deshalb sollten wir es jetzt und hier bei dem belassen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: die frage hatte ich mir schon bei..
von: Daniel
Geschrieben am: 23.06.2015 17:35:12
deinen ähnlich kurzen Beiträgen gestellt.
und bei deinen Beiträgen ohne Text.
Gruß Daniel

Bild

Betrifft: MTRANS() und INDEX() bedarf es hier nicht ...
von: der neopa C
Geschrieben am: 23.06.2015 11:12:13
Hallo Hans,
... folgende MATRIXFormel sollte das gewünschte ergeben:

{=SUMME(ISTZAHL(VERGLEICH([Mappe1.xlsx]Tabelle1!C9:C1503;WENN(ISTZAHL(VERGLEICH(B5:B73;B1;));C5:C73); ))*[Mappe1.xlsx]Tabelle1!C9:C1503*[Mappe1.xlsx]Tabelle1!Q9:$Q1503)
}
Umrandende { } nicht miteingeben, sondern Formel mit STRG+SHIFT+RETURN abschließen!
Gruß Werner
.. , - ...

Bild

Betrifft: AW: MTRANS() und INDEX() bedarf es hier nicht ...
von: Hans
Geschrieben am: 24.06.2015 08:17:37
hallo Werner,
leider erhalte ich für deinen Vorschlag kein Ergebnis im Excel.
Anbei die Beispieldatei im Upload.
https://www.herber.de/bbs/user/98420.xlsx
Ich hoffe, man kann mir trotzdem noch helfen... :)

Bild

Betrifft: wie bereits geschrieben ...
von: der neopa C
Geschrieben am: 24.06.2015 09:21:21
Hallo Hans,
... allerdings stehen bei Dir in der jeweiligen Spalte C keine Zahlenwerte, so dass diese auch nicht in die Multiplikation einbezogen werden müssen. Somit verkürzt sich meine Formel auf:
{=SUMME(ISTZAHL(VERGLEICH(Blatt2!C9:C24;WENN(ISTZAHL(VERGLEICH(B5:B13;B1;));C5:C13);))*Blatt2!Q9:Q24)}
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Y-Achse Min-Wert definieren"