Formellösung für Verweis

Bild

Betrifft: Formellösung für Verweis
von: Joerschi
Geschrieben am: 29.06.2015 13:59:01

Hallo liebes Forum,
folgendes Problem möchte ich lösen (siehe auch Skizze + Musterdatei unten).
In Spalte 3 & 4 ist untereinander je eine Zahlenspanne vorgegeben sowie zugehörig in Zeile 1 jeweils ein Zielwert.
Per Vorgabe einer Zahl in B6 (welche irgendwo innerhalb der Spanne von B3:F4 liegt) soll als Formellösung in B7 errechnet werden, wie der
zugehörige Zielwert in Zeile 1 lautet.
Es gilt also per Formel herauszufinden, in welcher Spanne sich der Vorgabewert befindet und dann nach oben den Zielwert auszulesen.
Am Beispiel bzw. Skizze:
Userbild
Musterdatei: https://www.herber.de/bbs/user/98544.xls
Hat jemand einen Tip?
Viele Grüße und besten Dank im Voraus
Joerschi

Bild

Betrifft: AW: Formellösung für Verweis
von: Jack_d
Geschrieben am: 29.06.2015 14:09:00
Hallo Joerschi
ich hab ne Idee =)
Grüße
Jack


Tabelle1

 BCDEF
1134610
2     
306121824
4511172329
5     
611    
73    

verwendete Formeln
Zelle Formel Bereich R1C1 für Add In
B7{=SUMME(WENN((B3:F3<=B6);WENN(B4:F4>=B6;B1:F1)))}$B$7 =SUM(IF((R[-4]C:R[-4]C[4]<=R[-1]C),IF(R[-3]C:R[-3]C[4]>=R[-1]C,R[-6]C:R[-6]C[4])))
{} Matrixformel mit Strg+Umschalt+Enter abschließen
Matrixformeln sind durch geschweifte Klammern {} eingeschlossen
Diese Klammern nicht eingeben!!


http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://hajo-excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 14.15 einschl 64 Bit


Bild

Betrifft: AW: Formellösung für Verweis
von: Joerschi
Geschrieben am: 29.06.2015 14:12:09
Danke Dir Jack,
funktioniert :-)
Liebe Grüße
joerschi

Bild

Betrifft: AW: Formellösung für Verweis
von: SF
Geschrieben am: 29.06.2015 14:09:27
Hola,
ungetestet:

=INDEX(B1:F1;VERGLEICH(B6;B3:F3;1))
Gruß,
steve1da

Bild

Betrifft: AW: Formellösung für Verweis
von: Joerschi
Geschrieben am: 29.06.2015 14:12:46
Ebenfalls Danke, steve.
Klappt einwandfrei und ist auch leicht zu verstehen :-)
Liebe Grüße
Joerschi

Bild

Betrifft: AW: Formellösung für Verweis
von: Daniel
Geschrieben am: 29.06.2015 14:17:46
Hi
wenns noch einfacher sein soll, dann baue deine Tabelle etwas um:
- verschiebe Zeile 3 (Spanne von) nach Zeile 1
- verschiebe Zeile 1 (Zielwerte) nach Zeile 2
dann verwende die in B7 die Formel:

=WVerweis(B6;B1:F2;2;Wahr)
Gruß Daniel

Bild

Betrifft: Du wolltest ja eine Formel mit VERWEIS() ...
von: der neopa C
Geschrieben am: 29.06.2015 14:18:03
Hallo Joerschi,
... die ergibt auch die kürzeste Lösung: =VERWEIS(B6;3:3;1:1)
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Formellösung für Verweis"