Microsoft Excel

Herbers Excel/VBA-Archiv

Datum anzeigen

Betrifft: Datum anzeigen von: Andy
Geschrieben am: 12.07.2015 09:50:55

Hallo liebe Forum Mitglieder,

ich möchte einen Arbeitszeitnachweis machen, nun soll wenn ich z. B. den 01.06.2015 eingebe bis 30.06.2015 anzeigen und nicht die Tage über den letzten eines Monats hinaus

https://www.herber.de/bbs/user/98776.xlsx

hab mal zur besseren Erklärung die Datei angefügt.

Danke für eure Hilfe

  

Betrifft: AW: Datum anzeigen von: Hajo_Zi
Geschrieben am: 12.07.2015 09:53:21

http://hajo-excel.de/gepackt/ohne_vba/arbeitszeit_wochenende_feiertage.htm

GrußformelHomepage


  

Betrifft: AW: Datum anzeigen von: Sepp
Geschrieben am: 12.07.2015 09:54:38

Hallo Andy,

eine Beispielmappe ist ja meist eine feine Sache, aber ohne zu wissen, was, wann und wo geschehen soll, ist sie nichts wert!

Du kennst dein Problem, wir nicht! Wo soll das Datum eingegeben werden und was soll dann geschehen?

Gruß Sepp



  

Betrifft: AW: Datum anzeigen von: Andy
Geschrieben am: 12.07.2015 10:14:17

Hallo Sepp,

in das Feld A11 soll der 1. Tag des Monats eingegeben werden. Und mit hilfe einer Formel, soll in die Spalten von A 12 bis A 65 das Datum mit Hilfe einer Formel gefüllt werden. aber nur bis zum letzten Tag des Monats.

Danke


  

Betrifft: AW: Datum anzeigen von: Sepp
Geschrieben am: 12.07.2015 10:30:07

Hallo Andy,

https://www.herber.de/bbs/user/98777.xlsx

Gruß Sepp



  

Betrifft: AW: Datum anzeigen von: Andy
Geschrieben am: 12.07.2015 11:15:00

Hallo Sepp,

zunächst vielen Dank für Deine Hilfe. Aber irgendwie geht es nicht ganz auf. Wenn am Montag der 29.06.15 eingegeben wird dann geht es nur bis zum 26.07,15 kann man es irgendwie machen?

Danke


  

Betrifft: AW: Datum anzeigen von: Sepp
Geschrieben am: 12.07.2015 11:35:33

Hallo Andy,

der 29.06.15 ist ja auch nicht der erste Tag des Monats!

Du sagtest:"in das Feld A11 soll der 1. Tag des Monats eingegeben werden."

Jetzt weißt du, was ich mit "du kennst dein Problem, wir nicht" meinte!

Beschreib genau was du willst, dann kann man die auch helfen.

Gruß Sepp



  

Betrifft: AW: Datum anzeigen von: Andy
Geschrieben am: 12.07.2015 11:42:21

Ja hast ja recht, Aber wenn in der 1. Woche der Montag der 29.06.2015 ist muss das mit berücksichtigt werden. Hab mich ein bissl falsch ausgedrückt.

https://www.herber.de/bbs/user/98778.xlsx


  

Betrifft: AW: Datum anzeigen von: AlexG
Geschrieben am: 12.07.2015 11:46:30

Hallo Andy,

dann So?

Tabelle1

 ABCDEFGHIJKLM
56Monat:KW   Arbeitszeit       Summe Stunden 
57  Ausfall  von      bis  von      bis  von      bis  von      bisSollIst
58123456789
59Mo            27.07           0,00
60Di             28.07           0,00
61Mi             29.07           0,00
62Do            30.07           0,00
63Fr             31.07           0,00
64            0,00
65            0,00

Formeln der Tabelle
ZelleFormel
A59=WENN(MONAT(A53+1)=MONAT($A$53); A53+1;"")
A60=WENN(A59="";"";WENN(MONAT(A59+1)=MONAT($A$53); A59+1;""))
A61=WENN(A60="";"";WENN(MONAT(A60+1)=MONAT($A$53); A60+1;""))
A62=WENN(A61="";"";WENN(MONAT(A61+1)=MONAT($A$53); A61+1;""))
A63=WENN(A62="";"";WENN(MONAT(A62+1)=MONAT($A$53); A62+1;""))
A64=WENN(A63="";"";WENN(MONAT(A63+1)=MONAT($A$53); A63+1;""))
A65=WENN(A64="";"";WENN(MONAT(A64+1)=MONAT($A$53); A64+1;""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß
Alex


  

Betrifft: AW: Datum anzeigen von: Sepp
Geschrieben am: 12.07.2015 15:13:55

Hallo Andy.

falsch ausgedrückt! Nein, einfach die geforderten Informationen nicht geliefert. Ich wusste schon um was es geht, aber ein bisschen sollte der Frager schon mitdenken, sonst macht es keinen Spaß!

Jahr und Monat in A2/B2 auswählen.

https://www.herber.de/bbs/user/98781.xlsx

Gruß Sepp



  

Betrifft: AW: Datum anzeigen von: Andy
Geschrieben am: 12.07.2015 16:45:27

Hallo Sepp

vielen Dank so ist es schon sehr schön. Kann man es auch so machen, dass in spalte 2 das Datum und in Spalte 1 der Wochentag steht?. Ich muss es auf 12 Tabellenblätter machen damit jeder Monat einzeln steht. Und wie bekomme ich es hin mit den Feiertagen, dass es die mir auch von allein anzeigt?

Danke


  

Betrifft: AW: Datum anzeigen von: Sepp
Geschrieben am: 12.07.2015 17:03:24

Hallo Andy,

und was kommt noch alles? Wo sind die Feiertage hinterlegt, oder hast du da auch noch keinen Ansatz?

Wie sollen die Feiertage angezeigt werden?
Wie heißen die Tabellenblätter?
Hast du dich etwa ein wenig übernommen?

Gruß Sepp



  

Betrifft: AW: Datum anzeigen von: Sepp
Geschrieben am: 12.07.2015 17:25:10

Hallo Andy,

meine Gute Tat für heute ;-)

Das Jahr und die Feiertage stellst du im Blatt FT ein, dieses kannst du auch ausblenden, wenn du willst. Das Jahr in A1 eingeben und bei den für dich zutreffenden Feiertagen ein x in die entsprechende Zelle.

https://www.herber.de/bbs/user/98782.xlsx

Gruß Sepp



  

Betrifft: AW: Datum anzeigen von: Andy
Geschrieben am: 12.07.2015 17:36:21

Hallo Sepp,

hab vielen Dank für Deine Hilfe es gefällt mir sehr gut Danke


 

Beiträge aus den Excel-Beispielen zum Thema "Datum anzeigen"