Mit Uhrzeit rechnen, aber nur innerhalb Arbeitstag

Bild

Betrifft: Mit Uhrzeit rechnen, aber nur innerhalb Arbeitstag
von: Tim
Geschrieben am: 23.07.2015 10:56:06

Hallo,
ich möchte Prozesse in Excel darstellen.
Der erste Prozess hat ein fixen Starttermin.
Aus dem Starttermin + der Dauer ergibt sich ein Endtermin.
Der Endtermin ist dann gleichzeitig der Starttermin des nächsten Prozesses.
Soweit so gut!
Aber ein Arbeitstag ist auch irgendwann zu Ende, so dass Excel ab 18h nicht weiterrechnen soll, sondern ab dem nächsten Tag um 8h starten soll.
Bsp.:
Prozess# / Start / Dauer / Ende
1 / 01.07.2015 11:00 / 05:00 / 01.07.2015 16:00
2 / 01.07.2015 16:00 / 04:00 / 02.07.2015 10:00
...
Vielen Dank im Voraus für eure Hilfe!
Gruß
Tim

Bild

Betrifft: und wie ist Deine Definition dazu ...
von: der neopa C
Geschrieben am: 23.07.2015 13:01:19
Hallo Tim,
... immer 8:00 bis 16:00 Uhr und ohne ohne Pausenzeiten?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Mit Uhrzeit rechnen, aber nur innerhalb Arbeitstag
von: UweD
Geschrieben am: 23.07.2015 13:20:33
Hallo
meinst du das so?

Tabelle1

 ABCD
1ProzessStartDauerEnde
2101.07.2015 11:0005:0001.07.2015 16:00
3201.07.2015 16:0004:0002.07.2015 10:00

verwendete Formeln
Zelle Formel Bereich N/A
D2=WENN(B2+C2>(DATUM(JAHR(B2);MONAT(B2);TAG(B2))+18/24);B2+C2+14/24;B2+C2)  
http://excel-inn.de/dateien/vba_beispiele/tabellenanzeige_in_html_addin.zip
http://Hajo-Excel.de/tools.htm
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.03 einschl. 64 Bit


Gruß UweD

Bild

Betrifft: AW: wenig kürzer..
von: UweD
Geschrieben am: 23.07.2015 13:27:33


=WENN(B2+C2>GANZZAHL(B2)+18/24;B2+C2+14/24;B2+C2)


 Bild

Beiträge aus den Excel-Beispielen zum Thema "Mit Uhrzeit rechnen, aber nur innerhalb Arbeitstag"