Roter Rahmen neben Sonntag

Bild

Betrifft: Roter Rahmen neben Sonntag
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 17:11:32

Hallo zusammen,
Folgendes Anliegen
In meiner Dienstplantabelle steht in C2 das Datum (01, 02...) und in C3, C4 usw.
der Tag (Mo, Di usw).
Nach unten hin stehen die Dienstkürzel mit Zeiten usw.
Nun möchte ich gerne, das nach jedem Sonntag ein roter Rahmen erscheint bis zum Tabellenende (wo der Dienstplan endet).
Ich habe es mit bedingter Formatierung versucht, bekomme den Rahmen aber nur direkt in der Zelle mit dem Sonntag, nicht bis unten hin.
Hat jemand die Lösung?
Schon mal meinen besten Dank und viele Grüße
Hans
https://www.herber.de/bbs/user/99234.xlsx

Bild

Betrifft: AW: Roter Rahmen neben Sonntag
von: Hajo_Zi
Geschrieben am: 01.08.2015 17:35:00
Hallo Hans,
Dir ist schon klar das es nur ein dünner Rahmen ist?

Tabelle1

 ABCDEFG
105060708091011
2DoFrSaSoMoDiMi
3F2F2F2F2F2FRFR
407:3007:3007:3007:3007:3000:0000:00
514:3014:3014:3014:3014:3000:0000:00
600:3000:3000:3000:3000:3000:0000:00
706:3006:3006:3006:3006:3000:0000:00
800:0000:0000:0000:0000:0000:0000:00
906:3006:3006:3006:3006:3000:0000:00

verwendete Formeln
Zelle Formel Bereich N/A
A1=+DATUM($K$1;MONAT($I$1);5)  
B1=+DATUM($K$1;MONAT($I$1);6)  
C1=+DATUM($K$1;MONAT($I$1);7)  
D1=+DATUM($K$1;MONAT($I$1);8)  
E1=+DATUM($K$1;MONAT($I$1);9)  
F1=+DATUM($K$1;MONAT($I$1);10)  
G1=+DATUM($K$1;MONAT($I$1);11)  
A2:G2=WOCHENTAG(A1)  
A4:G4=WENNFEHLER(WENN(A3=$AH$3;"";WENN(A3=$AJ$3;"";WENN(A3=$AI$3;"";SVERWEIS(A3;'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Schichtmodelle'!$A$4:$B$27;2;FALSCH))));"")  
A5:G5=WENNFEHLER(WENN(A3=$AH$3;"";WENN(A3=$AJ$3;"";WENN(A3=$AI$3;"";SVERWEIS(A3;'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Schichtmodelle'!$A$4:$C$27;3;FALSCH))));"")  
A6:G6=WENNFEHLER(WENN(A3=$AH$3;"";WENN(A3=$AJ$3;"";WENN(A3=$AI$3;"";SVERWEIS(A3;'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Schichtmodelle'!$A$4:$D$28;4;FALSCH))));"")  
A7:G7=WENNFEHLER(WENN(A3=$AH$3;A8;WENN(A3=$AI$3;A8;WENN(A3=$AJ$3;0;(A5-A4-A6))));"")  
A8:G8=WENN(UND('G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B4=$A$4;A$3=1);'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$I20;WENN(UND('G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B4=$A$4;A$3=2);'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$C20;WENN(UND('G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B4=$A$4;A$3=3);'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$D20;WENN(UND('G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B4=$A$4;A$3=4);'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$E20;WENN(UND('G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B4=$A$4;A$3=5);'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$F20;WENN(UND('G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B4=$A$4;A$3=6);'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$G20;WENN(UND('G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B4=$A$4;A$3=7);'G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$H20)))))))  
A9:G9=WENNFEHLER(WENN(A7-A8>=0;A7-A8;TEXT(A8-A7;"-[hh]:mm"));"")  

definierte Namen  
Name Bezieht sich auf Tabelle Z1S1-Formel
Feiertage='G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!$B$36:$C$46 ='G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Eingangseite'!R36C2:R46C3
Schichtmodelle='G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Schichtmodelle'!$A$4:$A$25 ='G:\Platte-Notebook Duisburg\Dienstpläne neu herr Koch\[Kopie von Dienstplan_Küche_Test 2 Version 26.07.2015.xlsm]Schichtmodelle'!R4C1:R25C1

Bedingte Formatierung Haupttabelle 1  
Wird angewendet auf   Nr. Bed.  Regeltyp  Operator   Formel1   Formel2   Format Schrift Füllfarbe   Unterstrichen   Schrift- farbe Muster   Musterfarbe Typ Bereich
$A:$G01.Bed.: Formel ist =UND(WOCHENTAG(A$1;2)=7;A1<>"")   Test         2A:G
$A$1:$G$102.Bed.: Formel ist =ZÄHLENWENN(Feiertage;A1)>0  15773696    6,25% Grau   2A1:G1
$A$1:$G$103.Bed.: Formel ist = WOCHENTAG(A1;2) > 5  11389944         2A1:G1
$A$104.Bed.: Zellwert istgleich="sa"  9359529         1A1
$A$2:$G$202.Bed.: Formel ist = WOCHENTAG(A2;2) > 5  11389944         2A2:G2
$A$3:$G$302.Bed.: Formel ist =ISTLEER(A3)   Test    Diagon. Gestreift49407  2A3:G3
$A$3:$G$303.Bed.: Zellwert istgleich="KR"  15189684         1A3:G3
$A$3:$G$304.Bed.: Zellwert istgleich="FR"  11854022         1A3:G3
$A$3:$G$305.Bed.: Zellwert istgleich="TU"  14083324         1A3:G3
$A$3:$G$306.Bed.: Zellwert istgleich="TU"  14083324         1A3:G3
$A$9:$G$9,$A$4:$G$702.Bed.: Zellwert istgleich="Sa"  13551615   393372      1A9:G9,A4:G7
$A$8:$G$802.Bed.: Zellwert istgleich="Sa"  13551615   393372      1A8:G8
Bedingte Formatierung Haupttabelle 2 oberere/unterer Bereich    
Wird angewendet auf   Nr. Bed.  Format Zelle Anhalten Auswahl   Anzeige   Anzahl   Durchschnitt   Typ   Bereich
$A:$G01.Bed.   Falsch          2A:G
$A$1:$G$102.Bed.   Falsch          2A1:G1
$A$1:$G$103.Bed.   Wahr          2A1:G1
$A$104.Bed.   Wahr          1A1
$A$2:$G$202.Bed.   Wahr          2A2:G2
$A$3:$G$302.Bed.   Falsch          2A3:G3
$A$3:$G$303.Bed.   Wahr          1A3:G3
$A$3:$G$304.Bed.   Wahr          1A3:G3
$A$3:$G$305.Bed.   Wahr          1A3:G3
$A$3:$G$306.Bed.   Wahr          1A3:G3
$A$9:$G$9,$A$4:$G$702.Bed.   Wahr          1A9:G9,A4:G7
$A$8:$G$802.Bed.   Wahr          1A8:G8
Rahmen
    Links     Rechts     Oben     Unten  
 Wird angewendet auf   Nr. Bed.   Linienart     Farbe     Linienart     Farbe     Linienart     Farbe     Linienart     Farbe  
$A:$G01.Bed.     dünn durchgehend 393372         
Die Bedingungen wurden mit Excel-Version ab 2007 ausgelesen.

Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 19.07 einschl. 64 Bit




Bild

Betrifft: AW: Roter Rahmen neben Sonntag
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 17:42:32
Hallo Hajo,
ja, ich hatte es gesehen, dass nur ein dünner Rahmen möglich ist, aber der in Rot müßte die Woche wohl abgrenzen.
Gruß
Hans

Bild

Betrifft: Danke für Rückmeldung
von: Hajo_Zi
Geschrieben am: 01.08.2015 17:44:22
Hallo Hans,
das Problem ist dann ja gelöst.
Gruß Hajo

Bild

Betrifft: AW: Danke für Rückmeldung
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 17:47:24
Hallo Hajo,
nein, oder hab ich was übersehen?
Ich bekomme den roten Rahmen ja nur neben den Sonntag in der einen Zelle, nicht die ganze Spalte runter bis der Dienstplan endet.
Gruß
Hans

Bild

Betrifft: AW: bedingte Formatierung.
von: Hajo_Zi
Geschrieben am: 01.08.2015 17:48:58
Hallo Hans,
bei meiner Formel ist er bei allen ausgefüllten Zellen.
Aber meine Lösung scheint Dir nicht zu gefallen.
Ich bin dann raus.
Gruß Hajo

Bild

Betrifft: AW: bedingte Formatierung.
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 17:53:51
Hallo Hajo,
ich finde deine Lösung nicht? Hab ich eine Antwort übersehen oder steckt die Formel in der ganzen Formel-Auswertung?
Sorry, aber ich schaue nochmal alle Antworten von Dir durch.
Danke und Gruß
Hans

Bild

Betrifft: AW: Danke für Rückmeldung
von: AlexG
Geschrieben am: 01.08.2015 18:05:51
Hallo Hans,
hier noch zwei Screenshots zu Hajos bedingter Formatierung.
Evtl hilft dir ja das weiter.
Userbild
Userbild
Gruß
Alex

Bild

Betrifft: Bei einem eigenen Betreff von Dir
von: WF
Geschrieben am: 01.08.2015 18:37:52
würde das auch jemand lesen.
WF

Bild

Betrifft: Der Betreff,...
von: AlexG
Geschrieben am: 01.08.2015 18:47:08
Hallo WF
... gerät bei leider oft in Vergessenheit.
Der Fragesteller wird sich den Beitrag, denke ich mal, ansehen.
Aber Danke für den Hinweis und ein schönes Restwochenende.
Gruß
Alex

Bild

Betrifft: AW: Bei einem eigenen Betreff von Dir
von: Hans-Joachim Koch
Geschrieben am: 01.08.2015 19:30:51
Hallo ALex,
vielen lieben Dank für Deine Unterstützung. Dadurch wurde mir alles noch mal klarer.
Ich habs jetzt fast hinbekommen. Außer die rote Linie endet nicht bei meinem Dienstplanende, sondern zieht sich bis ans Ende der Excel Spalten durch.
Aber das bekomme ich bestimmt auch noch hin.
Danke und schönen Abend
Hans

Bild

Betrifft: Danke für die Rückmeldung, Gruß (owT)
von: AlexG
Geschrieben am: 01.08.2015 19:45:46
.

Bild

Betrifft: AW: Danke für Rückmeldung
von: AlexG
Geschrieben am: 01.08.2015 18:06:01
Hallo Hans,
hier noch zwei Screenshots zu Hajos bedingter Formatierung.
Evtl hilft dir ja das weiter.
Userbild
Userbild
Gruß
Alex

Bild

Betrifft: AW: Roter Rahmen neben Sonntag
von: Hans-Joachim Koch
Geschrieben am: 02.08.2015 10:58:42
Hallo Hajo,
dank Deiner Unterstützung habe ich die rote Rahmenlinie als Abgrenzung von Sonntag zum Montag hinbekommen.
Ich hatte die Formel nicht sofort in Deiner Übersicht entdeckt.
Also nochmals Danke und schönen Sonntag
Hans

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Roter Rahmen neben Sonntag"