Dropdown für spezielles Kriterium anpassen

Bild

Betrifft: Dropdown für spezielles Kriterium anpassen
von: Tobias
Geschrieben am: 10.08.2015 09:19:57

Guten Morgen zusammen,
ich habe da mal wieder eine Frage zur Dropdown Feinjustierung. Genauer gesagt, ich möchte eine Dropdownliste erstellen, die mir nur die Kräne aus meiner Tabelle filtert und mir diese als Auswahlmöglichkeit im Dropdown anzeigt. Die Tabelle habe ich angehängt.
https://www.herber.de/bbs/user/99454.xlsx
Mit den Befehlen INDEX/VERGLEICH/BEREICH.VERSCHIEBEN habe ich noch nicht viel gemacht, befürchte aber, das diese die Werkzeuge zur Lösung sind.
Habe es versucht und folgendes in die Datenüberprüfung/Liste als Formel eingetragen:

=INDEX(F13:F17;VERGLEICH("Kran";E13:E17;0);F:G) 
Ziel ist es, jeden Artikel (Spalte F) im Dropdownfeld "anzuzeigen", welcher als Referenz (Spalte E) "Kran" ausweist. Leider kommt mit meiner Formel nur immer ein Kran in die Auswahl, wenn ich den Vergleich -1/0/1 anpassen.
Was mache ich falsch bzw. ist das überhaupt der richtige Weg?
Über eure Hilfe würde ich mich sehr freuen!
Danke vorab,
Tobias

Bild

Betrifft: mittels INDEX() und AGGREGAT() in ...
von: der neopa C
Geschrieben am: 10.08.2015 09:37:29
Hallo Tobias,
... einer Hilfsspalte (z.B. Spalte H) folgende Formel in H2:
=WENNFEHLER(INDEX(F:F;AGGREGAT(15;6;ZEILE(E$1:E$99)/(E$1:E$99="Kran");ZEILE(A1)));"")
und diese ziehend nach unten kopieren.
Dann eine Bereichsnamensdefinition: z.B. Kran= =$H$2:INDEX($H:$H;ZÄHLENWENN($E$1:$E$19;"Kran")+1) und in der Datengültigkeit mit Liste den Bereichsnamen "Kran" zuweisen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mittels INDEX() und AGGREGAT() in ...
von: Tobias
Geschrieben am: 10.08.2015 10:46:26
Hallo Werner,
musste es erstmal verstehen, aber jetzt habe ich es in meine Tabelle eingebaut und es funktioniert tadellos!
Viele Dank dir!
beste Grüße aus der Eifel,
Tobias

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Dropdown für spezielles Kriterium anpassen"