Matrixformel als VBA

Bild

Betrifft: Matrixformel als VBA
von: mskro
Geschrieben am: 10.08.2015 11:35:09

Hallo Excelfreunde,
wie kann ich folgende Formel (Matrixformel) im VBA einbinden und das Ergebnis davon in eine Variable bringen?
{=WENN(ISTZAHL(FINDEN("/";B12));TEIL(B12;VERGLEICH(WAHR;ISTZAHL(TEIL(B12;ZEILE($1:$99);1)*1);0);99); "-") }
Var1= "Formel" funktioniert nicht.
Gruß Manfred

Bild

Betrifft: AW: Matrixformel als VBA
von: Rudi Maintaire
Geschrieben am: 10.08.2015 12:04:13
Hallo,
würde ich durch eine Funktion ersetzen.

Sub aa()
  Dim x
  x = mattze([b12])
End Sub

Function mattze(s As String) As String
  Dim i
  If InStr(s, "/") Then
    For i = 1 To Len(s)
      If IsNumeric(Mid(s, i, 1)) Then
        mattze = Mid(s, i)
        Exit Function
      End If
    Next i
  Else
    mattze = "-"
  End If
End Function

Gruß
Rudi

Bild

Betrifft: AW: Matrixformel als VBA
von: mskro
Geschrieben am: 10.08.2015 12:42:03
Hallo Rudi,
Du bist der Wahnsinn, vielen Dank, es klappt hervorragend.
Habe Deine Funktion gerade in eine Schleife meines Makros eingebaut und erziele damit mit genau das, was ich erreichen wollte.
Nochmals Danke
Gruß Manfred

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Matrixformel als VBA"