@neopa & alle: Summenprodukt + Aggregat Min?

Bild

Betrifft: @neopa & alle: Summenprodukt + Aggregat Min?
von: Joerschi
Geschrieben am: 21.08.2015 09:25:01

Hallo Werner (und natürlich auch alle anderen Forenmitglieder),
gezielte Ansprache an Dich, weil ich mir nicht sicher bin, ob wir etwas Ähnliches nicht schon mal hatten oder ob es ähnlich der "offenen" Fragen ist.
Folgendes Problem soll gelöst werden (Skizze + Musterdatei unten):
Es gibt eine Datentabelle d7:U34 (in der "Realität" dann 300 Spalten*2000Zeilen, hier also stark vereinfacht).
In C3:U3 werden manuell Vorgaben gesetzt. Für C3:F3 gelten sie für ihre Spalten als fix (also genaue Übereinstimmung), für alle weiteren Spalten ist die Vorgabe ein Mindestwert.

In G5:U5 soll nun unter Beachtung der Vorgaben das Minimum jeder Spalte von denjenigen Zeilen errechnet werden, die ALLE gesetzten Vorgaben erfüllen.
Grafisch dargestellt wird spaltenweise das Minimum aus den Zahlenwerten gesucht, welche in der Skizze vertikal durchweg grün dargestellt sind. Zum besseren Verständnis habe ich diese Zeilen mit einem dicken Rahmen versehen.
Außerdem soll in O6 die Anzahl der Zeilen ausgegeben werden, wo ALLE Bedingungen erfüllt sind.
Skizze:
Userbild
Musterdatei zur Skizze: https://www.herber.de/bbs/user/99749.xlsx
Meine erste Idee wäre eine Kombination aus Summenprodukt und Aggregat_Min, aber irgendwie scheint das noch nicht recht zu klappen.
@Werner & alle anderen: könnte man die Idee aus Werners Post vom 13.08. 14.21 Uhr hier darauf adaptieren?
(aus diesem Thread: https://www.herber.de/forum/archiv/1440to1444/t1442040.htm)
Danke vorab für alle Tipps und liebe Grüße
Joerschi

Bild

Betrifft: AW: Deine Vermutung stimmte ...
von: ... neopa C
Geschrieben am: 21.08.2015 09:47:24
Hallo Joerschi,
... auf die Schnelle mal die Lösung(en) mit einer Hilfsspalte.
In V8:


=SUMMENPRODUKT((G9:U9>=G$3:U$3)*(C9&D9&E9&F9=C$3&D$3&E$3&F$3))=15
und nach unten kopieren.
In G5: einfach: =AGGREGAT(15;6;G9:G2000/$V9:$V2000;1) und nach rechts kopieren
In O6: noch einfacher =ZÄHLENWENN(V:V;WAHR)
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Deine Vermutung stimmte ...
von: Joerschi
Geschrieben am: 21.08.2015 09:56:49
Super. Danke Dir.
Für alle Mitleser odere andere, die mit der Lösung was anfangen können: Statt V8 meinte neopa natürlich V9 (Tippfehler).
Beste Grüße
Joerschi

Bild

Betrifft: AW: natürlich V9 anstelle V8 und nachgefragt ...
von: ... neopa C
Geschrieben am: 21.08.2015 10:23:04
Hallo Joerschi,
... ich hab mir Deine zusätzliche Anfrage in https://www.herber.de/forum/archiv/1440to1444/t1442040.htm noch nicht wirklich näher angeschaut. Ist diese nun aber mit der hiesigen Lösung schon "gegessen", oder?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: natürlich V9 anstelle V8 und nachgefragt ...
von: Joerschi
Geschrieben am: 21.08.2015 10:31:28
ich bin grad fleißig beim Testen.
Schrägerweise löst dieser Aufbau oben scheinbar die andere "unbeantwortete" Frage (die 10 Vorgaben erweitert werden sollte). Da bitte erstmal nix machen.
Die von Dir verlinkte Frage ist damit noch als Einziges offen :-)

Bild

Betrifft: AW: der andere thread liegt schon im Archiv ...
von: ... neopa C
Geschrieben am: 21.08.2015 11:08:54
Hallo Joerschi,
... und ist somit nicht mehr aktiv, nur noch lesbar.
Deine dortigen Erläuterungen vom 17.08. und die dort eingestellte Datei sagt mir momentan noch nicht, was Du genau ermittelt haben willst. Kannst Du das an zwei, drei konkreten Beispielen zunächst für "Vorgabe-Tab1 mal aufzeigen?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: der andere thread liegt schon im Archiv ...
von: Joerschi
Geschrieben am: 21.08.2015 12:51:36
Hi Werner,
ich habe einen neuen Folge(thread) dazu eröffnet, dort mit Beispiel.
So können auch andere folgen, welche eine Lösung für so eine Problem haben.
Danke Dir wie immer.
Beste Grüße, Joerschi

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Array füllen mit doppelten"