Suche nach Kriterium und Ausgabe in Reihenfolge

Bild

Betrifft: Suche nach Kriterium und Ausgabe in Reihenfolge
von: Major
Geschrieben am: 21.08.2015 16:42:42

Hallo zusammen,
ich hoffe ihr könnt mir hierbei helfen...
bitte Datei beachten, ansonsten macht meine Beschreibung keinen Sinn.
https://www.herber.de/bbs/user/99763.xlsx
Es soll nach der Bedingung "ja" gesucht werden. Ausgegeben werden soll der zugehörige Artikel und der dazugehörige Fall. (1,2 oder3)
Wie im Lösungswunsch zu sehen ist, soll aber auch eine gewisse Reihenfolge eingehalten sein. In der Ausgabe also zuerst Fall 1, dann Fall 2 und dann Fall 3.
Erwähnenswert ist noch.... ein Artikel kann nicht bei mehreren Fällen vorkommen.
Ich bin mir gar nicht sicher ob das überhaupt ohne Makro zu lösen ist?
Und in Sachen Makros bin ich einfach nicht fit genug.
Hat jemand einen Lösungsvorschlag?
Danke euch!
Gruss Major

Bild

Betrifft: AW: mit INDEX() und AGGREGAT() ...
von: ... neopa C
Geschrieben am: 21.08.2015 17:02:20
Hallo Major,
... so (Formeln nach unten kopieren):

 BCDE
4Artikel123
5ajaneinnein
6bneinneinnein
7cneinneinja
8dneinneinnein
9ejaneinnein
10fneinneinnein
11gneinjanein
12hneinneinnein
13ineinneinnein
14jneinneinnein
15kneinneinnein
16lneinneinnein
17mneinjanein
18nneinjanein
19oneinjanein
20    
21    
22Ausgabe  
23ArtikelFall (1, 2 oder 3)  
24a1  
25e1  
26g2  
27m2  
28n2  
29o2  
30c3  
31    

Formeln der Tabelle
ZelleFormel
B24=WENN(C24="";"";INDEX(B:B;AGGREGAT(15;6;ZEILE(A$5:A$19)/ISTZAHL(SUCHEN("ja";C$5:E$19))/(C$4:E$4=C24); ZÄHLENWENN(C$24:C24;C24))))
C24=WENNFEHLER(AGGREGAT(15;6;C$4:E$4/(C$5:E$19="ja"); ZEILE(A1)); "")

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: mit INDEX() und AGGREGAT() ...
von: Major
Geschrieben am: 21.08.2015 17:12:32
Hallo Werner,
AGGREGAT habe ich noch nie genutzt, gibt es wohl auch unter Excel2007 noch nicht.
Gibt es eine alternative Lösung?
Gruss Major

Bild

Betrifft: AW: ach ja, Du hast ja XL2007 ...
von: ... neopa C
Geschrieben am: 21.08.2015 17:17:55
Hallo Major,
... sorry, das hab ich übersehen. Da kannst Du AGGREGAT() noch nicht anwenden.
Geht mit analogen echten Matrixformel.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: ach ja, Du hast ja XL2007 ...
von: Major
Geschrieben am: 21.08.2015 17:26:58
Hallo Werner und Co.
Level VBA gebe ich immer mit = "nein" an :-)
Wenn also jemand mir zeigen könnte wie das aussehen könnte wäre ich echt dankbar.
Gruss Major

Bild

Betrifft: AW: siehe unten drunter owT
von: ... neopa C
Geschrieben am: 21.08.2015 17:34:17
Gruß Werner
.. , - ...

Bild

Betrifft: AW: für ältere Excelversionen mit Hilfssp.
von: Daniel
Geschrieben am: 21.08.2015 17:40:48
Hi
hier eine Lösung, die auch in ältern Excelversionen funktionieren sollte.
falls du nach einer Lösung ohne Hilfsspalte fragen solltest: wenn ich eine einfache Lösung wüsste, die ohne Hilfsspalte auskommt, würde ich sie dir auch zeigen.
https://www.herber.de/bbs/user/99767.xlsx
Gruß Daniel

Bild

Betrifft: AW: und für Excelversionen vor 2010 ...
von: ... neopa C
Geschrieben am: 21.08.2015 17:26:22
Hallo Major,
... so:

 BC
22Ausgabe
23ArtikelFall (1, 2 oder 3)
24a1
25e1
26g2
27m2
28n2
29o2
30c3
31  

Formeln der Tabelle
ZelleFormel
B24{=WENN(C24="";"";INDEX(B:B;KKLEINSTE(WENN(ISTZAHL(SUCHEN("ja";C$5:E$19))*(C$4:E$4=C24); ZEILE(A$5:A$19)); ZÄHLENWENN(C$24:C24;C24))))}
C24{=WENNFEHLER(KKLEINSTE(WENN(C$5:E$19="ja";C$4:E$4); ZEILE(A1)); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen

Bedingte Formatierungen der Tabelle
ZelleNr.: / BedingungFormat


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: und für Excelversionen vor 2010 ...
von: Major
Geschrieben am: 26.08.2015 14:33:40
Hallo Werner,
deine Version hat super geklappt, danke dir für deine Hilfe! Thema beendet.
Gruss Major

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Suche nach Kriterium und Ausgabe in Reihenfolge"