Zellinhalte vervielfachen

Bild

Betrifft: Zellinhalte vervielfachen
von: Lars Kämper
Geschrieben am: 03.09.2015 16:51:01

Hallo Zusammen,
ich finde zu meiner Frage einige Anfragen und auch Antworten, aber leider mit einem Unterschied zu meinem Problem, den ich nicht überwinden kann.
Ich benötige Etiketten-Aufkleber für Verpackungen und möchte eine Tabelle als Datensatz für diese Etiketten erstellen.
Ich habe in Spalte A verschiedene Artikelnummern einzeln aufgeführt. Jede Artikelnummer hat in der Spalte B eine Zahl zugeordnet, welche der Menge an benötigten Preisetiketten entspricht.
Beispiel:
Artikelnummer|Menge
Artikel123|5
Artikel456|8
Artikel789|15
Nun benötige ich in der Spalte C den Artikel123 insgesamt 5 Mal untereinander, Artikel456 brauche ich 8Mal usw...
Welche Formel muss ich in Spalte C anwenden?
Vielen Dank für eure Hilfe im Voraus,
Lars

Bild

Betrifft: AW: Zellinhalte vervielfachen
von: Rudi Maintaire
Geschrieben am: 03.09.2015 17:08:25
Hallo,
C1: =A1
C2 ff: =WENN(ZÄHLENWENN(C$1:C1;C1)<SVERWEIS(C1;A:B;2;);C1;INDEX(A:A;VERGLEICH(C1;A:A;)+1))
Gruß
Rudi

Bild

Betrifft: AW: Zellinhalte vervielfachen
von: Daniel
Geschrieben am: 03.09.2015 17:28:13
Hi
mit Hilfsspalte so:
1. füge in Spalte A eine Hilfsspalte ein, so dass in B der Artikel steht und in C die Menge
2. in die Zelle A1 kommt der Wert 1
3. in die Zelle A2 kommt die Formel: =A1+C1, diese Formel bis zum letzten Artikel runterziehen.
4. in D1 kommt dann die Formel: =Wenn(Zeile()>Summe(C:C);"";SVerweis(Zeile();A:B;2;1))
diese Formel soweit runterziehen, bis sie nichts mehr anzeigt.
Gruß Daniel

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellinhalte vervielfachen"