Maximalwert aus Matrix

Bild

Betrifft: Maximalwert aus Matrix
von: Anna-Sophie
Geschrieben am: 19.09.2015 16:08:58

Hallo,
ich habe folgendes Problem. Ich habe eine große Liste mit Personen, die zum Teil mehrfach auftauchen. Nun möchte ich den maximalen Wert einer jeden Person angezeigt bekommen, über den gesamten Betrachtungszeitraum. Nun habe ich es in der Spalte C mit der Formel =WENNFEHLER(MAX((A1:A150=A1)*B1:B150);"") versucht. Nur leider steht in der Spalte C immer noch nicht überall 20 bzw. 10.
A - B - C
ID - 1. Termin
0056517 - 07 - 07
0056517 - 10 - 10
0056517 - 00 - 00
0056517 - 20 - 20
0056517 - 11 - 11
Ausschauen soll das ganze nachher so:
A - B - C
ID - 1. Termin
056517 - 07 - 10
056517 - 10 - 10
056517 - 00 - 10
040510 - 20 - 20
040510 - 11 - 20
Ich hoffe mir kann jemand helfen. Es würde mir die Arbeit extrem erleichtern, wenn ich nicht manuell den höchsten Wert auslesen müsste.
Vielen Dank und Gruß Anna

Bild

Betrifft: AW: Maximalwert aus Matrix
von: Sepp
Geschrieben am: 19.09.2015 16:13:36
Hallo Anna,
so?
Tabelle2

 ABC
1ID1. Termin 
256517710
3565171010
456517010
5405102020
6405101120

Formeln der Tabelle
ZelleFormel
C2=WENNFEHLER(AGGREGAT(14;6;$B$1:$B$150/($A$1:$A$150=A2); 1); "")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Sepp


Bild

Betrifft: das ist eine Array-Formel und die $ fehlen
von: WF
Geschrieben am: 19.09.2015 16:29:01
Hi,
{=WENNFEHLER(MAX((A$1:A$150=A1)*B$1:B$150);"")}
Eingabe Arrayformel:
Du kopierst Dir die Formel.
Dann gehst Du in die Bearbeitungszeile, löschst die {geschweiften Klammern} am Anfang und Ende und schließt ab mit GLEICHZEITIG: Strg Shift Enter (statt Enter allein). Dadurch werden diese Klammern erzeugt.
Und, wenn Du die Formel runterkopieren willst, brauchst Du die Dollars.
WF

Bild

Betrifft: AW: Maximalwert aus Matrix
von: Anna-Sophie
Geschrieben am: 22.09.2015 21:16:26
Vielen, vielen lieben Dank!!!! Jetzt klappt es... ich hatte es schon aufgegeben!
LG Anna

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Maximalwert aus Matrix"