Am kürzesten zurück liegendes Datum finden

Bild

Betrifft: Am kürzesten zurück liegendes Datum finden
von: Stefan
Geschrieben am: 25.09.2015 09:43:40

Guten Morgen zusammen,
ich hänge gerade an einer kleinen Knobelaufgabe mit einem Datumsvergleich und wollte mal schauen, ob hier jemand eine Lösungsidee hat.
Es gibt eine Bewegungstabelle mit Verkaufsdaten aus Produkt und Verkaufstag und eine weitere Stammdatentabelle, die die Produkte mit dem Veröffentlichungstag enthält.
Die Logik ist, dass die Produkte im Abstand von 1-4 Wochen erscheinen, aber jeden Tag verkauft werden können. Es wird immer nur das aktuellste Produkt verkauft. Ich möchte nun eine Formel bauen, die an die Verkaufsdaten eine Spalte ergänzt, wo das zugehörige Veröffentlichungsdatum, also das jeweils am kürzesten von dem Verkaufstag entfernte, zurückliegende Datum zugeordnet wird.
Irgendwie klappt der Dateiupload bei mir nicht, daher hier meine Bsp. Datei als Download-Link.
https://www.dropbox.com/s/iqylzdep6s8ks6w/Datum-Vergleich.xlsx?dl=0
Freue mich über Eure Vorschläge.
Viele Grüße

Bild

Betrifft: AW: Am kürzesten zurück liegendes Datum finden
von: Daniel
Geschrieben am: 25.09.2015 09:56:30
HI
zum Download:
Hast du die Hinweise auf der Downloadseite beachtet?
wenn man die einhält, sollte es eigentlich funktionieren (aber wer machst sich schon die mühe, das zu lesen ???)
Gruß Daniel

Bild

Betrifft: AW: Am kürzesten zurück liegendes Datum finden
von: SF
Geschrieben am: 25.09.2015 09:58:00
Hola,
wie sähe denn dein Wunschergebnis aus?
Gruß,
steve1da

Bild

Betrifft: AW: Am kürzesten zurück liegendes Datum finden
von: Stefan
Geschrieben am: 25.09.2015 15:07:02
Hallo,
so sähe das aus:
https://www.herber.de/bbs/user/100397.xlsx
Habe die Werte, die die Formel ausgeben soll, einfach mal händisch eingetragen und grün hinterlegt.
p.s. Upload Problem "gelöst". Hinweise hatte ich natürlich alle gelesen. Nur im Chrome Browser unter Osx lassen sich keine Dateien auswählen (alles grau als ob falscher Dateityp). Im Firefox geht es auch unter Osx. ;)
Grüße
Stefan

Bild

Betrifft: AW: Deine Datumswertangaben sind fragwürdig ...
von: ... neopa C
Geschrieben am: 25.09.2015 16:38:01
Hallo Stefan,
... und zwar sind Deine Datumswerte nur visuelle Datumswerte aber keine echten Exceldatumswerte (kannst Du leicht erkennen; die Summe dieser Datumswerte ist 0 (siehe F2:H2) und nicht wie bei echten Exceldatumswerte eine Dezimalzahl; siehe C2).
Die Ursache dafür: Es standen in diesen Zellen ursprünglich mal "hart" als Textwerte formatierte Werte, die auch durch nachträgliches Formatieren als Datumswerte keine echten Exceldatumswerte werden. Dieses kannst Du nur erreichen, wenn Du diese Werte mit einer 1 multiplizierst und danach als Datumswerte formatierst.
Und Deine händisch vorgegebenen Ergebniswerte in (habe ich jetzt in F7:F10) stehen, widersprechen mE Deinen verbalen Aussagen.
Eine korrekte Auswertung für Deine verbale Vorgabe wäre mit AGGREGAT() und Datumsformat in Spalte D erzielbar. Die Formel D4 einfach unten ziehend kopieren (die darin eingebaute *1 kann entfallen, wenn in H echte Datumswerte stehen).
Tabelle1

 BCDEFGH
1Verkaufsdaten   Stammdaten
2 464208  0 0
3ProduktVerkaufdatum(aktuellstes) Veröffentlichungsdatum VorgabenProduktVeröffentlichungsdatum
4S203.07.201502.07.2015 02.07.2015S202.07.2015
5S205.07.201502.07.2015 02.07.2015S209.07.2015
6S228.07.201523.07.2015 09.07.2015S216.07.2015
7S228.07.201523.07.2015 09.07.2015S223.07.2015
8S216.07.201516.07.2015 09.07.2015S230.07.2015
9S217.07.201516.07.2015 09.07.2015B108.07.2015
10S223.07.201523.07.2015 09.07.2015B122.07.2015
11B108.07.201508.07.2015 08.07.2015  
12B112.07.201508.07.2015 08.07.2015  
13B110.07.201508.07.2015 08.07.2015  
14B123.07.201522.07.2015 22.07.2015  
15       

Formeln der Tabelle
ZelleFormel
C2=SUMME(C4:C99)
F2=SUMME(F4:F99)
H2=SUMME(H4:H9)
D4=AGGREGAT(14;6;H$4:H$99/(H$4:H$99*1<=C4)/(G$4:G$99=B4); 1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Deine Datumswertangaben sind fragwürdig ...
von: Stefan
Geschrieben am: 25.09.2015 20:00:53
Hallo Werner,
vielen vielen Dank - das funktioniert genau so wie ich mir das gedacht habe.
Die roten manuellen Werte waren natürlich falsch abgetippt - da hattest Du Recht.
Wünsche ein schönes Wochenende!
Stefan

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Am kürzesten zurück liegendes Datum finden"