Datumsberechnung ohne Wochenenden und o Feiertage

Bild

Betrifft: Datumsberechnung ohne Wochenenden und o Feiertage
von: Franz Sperger
Geschrieben am: 13.10.2015 11:16:26

Hallo zusammen.
Bei einigen Dingen hat mir dieses Forum schon geholfen. Leider komme ich nicht mehr weiter. Derzeit berechne ich folgendes: Differenz Datum 1 zu Datum 2 exklusive Wochenende. Nun würde ich gerne die Formel erweiterten um die definierten betrieblichen "Feiertage" an denen nicht gearbeitet wird - klingt komisch :-) ist aber so - mit einbeziehen!
Bisherige Eingabe:
=B5+1-B4-GANZZAHL((WOCHENTAG(B4;2)+B5-B4)/7)-GANZZAHL((WOCHENTAG(B4;1)+B5-B4)/7)
B4 = Datum 1
B5 = Datum 2
Feiertage werden über eine eigene Tabelle definiert = eigenes Tabellenblatt!
Bitte um Eure Unterstützung.
Beste Grüße.
Franz

Bild

Betrifft: AW: Datumsberechnung ohne Wochenenden und o Feiertage
von: RPP63
Geschrieben am: 13.10.2015 11:20:25
Hallo!
Dafür gibt =Nettoarbeitstage() (5-Tage-Woche)
bzw. ab xl2010 =Nettoarbeitstage.Intl() (beliebig definierbare "Wochenenden")
Lies Dir dazu mal die gute Excel-Hilfe durch oder suche nach dem Formeltext in einer Suchmaschine Deiner Wahl.
Gruß Ralf

Bild

Betrifft: AW: Datumsberechnung ohne Wochenenden und o Feiertage
von: Franz Sperger
Geschrieben am: 13.10.2015 11:27:02
Ich nutze die Formel auch in einem EIS daher klappt das nicht mit den Nettoarbeitstagen!
Haben Sie eine einfache Lösung?
Grüße und Danke.

Bild

Betrifft: die Formel ist ja von uns
von: WF
Geschrieben am: 13.10.2015 11:30:46
da solltest Du weiterlesen - es kommen dann auch die Feiertage
http://excelformeln.de/formeln.html?welcher=11
WF

Bild

Betrifft: AW: die Formel ist ja von uns
von: Franz Sperger
Geschrieben am: 13.10.2015 11:44:47
Das es die Formel mehrfach gibt habe ich schon herausgefunden! Dafür schon mal recht herzlichen Dank! Leider klappt das nicht in dem EIS Programm - es lassen sich viele Excel Formeln anwenden, aber eben nicht alle!?
Eine geniale Idee würde mir hier vieeeeel Murx ersparen....
Grüße.

Bild

Betrifft: was ist EIS ?
von: WF
Geschrieben am: 13.10.2015 13:20:11
.

Bild

Betrifft: AW: was ist EIS ?
von: Wilfried Höttl
Geschrieben am: 13.10.2015 13:57:47
Hallo!
Hier zwei Formeln.
Tabelle1

 ABCDEF
1Nettoarbeitstage ohne Sa, So, und Feiertage     
2      
3Fr 01.08.2014Mo 01.09.201420   
4      
5Fr 01.08.2014Mo 01.09.201420 Feiertage 
6    Fr 15.08.2014  
7    Do 21.08.2014  
8      

Formeln der Tabelle
ZelleFormel
C3=WENN(ANZAHL(A3:B3)=2;NETTOARBEITSTAGE(A3;B3;$E$6:$E$10); "")
C5=SUMMENPRODUKT((WOCHENTAG(ZEILE(INDIREKT(A5&":"&B5)); 2)<6)*1)-SUMMENPRODUKT(($E$6:$E$10>=A5)*($E$6:$E$10<=B5)*(WOCHENTAG($E$6:$E$10;2)<6))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß
Wilfried

Bild

Betrifft: Enterprise Information System?
von: RPP63
Geschrieben am: 13.10.2015 14:01:22
Hi!
ist wohl: http://support.sas.com/documentation/cdl/en/appdevgd/59506/HTML/default/viewer.htm#a000427327.htm
Damit kenne ich mich nicht aus.
Gruß Ralf

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datumsberechnung ohne Wochenenden und o Feiertage"