Bestimmte Zeilen für Berechnung auswählen

Bild

Betrifft: Bestimmte Zeilen für Berechnung auswählen
von: Markus
Geschrieben am: 14.10.2015 08:43:10

Hallo Miteinander
Gerne wende ich mich mit meinem Anliegen an dieses Forum. Die Tabelle seht ihr hier: https://www.herber.de/bbs/user/100765.xlsx
Ich kopiere jeweils monatlich Daten in das Tabellenblatt "Rohdaten Monat". Spalte A+B resp C+D gehören als Zeitkombination zusammen (Datum und Uhrzeit).
Ziel ist, die Zeitdifferenz in Minuten für den type "M" pro Monat zu errechnen (z.B. (C2+D2)-(A2+B2)). Die Formel muss im Tabellenblatt "Zusammenstellung" erstellt werden (gelber Bereich). Die Tabellenblätter der Rohdaten dürfen nicht ergänzt oder angepasst werden. Zudem soll sich die Formel automatisch das richtige Tabellenblatt mit dem entsprechenden Monat beziehen (Thema INDIREKT()).
Die Möglichkeiten mit SVERWEIS(), INDIREKT(), Arrays usw.. habe ich ohne Erfolg durchgespielt. Ich hoffe ihr habt hier eine zündende Idee.
Gruss
Markus

Bild

Betrifft: AW: Bestimmte Zeilen für Berechnung auswählen
von: selli
Geschrieben am: 14.10.2015 09:12:29
hallo markus,
die funktionen SUMMENPRODUKT() in kombination mit INDIREKT() zur auswahl des entsprechenden blattes sollten dir hier weiterhelfen.
gruß
selli

Bild

Betrifft: AW: Bestimmte Zeilen für Berechnung auswählen
von: Markus
Geschrieben am: 14.10.2015 09:52:53
hallo selli
Merci für den Input. Habe dank der Idee des summenprodukts gedanklich den Link zur folgenden Lösung geschafft. Ob das die Beste ist, sei dahingestellt, aber es funktioniert.
=(SUMMEWENN(C17:G26;A7;F17:F26)+SUMMEWENN(C17:G26;A7;G17:G26))-(SUMMEWENN(C17:G26;A7;E17:E26) +SUMMEWENN(C17:G26;A7;D17:D26))
Merci nochmals für die Hilfe.
Gruss
Markus

Bild

Betrifft: AW: Ergebnisse in den Monatsblättern ermitteln ...
von: ... neopa C
Geschrieben am: 14.10.2015 09:58:17
Hallo Markus,
... und diese dann in das Blatt "Zusammenstellung" holen, vereinfacht die Formelauswertung.
In den Monatsblättern in immer der gleichen Hilfszelle z.B. in H1 folgende Formel:

=RUNDEN(SUMMENPRODUKT(((C2:C19+D2:D19)-(A2:A19+B2:B19))*(E2:E19=Zusammenstellung!A$4))*24*60;2)

ergeben dann die Minuten als Dezimalzahl und diese in B4 des Blattes "Zusammenstellung" mit folgender Formel "holen": =INDIREKT("'Rohdaten "&B3&"'!H1") Formel einfach nach rechts kopieren.
Du kannst natürlich auch die Auswertung in die Formel B4 integrieren, die Formel strotzt dann jedoch vor jeder Menge INDIREKT()
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Bestimmte Zeilen für Berechnung auswählen"