Textteil aus Zelle und Summenprodukt/Summewenn

Bild

Betrifft: Textteil aus Zelle und Summenprodukt/Summewenn
von: oli.p
Geschrieben am: 21.10.2015 13:26:31

Hallo Zusammen,
da ich der Verzweifelung nahe bin, möchte ich Euch um Rat fragen.
Für einzelne Projekte möchte ich die Stunden und entsprechenden €-Werte summieren.
https://www.herber.de/bbs/user/100939.xls
Könntet Ihr mir helfen?
Vielen Dank und
Viele Grüße
oli.p

Bild

Betrifft: AW: Textteil aus Zelle und Summenprodukt/Summewenn
von: SF
Geschrieben am: 21.10.2015 13:30:08
Hola,
wenn du die Projekt Nummern in Spalte I ebenfalls mit einem Leerzeichen versiehst, dann so:
=SUMMEWENN($C$4:$C$13;"*"&I4&"*";$E$4:$E$13)
Gruß,
steve1da

Bild

Betrifft: AW: für alle XL-Versionen ...
von: ... neopa C
Geschrieben am: 21.10.2015 13:39:44
Hallo Oli,
... also auch Versionen vor XL2007, so: =WENN(I4="";"";SUMMENPRODUKT(ISTZAHL(FINDEN(WECHSELN(I4;"#";"# ");$C$2:$C$99))*D$2:D$99))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Textteil aus Zelle und Summenprodukt/Summewenn
von: oli.p
Geschrieben am: 21.10.2015 13:46:57
Hallo Werner,
das klappt eigentlich schon ganz gut.
Nur dass, Projekt #1 mit #1054 zusammengezogen wird. Wahrscheinlich weil die Suche nach dem Finden der "1" beendet wird?!
Hast Du noch einen Tip?
Danke und
VG
oli.p

Bild

Betrifft: AW: das hatte ich nicht bedacht, ...
von: ... neopa C
Geschrieben am: 21.10.2015 14:18:28
Hallo oli,
... muss ich natürlich allgemein (nicht nur für die 1) auch berücksichtigen.
Die Formel wird entsprechend länger:
=WENN(I4="";"";SUMMENPRODUKT(ISTZAHL(FINDEN(WECHSELN(I4;"#";"# ");$C$2:$C$99))*ISTFEHL(TEIL(C$2:C$99;FINDEN(WECHSELN(I4;"#";"# ");C$2:C$99)+LÄNGE(I4)+1;1)*1)*D$2:D$99))
Gruß Werner
.. , - ...

Bild

Betrifft: AW: das hatte ich nicht bedacht, ...
von: oli.p
Geschrieben am: 21.10.2015 14:41:01
Hallo Werner,
die Stunden stimmen bei mir. Nur die €-Werte nicht. Ich erhalte nur in der ersten Zeile den korrekten Wert (966). Die anderen sind 0?!
Woran könnte das liegen?
Danke und
VG
oli.p

Bild

Betrifft: AW: musst Du dazu nicht nur ...
von: ... neopa C
Geschrieben am: 21.10.2015 15:15:37
Hallo oli,
... die ermittelten Stunden mit den angegebenen Honorar multiplizieren?
Gruß Werner
.. , - ...


Bild

Betrifft: AW: musst Du dazu nicht nur ...
von: oli.p
Geschrieben am: 21.10.2015 15:34:40
Hallo Werner,
wenn unterschiedliche Anwälte daran arbeiten, kann es zu unterschiedlichen Stundensätzen kommen.
Das war in der Beispieltabelle nicht drin, das tut mir leid.
Was müsste ich an der Formel ändern damit es passt?
Danke und
VG
oli.p

Bild

Betrifft: AW: wenn es ein Stundensatz ist, dann ...
von: ... neopa C
Geschrieben am: 21.10.2015 15:42:10
Hallo oli,
... dann ist es für viele und erst Recht für mich, ein unerreichbarer Traumwert ;-) und Du musst trotzdem nur die Multiplikation vornehmen. Oder was meinst Du, wie die Werte dort ermittelt werden sollen?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: wenn es ein Stundensatz ist, dann ...
von: oli.p
Geschrieben am: 21.10.2015 15:49:57
Hallo Werner,
ich kann Dir versichern, dass ich jemals auch auch nur in die Nähe dieses Wertes gelangen werde. ;-)
Wäre es nicht möglich, analog zur Ausgabe der Stunden auch die €-Werte aus der jeweiligen Zeile, in der die Projektnr. vorkommt, auszugeben?
Danke und
VG
oli.p

Bild

Betrifft: AW: möglich ist alles ...
von: ... neopa C
Geschrieben am: 21.10.2015 16:14:53
Hallo oli,
... dazu müsstest Du ja nur die gleiche Formel nutzen wie in K4, nur da D$2:D$99 durch F$2:$99 ersetzen. Da kommt aber wirklich gleiche heraus, wie wenn Du in L4: =WENN(I4="";"";K4*E4) rechnen lässt.
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Datum wird falsch dargestellt"