Dynamischer Monat über Formel

Bild

Betrifft: Dynamischer Monat über Formel
von: Michael
Geschrieben am: 21.10.2015 13:49:38

Hallo zusammen,
bei einem Kalender der sich von links nach rechts erstreckt (1.1, 2.1....30.12, 31.12)
soll über den Datumszellen derm Monat eingetragen werden. Allerdings nur in der Zeile, über dem 1. des entsprechenden Monats.
Das ganze ist dynamisch gehalten, das heißt abhängig vom ausgewählten Jahr. Somit liegt der 1.1 nicht immer in der selben Zelle. Der Monatsname müßte also auch dynamisch generiert werden. Und das ganze bitte ohne VBA.
Ist das möglich?
Vielen Dank für eure Hilfe

Bild

Betrifft: AW: z.B. mit TAG() und TEXT() ...
von: ... neopa C
Geschrieben am: 21.10.2015 14:06:15
Hallo Michael,
... angenommen Dein Kalender beginnt in B2, dann einfach: =WENN(TAG(B2)=1;TEXT(B2;"MMMM");"")
und Formel nach rechts ziehend kopieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: z.B. mit TAG() und TEXT() ...
von: Michael
Geschrieben am: 21.10.2015 14:39:17
Hallo Werner,
funktioniert super, vielen Dank.
Leider schreibt er aber jetzt den Moat nicht ganz aus, da in der Nachbarzelle ja eine Formel steht.
Hättest du dafür auch eine Lösung?
Gruß Michael

Bild

Betrifft: AW: z.B. folgende Varianten im Angebot ...
von: ... neopa C
Geschrieben am: 21.10.2015 15:18:34
Hallo Michael,
... die erste wäre, Du erweiterst die Spaltenbreite . Die zweit wäre, Du schreibst den Monatstexttext vertikal und die dritte Du kürzt den Monatsnamen so: =WENN(TAG(B2)=1;TEXT(B2;"MMM");"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: z.B. folgende Varianten im Angebot ...
von: Michael
Geschrieben am: 21.10.2015 15:22:16
Hallo Werner,
vielen Dank, es wird wohl auf die dritte Variante hinauslaufen.
Gruß Michael

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Dynamischer Monat über Formel"