Summewenn() auf Abwegen...

Bild

Betrifft: Summewenn() auf Abwegen...
von: Clavis
Geschrieben am: 22.10.2015 14:41:47

Hallo zusammen!
Leider bin ich bei einem Problem mit meinem begrenzten Excel-Latein am Ende.
Ich habe zwei Zahlenreihen, bspw.
Zeile A: 0 0 10 40 30 0
Zeile B: 20 10 20 40 10 0
diese sollen spaltenweise jeweils miteinander verglichen werden; wenn in Zeile A ein Wert größer Null steht; dann sollen die jeweils kleineren Werte addiert und in einer Zelle ausgegeben werden (im Beispiel hier also 10+40+10 der 3-5. Spalte). Spalte 1 und 2 sollen ignoriert werden, da der Wert in Zeile A nicht größer Null ist.
Ich glaube, die Lösung ist ganz naheliegend, aber ich komme einfach nicht darauf! Vielen Dank für Eure Mühen und Lösungsvorschläge!

Bild

Betrifft: AW: z.B. mit SUMMENPRODUKT() ...
von: ... neopa C
Geschrieben am: 22.10.2015 14:53:58
Hallo Clavis,
... geht sicherlich eleganter, aber auf die Schnelle geht es so:

 ABCDEF
1001040300
220102040100
3      
460     

Formeln der Tabelle
ZelleFormel
A4=SUMMENPRODUKT((A1:F1>0)*((A1:F1<A2:F2)*A1:F1+(A2:F2<A1:F1)*A2:F2)+(A1:F1=A2:F2)*A1:F1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Bild

Betrifft: AW: z.B. mit SUMMENPRODUKT() ...
von: Clavis
Geschrieben am: 22.10.2015 15:07:00
Hallo Werner,
danke dir! Das reicht mir schon - ich wäre da nie drauf gekommen!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summewenn() auf Abwegen..."