Summenprodukt Bereichende aus anderer Zelle überne

Bild

Betrifft: Summenprodukt Bereichende aus anderer Zelle überne
von: Nick28
Geschrieben am: 24.10.2015 09:33:44

Guten Tag,
ich habe eine Statistiktabelle, in der mehrere Sachen per Summenprodukt ausgewertet werden. Leider habe ich den Auswertebereich zu klein gewählt, so dass ich jetzt ca. 1000 Formeln per Hand korrigieren muss. Dabei kam mir die Idee, den Endbereich als Zahl in einer anderen Zelle einzutragen, um etwaige weitere Änderungen schneller eintragen zu können. Als Beispiel die Formel, wie sie zur Zeit aussieht.
SUMMENPRODUKT((MONAT(Statistik!$B$2:$B$401)=1)*(Statistik!$V$2:$V$401="A-Stadt"))
Ist es möglich, statt des Endbereichs B401 einen Verweis auf eine andere Zelle in der Art zu machen B(=N1)? Die Formel gibt mir dann einen Fehler zurück.
Gruß
Ulf

Bild

Betrifft: =indirekt()
von: ransi
Geschrieben am: 24.10.2015 09:47:54
Hallo Nick,
Schau dir mal =indirekt() an.
Damit müsste das gehen.
ransi

Bild

Betrifft: AW: =indirekt()
von: Daniel
Geschrieben am: 24.10.2015 11:19:52
(Indirekt + Summenprodukt) * viele Formeln = keine gute Idee
Indirekt ist volatil, das bedeutet dass eine Formel die ein Indirekt enthält, bei JEDER Änderung in Excel neu berechnet wird. Normalerweise berechnet Excel eine Formel nur dann neu, wenn sich im referenzierten Zell Bereich eine Änderung ergibt, bei Formeln mit Indirekt ist das aber nicht sinnvoll.
Vorallem wenn das Indirekt mit Funktionen verbunden ist, die selber eine längere Berechnungszeit erfordern und in hoher Anzahl auftreten, wird durch die ständige Neubrechung das Arbeiten mit dieser Datei zur Geduldsprobe.
Besser ist das hier schon gezeigte INDEX, um den Zellbezug variabel zu gestalten.
INDIREKT wird nur benötigt, wenn das Tabellenblatt variabel sein soll per wenn auf verschiedene Namen referenziert werden muss, denn das kann Index nicht.
Gruß Daniel

Bild

Betrifft: AW: oder Index
von: hary
Geschrieben am: 24.10.2015 10:21:16
Moin
oder mit Index.
=SUMMENPRODUKT((MONAT(INDEX(Statistik!B:B;2):INDEX(Statistik!B:B;N1))=1)*(INDEX(Statistik!V:V;2) :INDEX(Statistik!V:V;N1)="A-Stadt"))
gruss hary

Bild

Betrifft: Danke für die Hinweise
von: Nick28
Geschrieben am: 27.10.2015 18:09:51
Danke für die Antworten. Werde ich mal ausprobieren. Da die Änderungen zu groß in den einzelnen Formeln sind, werde ich es jetzt wohl per Hand ändern. Da aber noch weitere Tabellen auf Erstellung warten, werde ich Eure / Ihre Tipps da definitiv ausprobieren und anwenden.
Ist schon toll was Excel alles könnte, wenn ich die jeweiligen Funktionen nur vorher genau und umfassend kennen würde.
Gruß
Ulf

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Summenprodukt Bereichende aus anderer Zelle überne"