Kalender

Bild

Betrifft: Kalender
von: Michael
Geschrieben am: 10.11.2015 10:02:51

Hallo Leute,
ich stehe etwas auf dem Schlauch.
Ich habe hier einen Datei, in der ich ein Kalenderjahr mit Wochenenden und Feiertagen abbilden möchte. Die bedingten Formatierungen ergeben sich später aus Urlaubs und Freizeittagen und spielen hier keine Rolle.
Was ich möchte, ist das sich die Tage abhängig vom Wochentag nach rechts verschieben.
Der 1. Februar wäre dann auf einen Montag, Der 1. März auf einen Dienstag usw.
Immer in Abhängigkeit vom ausgewählen Jahr. in diesem Fall 2016.
Das ganze sollte bitte nur mit Formeln und Funktionen zu lösen sein.
Danke schon mal für die Hilfe.
https://www.herber.de/bbs/user/101368.xlsx
LG Michael

Bild

Betrifft: AW: Kalender
von: Bernd
Geschrieben am: 10.11.2015 10:14:15
Hi,
also bzgl. Kalender gibt es sehr viele Beiträge, Recherche hilft eventuell weiter.
Überdies würde ich als Oberste Zeile nicht die Tage, sondern die Nummerierung 1-31 und darunter, im Bezug auf diese, die Wochentage verwenden.
Lasse den Beitrag aber dennoch offen.
mfg Bernd

Bild

Betrifft: AW: Kalender
von: Michael
Geschrieben am: 10.11.2015 10:33:14
Hallo Bernd,
1. Ich habe über die Recherche eben nichts gefunden.
2. Was ändert sich denn wenn ich die Nummerierung als Kopzeile habe? Das gleich Problem, nur andersrum...
LG Michael

Bild

Betrifft: AW: Kalender
von: Bernd
Geschrieben am: 10.11.2015 10:39:03
Hi,
hier mal ein Beispiel mit Feiertage (Ö):
https://www.herber.de/bbs/user/101371.xlsm
mfg Bernd

Bild

Betrifft: AW: Kalender
von: Michael
Geschrieben am: 10.11.2015 10:54:57
Ja, danke.
Genau das brauche ich nicht...
Trotzdem, hab Dank für deine Mühe.
LG Michael

Bild

Betrifft: AW: Kalender
von: Bernd
Geschrieben am: 10.11.2015 11:15:15
Hi Michael,
Nun stehe ich etwas auf dem Schlauch. Mir ist nicht klar was Du genau möchtest, eventuell
kommt ja ein andere User drauf.
mfg Bernd

Bild

Betrifft: Hinweis für Bernd
von: Matthias L
Geschrieben am: 10.11.2015 11:36:25
Hallo Bernd
In einigen Jahren Deines Kalenders erscheint der 01.03 bereits im Februar
Dies soll nur als Hinweis dienen, für den Fall das Du es noch nicht bemerkt hast
und es ändern möchtest.
Gruß Matthias

Bild

Betrifft: AW: @ Michael
von: Bernd
Geschrieben am: 10.11.2015 11:39:23
Hi Michi,
ja recht herzlichen Dank für Deine Info.
Ist aber deshalb nicht schlimm, da dieser Kalender eigentlich nur als Grundvorlage dient und ohnehin nicht zum Einsatz kommt.
mfg bernd

Bild

Betrifft: AW: Sorry, Matthias meinte ich - owT
von: Bernd
Geschrieben am: 10.11.2015 11:40:48


Bild

Betrifft: AW: Kalender
von: Bernd
Geschrieben am: 10.11.2015 11:32:22
Hi,
meinst Du so?
https://www.herber.de/forum/archiv/1032to1036/1033901_KALENDER.html
mfg bernd

Bild

Betrifft: AW: Kalender
von: Matthias L
Geschrieben am: 10.11.2015 12:05:20
Hallo
Da würde aber eine Spalte fehlen!
Urlaubsplan

 BCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAG
8 MiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFr
9Januar01020304050607080910111213141516171819202122232425262728293031
10Februar   01020304050607080910111213141516171819202122232425262728


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Denn 2020 gibts den 29.02.


Also Ansatz und nicht komplett durchgetestet
Urlaubsplan

 BCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAH
8 FrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMo
9Januar01020304050607080910111213141516171819202122232425262728293031 
10Februar   0102030405060708091011121314151617181920212223242526272829

Formeln der Tabelle
ZelleFormel
C8=C9
D8=C8+1
E8=D8+1
F8=E8+1
G8=F8+1
H8=G8+1
I8=H8+1
J8=I8+1
K8=J8+1
L8=K8+1
M8=L8+1
N8=M8+1
O8=N8+1
P8=O8+1
Q8=P8+1
R8=Q8+1
S8=R8+1
T8=S8+1
U8=T8+1
V8=U8+1
W8=V8+1
X8=W8+1
Y8=X8+1
Z8=Y8+1
AA8=Z8+1
AB8=AA8+1
AC8=AB8+1
AD8=AC8+1
AE8=AD8+1
AF8=AE8+1
AG8=AF8+1
AH8=AG8+1
B9=DATUM($B$1;ZEILE(B1);1)
C9=DATUM($B$1;ZEILE(B1);1)
D9=C9+1
E9=D9+1
F9=E9+1
G9=F9+1
H9=G9+1
I9=H9+1
J9=I9+1
K9=J9+1
L9=K9+1
M9=L9+1
N9=M9+1
O9=N9+1
P9=O9+1
Q9=P9+1
R9=Q9+1
S9=R9+1
T9=S9+1
U9=T9+1
V9=U9+1
W9=V9+1
X9=W9+1
Y9=X9+1
Z9=Y9+1
AA9=Z9+1
AB9=AA9+1
AC9=AB9+1
AD9=AC9+1
AE9=AD9+1
AF9=AE9+1
AG9=AF9+1
B10=DATUM($B$1;ZEILE(B2);1)
C10=WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(C9);AG9+1;"")
D10=WENN(C10<>"";C10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(D9);AH9+1;""))
E10=WENN(D10<>"";D10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(E9);AI9+1;""))
F10=WENN(E10<>"";E10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(F9);AJ9+1;""))
G10=WENN(F10<>"";F10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(G9);AK9+1;""))
H10=WENN(G10<>"";G10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(H9);AL9+1;""))
I10=WENN(H10<>"";H10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(I9);AM9+1;""))
J10=WENN(I10<>"";I10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(J9);AN9+1;""))
K10=WENN(J10<>"";J10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(K9);AO9+1;""))
L10=WENN(K10<>"";K10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(L9);AP9+1;""))
M10=WENN(L10<>"";L10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(M9);AQ9+1;""))
N10=WENN(M10<>"";M10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(N9);AR9+1;""))
O10=WENN(N10<>"";N10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(O9);AS9+1;""))
P10=WENN(O10<>"";O10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(P9);AT9+1;""))
Q10=WENN(P10<>"";P10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(Q9);AU9+1;""))
R10=WENN(Q10<>"";Q10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(R9);AV9+1;""))
S10=WENN(R10<>"";R10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(S9);AW9+1;""))
T10=WENN(S10<>"";S10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(T9);AX9+1;""))
U10=WENN(T10<>"";T10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(U9);AY9+1;""))
V10=WENN(U10<>"";U10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(V9);AZ9+1;""))
W10=WENN(V10<>"";V10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(W9);BA9+1;""))
X10=WENN(W10<>"";W10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(X9);BB9+1;""))
Y10=WENN(X10<>"";X10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(Y9);BC9+1;""))
Z10=WENN(Y10<>"";Y10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(Z9);BD9+1;""))
AA10=WENN(Z10<>"";Z10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AA9);BE9+1;""))
AB10=WENN(AA10<>"";AA10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AB9);BF9+1;""))
AC10=WENN(AB10<>"";AB10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AC9);BG9+1;""))
AD10=WENN(AC10<>"";AC10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AD9);BH9+1;""))
AE10=WENN(AD10<>"";AD10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AE9);BI9+1;""))
AF10=WENN(AE10<>"";AE10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AF9);BJ9+1;""))
AG10=WENN(AF10<>"";AF10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AG9);BK9+1;""))
AH10=WENN(AG10<>"";AG10+1;WENN(WOCHENTAG($AG$9+1)=WOCHENTAG(AH9);BL9+1;""))


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Matthias

Bild

Betrifft: Hast Du keinen Bedarf mehr ?
von: Matthias L
Geschrieben am: 12.11.2015 23:20:00
Hallo
Dann wäre es ja mal wieder für den Papierkorb geschrieben.
Tabelle1

 BCDEFGHIJKLMNOPQRSTUVWXYZAAABACADAEAFAGAHAIAJAKALAM
8 MoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDiMiDoFrSaSoMoDi
9Jan    01020304050607080910111213141516171819202122232425262728293031  
10Feb0102030405060708091011121314151617181920212223242526272829        
11Mrz 01020304050607080910111213141516171819202122232425262728293031     
12Apr    010203040506070809101112131415161718192021222324252627282930   
13Mai      01020304050607080910111213141516171819202122232425262728293031
14Jun  010203040506070809101112131415161718192021222324252627282930     
15Jul    01020304050607080910111213141516171819202122232425262728293031  
16Aug01020304050607080910111213141516171819202122232425262728293031      
17Sep   010203040506070809101112131415161718192021222324252627282930    
18Okt     01020304050607080910111213141516171819202122232425262728293031 
19Nov 010203040506070809101112131415161718192021222324252627282930      
20Dez   01020304050607080910111213141516171819202122232425262728293031   


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Du wolltest es doch so ? Oder ?
Gruß Matthias

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Kalender"