Falsche Ergebnisse bei Wenn-Dann Funktion mit ODER

Bild

Betrifft: Falsche Ergebnisse bei Wenn-Dann Funktion mit ODER
von: Albrecht Benzing
Geschrieben am: 15.11.2015 17:42:09

Hallo,
ich muss nochmal fragen... Hier meine Datei:
https://www.herber.de/bbs/user/101533.xlsx
Im Blatt "Productores" möchte ich, dass in Spalte Q eine Fehlermeldung erscheint, wenn ODER in B UND G ein positiver Wert steht, ODER in C UND H, ODER in D UND I, usw. Ich habe schon alles Mögliche probiert (siehe die diversen Formeln in Q), kriege aber immer entweder ein falsches Ergebnis, oder eine Fehlermeldung. Ich vermute, es hat mit der Formatierung der Bezugsspalten B:K zu tun, aber eigentlich sind sie als Zahlen formatiert. Ich habe es auch schon mit WERT(B3) statt "nur" B3 probiert, bringt auch nix.
Vielen Dank im Voraus!
Albrecht

Bild

Betrifft: AW: Falsche Ergebnisse bei Wenn-Dann Funktion mit ODER
von: Sepp
Geschrieben am: 15.11.2015 18:04:51
Hallo Albrecht,
so?
Productores

 BCDEFGHIJKQ
1Hectareas (cultivos a certificar,orgánico!)    Hectareas (cultivos a certificar, no orgánico!)    Producción paralela?
2Quinua BlancaQuinua MixtaQuinua Roja  Quinua BlancaQuinua MixtaQuinua Roja   
35,00    3,50    Prod. Paralela!
4           
5 3,00   2,20     
6           
7  1,00        

Formeln der Tabelle
ZelleFormel
Q3{=WENN((MIN(B3:F3*G3:K3)=0)*(B3:K3<>0); "Prod. Paralela!";"")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
Gruß Sepp


Bild

Betrifft: AW: Falsche Ergebnisse bei Wenn-Dann Funktion mit ODER
von: Sepp
Geschrieben am: 15.11.2015 18:37:55
Hallo Albrecht,
mein Fehler, war durch ein Telefongespräch abgelenkt, in der Sumenproduktformel, so wie Ransi schon angemerkt hat, "" durch 0 ersetzten.

Gruß Sepp


Bild

Betrifft: da ist grundsätzlich was faul
von: WF
Geschrieben am: 15.11.2015 18:09:28
Hi,
in Deiner Formel in Q4:
=WENN(ODER(B4*G4>0;C4*H4>0;D4*I4>0;E4*J4>0;F4*K4>0);"Prod. Paralela!";"")
der part B4*G4>0 ergibt FALSCH (ist ja OK)
die weiteren auch
ABER
E4*J4>0 ergibt nicht FALSCH oder WAHR sondern #WERT!
F4*K4>0 dito
Der Fehler liegt also in der Bezugstabelle. Den zu suchen hab ich keine Lust.
WF

Bild

Betrifft: AW: da ist grundsätzlich was faul
von: Albrecht Benzing
Geschrieben am: 15.11.2015 18:29:56
Erst mal Danke für die rasche Rückmeldung!
Sepp - irgendwie verhext: ich kopiere deine Formel in meine Datei, mit Matrix und allem drum und dran, trotzdem kommt die #WERT! Fehlermeldung... Woran kann das liegen?
Albrecht

Bild

Betrifft: mein Fehler!
von: Sepp
Geschrieben am: 15.11.2015 18:38:50
Hallo Albrecht,
siehe hier: https://www.herber.de/forum/messages/1458537.html

Gruß Sepp


Bild

Betrifft: AW: Falsche Ergebnisse bei Wenn-Dann Funktion mit ODER
von: ransi
Geschrieben am: 15.11.2015 18:11:32
Hallo Albrecht
Deine =wenn(oder()) funktioniert.
Du musst dazu allerdings die =Summenprodukt() in B:K geringfügig ändern.
Productores

 BCDEFGHIJKQ
35,00    3,50    Prod. Paralela!
4           
5 3,00   2,20     
6           
7  1,00        
8           

Formeln der Tabelle
ZelleFormel
B3=WENN(B$2=0;0;SUMMENPRODUKT((Parcelas!$A$3:$A$499=Productores!$A3)*(INDEX(Parcelas!$G$3:$AE$499;;VERGLEICH($A$1;Parcelas!$G$1:$AE$1;0))=Productores!B$2)*(INDEX(Parcelas!$G$3:$AE$499;;VERGLEICH($A$1;Parcelas!$G$1:$AE$1;0)+1)="Org")*INDEX(Parcelas!$G$3:$AE$499;;VERGLEICH($A$1;Parcelas!$G$1:$AE$1;0)+2)))


Productores

 G
33,50

Formeln der Tabelle
ZelleFormel
G3=WENN(G$2=0;0;SUMMENPRODUKT((Parcelas!$A$3:$A$499=Productores!$A3)*(INDEX(Parcelas!$G$3:$AE$499;;VERGLEICH($A$1;Parcelas!$G$1:$AE$1;0))=Productores!G$2)*(INDEX(Parcelas!$G$3:$AE$499;;VERGLEICH($A$1;Parcelas!$G$1:$AE$1;0)+1)<>"Org")*INDEX(Parcelas!$G$3:$AE$499;;VERGLEICH($A$1;Parcelas!$G$1:$AE$1;0)+2)))


Productores

 Q
3Prod. Paralela!

Formeln der Tabelle
ZelleFormel
Q3=WENN(ODER(B3*G3>0;C3*H3>0;D3*I3>0;E3*J3>0;F3*K3>0); "Prod. Paralela!";"")


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
ransi

Bild

Betrifft: AW: Falsche Ergebnisse bei Wenn-Dann Funktion mit ODER
von: Albrecht Benzing
Geschrieben am: 15.11.2015 18:45:04
Herzlichen Dank, Ransi! So einfach, da hätte ich auch... naja!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Falsche Ergebnisse bei Wenn-Dann Funktion mit ODER"