Zählen/ summewenn

Bild

Betrifft: Zählen/ summewenn
von: Daniel
Geschrieben am: 01.12.2015 08:25:03

Moin, moin!
Ich habe da mal eine Frage zu folgender Tabelle:
https://www.herber.de/bbs/user/101923.xlsx
Ich möchte gerne wissen, wie viele Artikel je WG ein OK bzw Ertrag kleiner als 50 in Spalte F stehen haben.
Die Spalten H und J habe ich mit summewenn gemacht (dafür die Spalte G und I mit der 1).
Ich kenne zwar Wege um das hinzubekommen, allerdings hätte ich hier gern lediglich Formel eingegeben :)
Ich hoffe, Ihr könnt mir helfen. Ich denke, man muss hier Formeln kombinieren, oder?
Danke schon mal und Gruß,
Daniel

Bild

Betrifft: AW: auch nach den zweiten Lesen ...
von: neopa C
Geschrieben am: 01.12.2015 08:41:08
Hallo Daniel,
... ist für mich nicht eindeutig, was Du in Spalte G bis J mit SUMMEWENN() "gemacht" hast und zwar auf welcher Datenbasis was Du jetzt anstrebst.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: auch nach den zweiten Lesen ...
von: Daniel
Geschrieben am: 01.12.2015 08:57:01
Hallo Werner,
ich habe mit den "Einsen" die Spalte H und J errechnet.
Also in (Spalte H) die Summe/ Anzahl der Artikel in WG und in Spalte J
die Summe/ Anzahl aller Artikel mit "OK" bzw. "Ertrag unter 50".
Jetzt benötige ich die Summe der Artikel mit "OK" und "Ertrag unter 50" je WG.
Ich hoffe, ich habe es jetzt richtig beschrieben.
Die Beschreibung ist immer nicht ganz so einfach, da man selbst ja quasi weiß, was gemeint ist ;)
SORRY!
Gruß,
Daniel

Bild

Betrifft: AW: stell noch mal Deine Datei ein ...
von: neopa C
Geschrieben am: 01.12.2015 09:05:16
Hallo Daniel,
... diesmal aber mit Deinen Formeln und zusätzlich zwei oder drei von Dir von Hand ermittelten Endergebnisse.
Vielleicht verstehe ich dann dein Anliegen besser.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: stell noch mal Deine Datei ein ...
von: Daniel
Geschrieben am: 01.12.2015 09:17:31
Hallo Werner,
anbei die Liste mit Formeln und die Spalte K sollte eine schöne Formel bekommen :)
https://www.herber.de/bbs/user/101924.xlsx
Gruß,
Daniel

Bild

Betrifft: AW: ist wohl ein "Adventskalender" ;-) ...
von: neopa C
Geschrieben am: 01.12.2015 09:31:26
Hallo Daniel,
... nachdem Du nun mir die "Tür" für die Werte in Spalte H und J geöffnet hast, wäre es schön, wenn Du mir den "Schlüssel" für Werte in Spalte K eindeutig beschreibst.
Ich finde für Deine vorgegebenen "Ergebniswerte" bestenfalls einen "Teilschlüssel" für K2:K4 aber der ist dann nicht kompatibel zu K5:K15. Wieso dort überall 11?
Gruß Werner
.. , - ...

Bild

Betrifft: AW: ist wohl ein "Adventskalender" ;-) ...
von: Daniel
Geschrieben am: 01.12.2015 09:42:04
Hi Werner,
zu Spalte K:
K2:K3
"2" Weil WG gleich und 2* OK
K4
"1" Weil WG gleich und 1* "Ertrag unter 50"
UUPS Fehler in K5:K15
K5:K9 muss 6 sein
K10:K15 muss 5 sein.
Passiert nur, wenn man per Hand arbeitet *grins
Sorry nochmal!
Gruß,
Daniel
"11" Weil WG gleich und

Bild

Betrifft: AW: ist wohl ein "Adventskalender" ;-) ...
von: Daniel
Geschrieben am: 01.12.2015 09:44:05
Test unter Gruß ""11" Weil WG gleich und" bitte ignorieren!

Bild

Betrifft: AW: jetzt sind alle "Türchen" offen ;-) ...
von: neopa C
Geschrieben am: 01.12.2015 09:46:48
Hallo Daniel,
... in K2: =WENN(D2="";"";SUMMENPRODUKT((D$2:D$99=D2)*(F$2:F$99=F2))) und ziehend nach unten kopieren.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: jetzt sind alle "Türchen" offen ;-) ...
von: Daniel
Geschrieben am: 01.12.2015 09:59:53
Hallo Werner!
Vielen, vielen Dank!
Auf diese Formel mit SUMMENPRODUKT wäre ich nie gekommen.
Find ich geil :)
Hatte ich noch nie vorher gehört. /grins.
Gruß und schöne Woche,
Daniel

Bild

Betrifft: AW: Zählen/ summewenn
von: Werner
Geschrieben am: 01.12.2015 11:36:43
Hallo Daniel,
du willst doch für die einzelnen Warengruppen wissen, wie oft OK bzw. kleiner 50 erfasst ist. So wie deine Tabelle jetzt aufgebaut ist wäre das für mich ziemlich unübersichtlich (wobei ich natürlich nicht weiß ob du das genau so brauchst).
Ich hab mal ein wenig gespielt. In Bezug auf deine Beispiel Mappe Spalte L und M.
L1: Überschrift Warengruppen
M1: Überschrift Summe OK / kleiner 50
Formel in L2:=MIN(D:D)
Formel in L3:=WENN(MAX(D:D)=MAX(L$2:L2);"";KGRÖSSTE(D:D;ZÄHLENWENN(D:D;">"&L2)))
Formel in L3 nach unten kopieren so weit wie du es brauchst. Listet die die Warengruppen aus Spalte D untereinander auf.
Formel in M2:=WENN(L2="";"";SUMMENPRODUKT(($D$2:$D$1000=$L2)*($F$2:$F$1000="Ertrag<50")+($D$2:$D$1000=$L2)*($F$2:$F$1000="ok")))
So weit nach unten kopieren wie du es brauchst.
Gibt dir die Summe OK/<50 für die jeweilige Warengruppe aus Spalte M aus.
Gruß Werner

Bild

Betrifft: AW: Zählen/ summewenn
von: Daniel
Geschrieben am: 01.12.2015 12:28:58
Hallo Werner,
ich benötige ja aber die Summe je Warengruppe von OK und kleiner als 50.
So habe ich ja nur die Summe insgesammt von OK und kleiner als 50 je WG
Gruß,
Daniel

Bild

Betrifft: AW: Zählen/ summewenn
von: Werner
Geschrieben am: 01.12.2015 12:55:03
Hallo Daniel,
keine Ahnung was du meinst. Ausprobiert hast du es wohl nicht. Für deine Beispiel Tabelle steht dann in L3 die Warengruppe 1 und in M3 die Summe OK bzw. kleiner 50 für Warengruppe 1, für dein Beispiel ist das Ergebnis 3. Das gleiche für Warengruppe 2 in L4, Ergebnis in M4 gleich 11.
Gruß Werner

Bild

Betrifft: AW: Zählen/ summewenn
von: Daniel
Geschrieben am: 01.12.2015 13:17:37
Hallo Werner,
selbstverständlich habe ich es ausprobiert...
Doch es geht mir ja um das Ergebnis in der Spalte K !!!
Das Ergebnis Deiner Formel zeigt mir das Ergebnis aus der Spalte H, richtig?
Von der Sache her, ist es super! Aber wie lautet die Formel für das Ergebnis, welches in Spalte K zu finde ist?
Gruß,
Daniel


Bild

Betrifft: AW: Zählen/ summewenn
von: Werner
Geschrieben am: 01.12.2015 13:36:46
Hallo Daniel,
die Formeln in Spalte L listet dir deine einzelnen Warengruppen aus Spalte D untereinander auf.
Die Formel in Spalte M bildet dann die Summe von OK/kleiner 50 aus Spalte F für die jeweilige Warengruppe. Die Formel hat weder etwas mit der Spalte K noch mit der Spalte H zu tun.
Nimm doch einfach mal bei deiner Beispiel Tabelle ein OK aus Spalte F raus, oder ändere mal einen Eintrag der Warengruppe in Spalte D von Warengruppe 2 auf Warengruppe 1 und schau dir dann das Ergebnis an.
Gruß Werner

Bild

Betrifft: AW: Zählen/ summewenn
von: Daniel
Geschrieben am: 01.12.2015 13:38:39
Hi Werner,
schau mal bitte hier:
https://www.herber.de/bbs/user/101934.xlsx
Dort habe ich mal in schwarzer Schrift eingebaut,
wie es dort (natürlich gerne mit Formeln) stehen sollte.
[blau ist die "alte" Liste auch mit Deinen Formeln]
Gruß,
Daniel

Bild

Betrifft: AW: Zählen/ summewenn
von: Werner
Geschrieben am: 01.12.2015 14:04:28
Hallo Daniel,
davon war zunächst aber nicht die Rede, dass du pro Warengruppe die Summe von OK und kleiner 50 getrennt ausgewiesen haben wolltest. Dann hält so:
Formel in N2:=MIN($D:$D)
Formel in N3:=WENN(MAX($D:$D)=MAX(N$2:N2);"";KGRÖSSTE($D:$D;ZÄHLENWENN($D:$D;">"&N2)))
N3 nach unten kopieren so weit wie du es brauchst.
Formel in O2:=WENN(N2="";"";SUMMENPRODUKT(($D$2:$D$1000=$L2)*($F$2:$F$1000="ok")))
O2 nach unten kopieren so weit wie du es brauchst.
Formel in P2:=WENN(O2="";"";SUMMENPRODUKT(($D$2:$D$1000=$L2)*($F$2:$F$1000="Ertrag<50")))
P2 nach unten kopieren so weit wie du es brauchst.
Gruß Werner

Bild

Betrifft: AW: Zählen/ summewenn
von: Daniel
Geschrieben am: 01.12.2015 14:42:12
https://www.herber.de/bbs/user/101936.xlsx
Abei noch mal markiert...

Bild

Betrifft: AW: Zählen/ summewenn
von: Daniel
Geschrieben am: 01.12.2015 14:53:03
Hallo Werner,
sorry, wenn wir aneinander vorbei gesprochen haben....
Aber Deine Formel ist jetzt genau DAS, wonach ich gesucht habe :)
Ich hatte mir den Rest halt mühsam (anders) zusammengespielt.
DANKE!!!!!!
Gruß,
Daniel

Bild

Betrifft: AW: dann auch eine PIVOTauswertung sinnvoll ...
von: neopa C
Geschrieben am: 01.12.2015 15:17:42
Hallo Daniel,
... da bräuchtest Du dafür nur wenige Mausklicks auszuführen.
Gruß Werner
.. , - ...

Bild

Betrifft: AW: dann auch eine PIVOTauswertung sinnvoll ...
von: Daniel
Geschrieben am: 01.12.2015 15:19:15
Japp... Das haben wir schon gemacht. Sollte aber per Formel ;)
DANKE!!!!

Bild

Betrifft: AW: Danke für die Rückmeldung.
von: Werner
Geschrieben am: 01.12.2015 15:21:35
Hallo Daniel,
hat zwar etwas gedauert aber jetzt passt es ja.
Gruß Werner

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zählen/ summewenn"