Zeile so häufig wie Wert in Zelle kopieren

Bild

Betrifft: Zeile so häufig wie Wert in Zelle kopieren
von: Tim
Geschrieben am: 01.12.2015 11:42:41

Hallo,
ich habe ein Problem, ich hoffe es kann ohne VBA gelöst werden, da ich damit leider noch vollkommen unerfahren bin.
Im Archiv habe ich leider nichts vergleichbares gefunden, bzw. wusste nicht wonach ich konkret hätte suchen können.
Folgende Sachlage:
In einer Spalte (B) habe ich verschiedene einstellige Zahlen stehen.
Ich hätte jetzt gerne, wenn in der Zelle z.B. eine 7 steht, diese Zeile 6 mal unter diese Zeile kopiert. Die unteren Zeilen verschieben sich dann nach unten und es geht mit der nächsten Zahl weiter. Also quasi:
von:
A B
1 7
2 6
8 3
zu:
A B
1 7
1 7
1 7
1 7
1 7
1 7
1 7
2 6
2 6
2 6
2 6
2 6
2 6
8 3
8 3
8 3
Es handelt sich zwar "nur" um 160 Zeilen, was man also auch manuell lösen könnte, aber per Formel und ggf. auch für die Zukunft wäre doch eine automatische Lösung wünschenswert.
Gibt es da einen möglichen Lösungsansatz.
Vielen Dank.
Tim

Bild

Betrifft: AW: Zeile so häufig wie Wert in Zelle kopieren
von: Rudi Maintaire
Geschrieben am: 01.12.2015 11:47:48
Hallo,

ABCDE
117 17
226 17
383 17
4   17
5   17
6   17
7   17
8   26
9   26

ZelleFormel
D1=A1
E1=B1
D2=WENN(ZÄHLENWENN(D$1:D1;D1)=E1;INDEX(A:A;VERGLEICH(D1;A:A;)+1);D1)
E2=WENN(ZÄHLENWENN(D$1:D1;D1)=E1;INDEX(B:B;VERGLEICH(D1;A:A;)+1);E1)

Gruß
Rudi

Bild

Betrifft: AW: Zeile so häufig wie Wert in Zelle kopieren
von: Tim
Geschrieben am: 01.12.2015 12:42:50
Wow, vielen Dank. Perfekt.

Bild

Betrifft: AW: eine (mE einfachere) Alternative wäre ...
von: neopa C
Geschrieben am: 01.12.2015 15:24:24
Hallo Tim,
... die Eingabe der 0 in der Hilfsspalte ist Pflicht, die beiden Formeln jeweils entsprechend weit nach unten ziehend kopieren:

 ABCDEFGH
117 1   0
226 1   7
383 1   13
4   1   16
5   1    
6   1    
7   1    
8   2    
9   2    
10   2    
11   2    
12   2    
13   2    
14   8    
15   8    
16   8    
17        

Formeln der Tabelle
ZelleFormel
D1=WENN(ZEILE(H1)>MAX(H:H); "";INDEX(A:A;VERGLEICH(ZEILE(A1)-1;H:H)))
H2=WENN(B1="";"";B1+H1)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zeile so häufig wie Wert in Zelle kopieren"