Zellbezug mit Formel versehen

Bild

Betrifft: Zellbezug mit Formel versehen
von: Manuel
Geschrieben am: 01.12.2015 11:55:55

Hallo zusammen, ich stehe gerade etwas auf dem Schlauch und brauche eure Hilfe.
Ich habe in Zelle G2 eine Formel , die mir einen Faktor ausrechnen soll, die Formel lautet:
=WENNFEHLER(WENN(E2=1;1;E2/$F$2);"")
Das Problem daran ist, die Liste ist endlos lang, und der Teil "$F$2" muss sich alle 12 Zeilen ändern, da wir etwas auf Produktbasis als Bezug nehmen (Quasi einen ganzjahreswert). Ist aber auch inhaltlich relativ egal.
Es geht mir darum die Zahl "2" im Ausdruck "$F$2" durch eine Formel zu ersetzen, diese lautet: =GANZZAHL(((ZEILE()-1,0001)/12))*12+2
Aber ich bekomme es nicht hin, die Formel quasi in der Formel zu verketten, also so ein änliches Konstrukt zu basteln wie:
=WENNFEHLER(WENN(E2=1;1;E2/$F$&GANZZAHL(((ZEILE()-1,0001)/12))*12+2);"")
Die Beatles würden sagen: Help! I need somebody help...

Bild

Betrifft: AW: Zellbezug mit Formel versehen
von: Rudi Maintaire
Geschrieben am: 01.12.2015 12:01:56
Hallo,
=WENNFEHLER(WENN(E2=1;1;E2/index(f:f;GANZZAHL(((ZEILE()-1,0001)/12))*12+2));"")
Gruß
Rudi

Bild

Betrifft: AW: mit INDEX() ...
von: neopa C
Geschrieben am: 01.12.2015 12:02:26
Hallo Manuel,
.. so: =WENNFEHLER(WENN(E2=1;1;E2/INDEX(F:F;(ZEILE(A1)-1)*12+2));"")
Gruß Werner
.. , - ...

Bild

Betrifft: AW: Zellbezug mit Formel versehen
von: Manuel
Geschrieben am: 01.12.2015 12:14:24
Oh mein Gott, natürlich :facepalm:
Die Firma dankt!

 Bild

Beiträge aus den Excel-Beispielen zum Thema "Zellbezug mit Formel versehen"