Microsoft Excel

Herbers Excel/VBA-Archiv

Hilfe bei Formel

Betrifft: Hilfe bei Formel von: Michael
Geschrieben am: 07.12.2015 14:46:48

Hallo,

folgendes Problem. Ich möchte wenn ein Feld leer ist den Durchschnitt der letzten 3 Zellen in der gleichen Zeile berechnen.

für eine Zelle ist das kein Problem, da rechne ich einfach:

=Wenn(G2="",Mittelwert(D2:F2),"")
Was ich als Formel suche ist jedoch eher in Richtung verschachtelte Wenn Formel:

=Wenn(G2="",Mittelwert(D2:F2),Wenn H2="",Mittelwert(E2:G2), Wenn (I2="",Mittelwert(F2:H2) usw.

Das ganze bis N2 ="" dann Mittelwert(der drei Zellen davor)

Ich hoffe ich hab mich einigermaßen verständlich ausgedrückt.

Gruß
Michael

  

Betrifft: AW: mit Hilfe von INDEX() und AGGREGAT() ... von: neopa C
Geschrieben am: 07.12.2015 15:03:52

Hallo Michael,

... nachfolgend setze ich voraus, dass Du immer genau drei vorhandene benachbarte Zahlen auswerten willst. Wenn nicht, müsstest Du Dich noch mal melden.

Dann so: =MITTELWERT(INDEX(2:2;MAX(4;(AGGREGAT(15;6;SPALTE(D2:N2)/(D2:N2="");1)-3))):INDEX(2:2;AGGREGAT(15;6;SPALTE(D2:N2)/(D2:N2="");1)-1))


Gruß Werner
.. , - ...


  

Betrifft: AW: ohne die von mir benannte Bedingung ... von: neopa C
Geschrieben am: 07.12.2015 15:09:34

Hallo nochmal,

... richtiger so: =WENNFEHLER(MITTELWERT(INDEX(2:2;AGGREGAT(15;6;SPALTE(G2:N2)/(G2:N2="");1)-3):INDEX(2:2;AGGREGAT(15;6;SPALTE(G2:N2)/(G2:N2="");1)-1));"")

Gruß Werner
.. , - ...


  

Betrifft: AW: ohne die von mir benannte Bedingung ... von: Michael
Geschrieben am: 07.12.2015 15:20:09

Hallo Werner,

ich hab mal eine Beispieldatei angehängt. Wie müsste ich die Formel anpassen wenn ich von einem Tab auf das andere zugreifen will.

Die Rechnung soll in 'Rechnung' statt finden und am Besten sich auf die ID in Test beziehen. Muss aber nicht zwingend.

Vielleicht kannst du mir nochmal kurz erläutern wie das funktionieren könnte.

Gruß
Michael

https://www.herber.de/bbs/user/102066.xlsx


  

Betrifft: AW: dann noch mit den Datentabellenblattnamen ... von: neopa C
Geschrieben am: 07.12.2015 15:28:21

Hallo Michael,

... in Rechnung!E2:

=WENNFEHLER(MITTELWERT(INDEX(Test!2:2;AGGREGAT(15;6;SPALTE(G2:N2)/(Test!G2:N2="");1)-3):INDEX(Test!2:2;AGGREGAT(15;6;SPALTE(G2:N2)/(Test!G2:N2="");1)-1));"")

damit ergibt sich für ID2 kein Wert, weil in D2:F2 nichts steht.

Gruß Werner
.. , - ...


  

Betrifft: AW: dann noch mit den Datentabellenblattnamen ... von: Michael
Geschrieben am: 07.12.2015 15:49:37

Vielen Dank Werner,

scheint zu funktionieren!


  

Betrifft: AW: "scheint" der Mond durchs offene Fenster? owT von: neopa C
Geschrieben am: 07.12.2015 15:59:56

Gruß Werner
.. , - ...


  

Betrifft: AW: dann noch mit den Datentabellenblattnamen ... von: Michael
Geschrieben am: 07.12.2015 16:03:24

Eine Frage hätte ich da noch.

Es scheint das die Formel immer nur G2:N2 berechnet. Ist das so richtig?

Eine kurze Erklärung was genau die Formel macht wäre hilfreich um den Rechenweg zu verstehen.

Danke und Gruß
Michael


  

Betrifft: AW: Formel berechnet nach Deiner Vorgabe ... von: neopa C
Geschrieben am: 07.12.2015 16:33:54

Hallo Michael,

... und zwar immer nur der Mittelwert der letzten (max)drei Zahlen vor der ersten Leerzelle, die beginnend ab Spalte G gesucht wird. Deswegen ergibt sich für ID ein ="", weil der erste Wert in I3 nach der Leerzelle in G3 kommt. In Zeile 15 steht in der Datentabelle in J15 die erste Leerzelle, demzufolge ergibt sich da der Mittelwert aus Test!G15:I15

Gruß Werner
.. , - ...


  

Betrifft: AW: Formel berechnet nach Deiner Vorgabe ... von: Michael
Geschrieben am: 08.12.2015 07:51:45

Danke Werner!


  

Betrifft: AW: Hilfe bei Formel von: Rudi Maintaire
Geschrieben am: 07.12.2015 15:07:39

Hallo,
wenn ab D lückenlos gefüllt:
=MITTELWERT(INDEX(D2:N2;ANZAHL(D2:N2)):INDEX(D2:N2;ANZAHL(D2:N2=-2)))

Gruß
Rudi


  

Betrifft: AW: Hilfe bei Formel von: Michael
Geschrieben am: 07.12.2015 15:50:22

Hallo Rudi,

Danke für deine Mühe. Ich schau mir gleich deinen Lösungsweg an.

Gruß


 

Beiträge aus den Excel-Beispielen zum Thema "Hilfe bei Formel"