Live-Forum - Die aktuellen Beiträge
Anzeige
Archiv - Navigation
1472to1476
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Pivot Tabelle - Datum ohne Duplikate zählen

Pivot Tabelle - Datum ohne Duplikate zählen
02.02.2016 17:02:46
Ramona
Hallo Zusammen,
ich wollte die Stundenaufzeichnungen aus dem letzten Monat auswerten, dazu habe ich mir aus den Daten eine Pivot Tabelle erstellt.
Nur das Problem ist, das einige Datumsangaben doppelt vorkommen und "Anzahl von Date" (siehe Beispieldatei) die Duplikate mitzählt. Gibt es eine Möglichkeit dies zu ermöglichen?
https://www.herber.de/bbs/user/103233.xlsx

9
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Pivot Tabelle - Datum ohne Duplikate zählen
02.02.2016 17:15:02
Daniel
Hi
eine Möglichkeit wäre:
1. füge auf Page1 eine weitere Spalte ein mit der Formel: =1/SummeWenns(A:A;A2;B:B;B2;C:C;C2)
(die Formel ist für Zeile2 und muss bis ans Datenende gezogen werden.)
2. Summiere in der Pivot-Auswertung dann diese neue Spalte.
Gruß Daniel

AW: Pivot Tabelle - Datum ohne Duplikate zählen
03.02.2016 08:08:21
Ramona
Vielen Dank Daniel - allerdings wenn ich die Formel so übernehme heißt es: "Sie haben zu wenig Argumente"
Liebe Grüße
Ramona

AW: Pivot Tabelle - Datum ohne Duplikate zählen
03.02.2016 08:13:37
Ramona
Vielen Dank Daniel - allerdings wenn ich die Formel so übernehme heißt es: "Sie haben zu wenig Argumente"
Liebe Grüße
Ramona

Anzeige
AW: Pivot Tabelle - Datum ohne Duplikate zählen
03.02.2016 09:06:36
Daniel
Sorry, hab die Falsche Funktion verwendet.
Nimm mal ZählenWenns.
Gruß Daniel

AW: dürfte mE nicht notwendig sein, denn .....
02.02.2016 17:47:29
...
Hallo Ramona,
... Deine Auswertung zeigt mir, dass die Datenerfassung zumindest teilweise sehr zweifelhaft ist.
Konkretes Beispiel: Die Person 6 hat am 18.01. einmal 9,25 und einmal 8,75 Stunden erfasst. Das kann so nicht richtig sein. Das kannst aber nur Du hinterfragen. Entweder ist eins von den beiden Zeiten zu einem anderen Datum erfolgt oder es wurde generell eine Falschangabe gemacht.
Analog müsstest Du das mE Fall für Fall für alle "Duplikate" untersuchen. Dazu in einer Hilfsspalte von "Page 1" folgende Formel (ab der zweiten Zeile): =ZÄHLENWENNS(A:A;A2;B:B;B2;C:C;C2) und dann in dieser Spalte nach Werten größer 1 filtern.
Gruß Werner
.. , - ...

Anzeige
AW: dürfte mE nicht notwendig sein, denn .....
03.02.2016 08:17:47
Ramona
Hallo Werner,
danke für deine Hilfe. Die Datenerfassung ist richtig, es hat sich scheinbar nur beim Ersetzen der Namen ein Fehler eingeschlichen.
Wenn ich deine Formel benutze - bekomme ich in jeder Zeile das Ergebnis Null :(
Liebe Grüße
Ramona

AW: dürfte mE nicht notwendig sein, denn .....
03.02.2016 08:18:12
Ramona
Hallo Werner,
danke für deine Hilfe. Die Datenerfassung ist richtig, es hat sich scheinbar nur beim Ersetzen der Namen ein Fehler eingeschlichen.
Wenn ich deine Formel benutze - bekomme ich in jeder Zeile das Ergebnis Null :(
Liebe Grüße
Ramona

AW: wie auch immer die Daten erfasst sind ...
03.02.2016 08:32:18
...
Hallo Ramona,
... nach wie vor bin ich der Meinung, wenn es auch nach Verknüpfung der Datenwerte der Spalten A:C noch "Duplikate" gibt (Wert in der Hilfsspalte, hier Spalte I größer 1), dann müssten diese Daten zumindest zunächst nochmal geprüft werden.
Deine Feststellung zu der Formel kann ich nicht bestätigen. Sieh mal (Formel ist nach unten kopieren);
Page 1

 ABCEI
22016-01-04person 4INT_TWX5,001
32016-01-04person 8INT_TWC0044,001
242016-01-11person 2INT_TWA_WIN2,002
252016-01-11person 1INT_TWC0048,251
262016-01-11person 6INT_TWX9,251
272016-01-11person 5INT_TWC0047,002
282016-01-11person 4INT_TWX5,001
292016-01-11person 5INT_TWC0041,002
302016-01-11person 2INT_TWC_EMP4,751
312016-01-11person 2INT_TWA_WIN8,502
322016-01-11person 8INT_TWA_WIN4,001
332016-01-12person 2INT_TWC_EMP1,501
342016-01-12person 2INT_TWA_WIN8,752
352016-01-12person 5INT_TWC0048,501
362016-01-12person 1INT_TWC0048,751
372016-01-12person 3INT_TWF4,501
382016-01-12person 6INT_TWX8,751
392016-01-12person 8INT_TWC0042,001
402016-01-12person 2INT_TWA_WIN6,002
412016-01-12person 4INT_TWX8,001

Formeln der Tabelle
ZelleFormel
I2=ZÄHLENWENNS(A:A;A2;B:B;B2;C:C;C2)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4
Gruß Werner
.. , - ...

Anzeige
AW: wie auch immer die Daten erfasst sind ...
03.02.2016 08:41:42
Ramona
super vielen Dank - hatte die Formel nicht am Ende.
So funktioniert es wie ich es mir vorgestellt habe - Danke!
Gruß
Ramona

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige