Microsoft Excel

Herbers Excel/VBA-Archiv

Zusammenführen mit Zählenwenn

Betrifft: Zusammenführen mit Zählenwenn von: Manfred
Geschrieben am: 16.03.2016 09:36:09

Hallo zusammen,

habe ein Formelproblem.

Ich möchte in das Tabellenblatt AKTION ab dem 7 Tabellenblatt alles zusammenführen. Die Tabellenblattnamen werden nach und nach unterschiedlich bezeichnet. Insgesamt sind es ca. 26-40 Tabellenblätter.
Die Formel =INDIREKT("'" &INDEX(x;ZEILE(A7))&"'!c7") benutze ich jetzt auch und ziehe sie nach unten. Das funktioniert auch super.

Die jetzige Formel heißt =ZÄHLENWENN('A1'!$A$33:$B$42;“Manni")

Ist das mit der =ZÄHLENWENN auch möglich ?

Mit freundlichen Grüßen
Manfred

  

Betrifft: AW: im Prinzip schon ... von: ... neopa C
Geschrieben am: 16.03.2016 09:50:24

Hallo Manfred,

... ungetestet, wenn die Tabellenblattnamen in A1:A## stehen und immer der gleiche Bereich auszuwerten ist, dann versuch mal: =ZÄHLENWENN(INDIREKT("'"&A1&"'"&"!A33:B42");“Manni") und Formel nach unten ziehen

Gruß Werner
.. , - ...


  

Betrifft: AW: im Prinzip schon ... von: Manfred
Geschrieben am: 16.03.2016 12:11:15

Hallo Werner,

bekomme #Bezug! zurück.
Habe keine Hilfsspalte mit Tabellenblattnamen.

Geht das auch direkt ab dem 7 Tabellenblatt ?

Gruß
Manfred


  

Betrifft: AW: ist abhängig davon was in A1 steht ... von: ... neopa C
Geschrieben am: 16.03.2016 12:26:22

Hallo Manfred,

... was steht denn bei Dir in A1? Da sollte dann der Name des 7. Tabellenblattes stehen oder Deine Formel beginnt eben mit A7 statt A1.

Aber wie geschrieben, ausgetestet habe ich es noch nicht. Wenn immer noch der Fehler kommt, dann würde ich es tun.


Gruß Werner
.. , - ...


  

Betrifft: AW: im Prinzip schon ... von: Manfred
Geschrieben am: 16.03.2016 12:41:26

Hallo Werner,

da liegt ein Missverständnis vor.

=INDIREKT("'" &INDEX(x;ZEILE(A7))&"'!c7"

Das A7.
A: ist nur ein Platzhalter damit die Formel funktioniert.
7: ab dem 7 Tabellenblatt werden die Daten gelesen, egal wie der Blattname heist.

Gruß
Manfred


  

Betrifft: AW: jetzt getestet ... von: ... neopa C
Geschrieben am: 16.03.2016 17:39:22

Hallo Manfred,


... allerdings weiß ich nicht, was Deinem Bereichsnamen "x" zugewiesen ist. Angenommen darin stehen Zahlen 1;2;3 ...6;7;8 ... dann eben:

=ZÄHLENWENN(INDIREKT("'"&INDEX(x;ZEILE(A7))&"'!A33:B42");"Manni") und diese Formel nach unten ziehend kopieren.

Die zählt dann den Text "Manni" im jeweiligen Bereich: A33:B42 Deiner Tabellenblätter namens 7, 8 ...

Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "Zusammenführen mit Zählenwenn"