Microsoft Excel

Herbers Excel/VBA-Archiv

kein plan wie das geht Formel suche

Betrifft: kein plan wie das geht Formel suche von: Gudrun
Geschrieben am: 19.03.2016 15:33:19

Hallo und einen schönen Tag zusammen,

leider habe ich ein großes Problem, und bin seit gestern drüber und schaffe es nicht.

In der Spalte A ist Lagerplatz und unten drunter die Artikelnummer drin.
Spalte B ist unwichtig
Spalte C ist Lagerplatz 2 und unten drunter die Menge.

Diese Liste bekomme ich so von einem Programm und kann da leider nichts verändern.
Ich möchte gerne, das er wie im Beispiel Spalte F bis J macht. Dies habe ich Manuell gemacht. Aber bei 10000 Zeilen bin ich immer ewig drüber.

https://www.herber.de/bbs/user/104470.xlsx

Ich brauche nämlich alles in einer Zeile. Lagerplatz dann Artikelnummer dann Menge. ( Lagerplatz 2 ist uninteressant)
Artikelnummer können mehrmals vorkommen, aber der Lagerplatz ist unterschiedlich
( z.B.F14 und F15 diese Beiden muss er zusammenzählen ( 130+5), weil es der gleiche Platz ist. 1-64-19-21,01.
Dann kommt diese Artikel nocheinmal aber die Position ist anders F32 = 1-65-46-67 da wären es 25)

Ich hoffe mir kann jemand folgen und helfen

Lieben Gruß
Gudrun

  

Betrifft: AW: kein plan wie das geht Formel suche von: Hajo_Zi
Geschrieben am: 19.03.2016 15:38:47

Hallo Gudrun,

formel in 2 Zeilen eintragen, beide Zeilen markieren und runterziehen.


Tabelle1

 FGHIJ
1ArtikelnummerDaten2Lagerplatz2  
2Lagerplatz MengeArtikelnummerMenge
31-51-98-20  1-51-98-20 111510
411151 0  

verwendete Formeln
Zelle Formel Bereich N/A
I3=F4  
J3=H4  
F3:F4,H3:H4=A3  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 22.01 einschl. 64 Bit



GrußformelHomepage


  

Betrifft: AW: kein plan wie das geht Formel suche von: Gudrun
Geschrieben am: 19.03.2016 16:19:06

Hallo Hajo,

danke aber das zusammenzählen fehlt noch. siehe rot.
https://www.herber.de/bbs/user/104471.xlsx
Danke


  

Betrifft: AW: kein plan wie das geht Formel suche von: Hajo_Zi
Geschrieben am: 19.03.2016 16:23:38

Ich erstelle die Lösung für das was im Beitrag dargestellt wurde. Wird diese Darstellung geändert, überlasse ich anderen die Lösung, da ich schon eine Lösung erstellt hatte und dafür Zeit investiert habe. Ich arbeite nicht für den Papierkorb.

GrußformelHomepage


  

Betrifft: AW: die Vorgabe ist nicht verändert worden ... von: ... neopa C
Geschrieben am: 19.03.2016 16:36:28

Hallo Hajo,

... Du hast Gudruns Aufgabenstellung wohl etwas zu einfach genommen.

Hallo Gudrun,

... so wie Du es bis jetzt dargestellt hast, dann

in D3: =WENN(ISTZAHL(A3);"";A4) und in E3 =WENN(D3="";"";SUMMEWENN(A4:A6;D3;C4:C6))
und beiden nach unten kopieren.

Allerdings setzt dies bisher voraus, dass sich die Nummern max in zwei hintereinander liegenden Zellen identisch sind. Andernfalls müsstest Du das korrigieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: die Vorgabe ist nicht verändert worden ... von: Gudrun
Geschrieben am: 19.03.2016 16:48:34

Hallo Werner,

danke genau so wollte ich es :-)
ich weiß aber nicht genau, ob es maximal zwei sind. was mache ich, wenn ich lieber auf nummer sicher gehe und drei mache? Heißt drei zeilen
Wie sieht die formel dann aus


  

Betrifft: AW: das kannst Du zunächst abschätzen ... von: ... neopa C
Geschrieben am: 19.03.2016 17:03:40

Hallo Gudrun,

... um sicher zu gehen, dass nicht eine von Dir ungewollte Summierung stattfindet, müsste ich die Formel für E3 schon recht verkomplizieren. Wenn Du aber abschätzen kannst, dass nicht z.B. folgende Konstellation in Spalte A:

Textwert (Ziffernfolge mit Bindestrichen und Punkt)
Zahlenwert #####
Textwert (Ziffernfolge mit Bindestrichen und Punkt)
Zahlenwert ##### identisch dem Zahlenwert zweier Zeilen oberhalb)

möglich ist, dann reicht in E3 folgende Formel: WENN(D3="";"";SUMMEWENN(A4:A7;D3;C4:C7))


Gruß Werner
.. , - ...


 

Beiträge aus den Excel-Beispielen zum Thema "kein plan wie das geht Formel suche"