Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Wenn summe ... mittelwertwenn funktion

Wenn summe ... mittelwertwenn funktion
26.04.2016 09:20:56
Guido
Hallo zusammen,
heiße Guido, bin neu im Forum, habe ein Problem:
in spalte b Zeile 12, 34,58,83,91,94 wird der Mittelwert gebildet von Spalte e Zeile 12:33, 33:57, 58:82,83:90, 91:93 und 94, angezeigt in % mit bedingter Formatierung.
In Spalte a8 steht eine wenn summe mittelwertwenn Formel unter Berücksichtigung von Null und leer, Null und leer soll vernachlässigt werden.
Problem. gebe ich einen Wert in die Null oder leer Zeile eine wird das Ergebnis in der spalte a8 negativer wie vorher: z.b. 78%, bei Eingabe eines Wertes dann 57%.
Wie kann ich dies so berechnen das der Wert in Spalte a8 nicht negativ.
Gruß
Guido

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Wenn summe ... mittelwertwenn funktion
26.04.2016 09:24:14
SF
Hola,
am Besten du zeigst das ganze mal in einer Beispieldatei.
Gruß,
steve1da

Äpfel und Birnen
26.04.2016 10:46:32
WF
Hi,
Du vergleichst 6 Werte in Spalte B mit 85 in Spalte E.
Die 6 Werte in Spalte B sind nicht gleichverteilt:
Die 100 % setzen sich aus 32 Werten zusammen und die 24,8 % aus 8 werden aber eins zu eins behandelt.
Die Gewichtung in Spalte E ist logischerweise real.
WF

AW: Wenn summe ... mittelwertwenn funktion
26.04.2016 17:07:55
DD
Moin Guido,
um leere Zellen und Zellen mit dem Wert 0 bei der bildung des Mittelwertes zu vernachlässigen,
gibst du in Zelle B12 folgende Formel ein.
=WENNFEHLER(SUMME(E12:E33)/ZÄHLENWENN(E12:E33;">0");0)
Die anderen Formeln in der Spalte B entsprechend anpassen.
Hoffe es hilft dir weiter.
Gruß Dieter_D
Anzeige

330 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige