Microsoft Excel

Herbers Excel/VBA-Archiv

Leere Spalteneinträge in Zeile filtern


Betrifft: Leere Spalteneinträge in Zeile filtern von: Nils
Geschrieben am: 22.08.2016 07:02:44

Hallo Leute,

Ich versuche mich gerade an einer Formel, welche mir beim nach rechts kopieren alle leeren Spalteneinträge in einer Zeile überspringt. In Herbers Formelsammlung gibt es ähnliche Matrix-Formeln nur leider beziehen sich die Beispiele auf eine Spalte mit leeren Zeilen...

in der Matrix E5:J5 gibt es leere Zellen.
Im Bereich C26:H26 soll die gefilterte Zeile stehen.

Wie muss meine Formel aussehen?
Wie mache ich das?

Grüße
Nils

  

Betrifft: AW: mit einer Matrixformel ... von: ... neopa C
Geschrieben am: 22.08.2016 07:49:48

Hallo Nils,


... Formel nach rechts kopieren:

 CDEFGHIJ
5   Wert1Wert2  Wert3
6        
7        
8        
26Wert1Wert2Wert3     
27        

Formeln der Tabelle
ZelleFormel
C26{=INDEX(5:5;KKLEINSTE(WENN($E5:$J5<>"";SPALTE($E5:$J5)); SPALTE(A1)))}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4



Gruß Werner
.. , - ...


  

Betrifft: AW: ohne {} als Matrixfunktion(alität)sformel ... von: ... neopa C
Geschrieben am: 22.08.2016 08:42:15

Hallo Nils,

... in C26 so: =INDEX(5:5;KKLEINSTE(INDEX(SPALTE($E5:$J5)+($E5:$J5="")*9;);SPALTE(A1)))&""

und diese Formel aber max auch nur bis H26 kopieren.

Gruß Werner
.. , - ...


  

Betrifft: AW: ohne {} als Matrixfunktion(alität)sformel ... von: Nils
Geschrieben am: 22.08.2016 09:59:48

Danke Werner,

habe mich für die Matrixformel entschieden, den Fehler "ZAHL!" habe ich wie folgt abgefangen:

{=WENN(SPALTE(A1)>ANZAHL2($E5:$J5);"";INDEX(5:5;KKLEINSTE(WENN($E5:$J5<>"";SPALTE($E5:$J5)); SPALTE(A1)))) }
Vielen Dank! Genau das hatte ich gesucht!


  

Betrifft: AW: ohne {} als Matrixfunktion(alität)sformel ... von: SF
Geschrieben am: 22.08.2016 10:01:21

Hola,

und warum nicht einfach mit Wennfehler()?

Gruß,
steve1da


  

Betrifft: machmal besser nicht mit WennFehler.. von: Daniel
Geschrieben am: 22.08.2016 10:28:46

Hi
weil das Problem: "mehr Formeln vorhanden als eigentlich benötigt" hier kein Fehler im eigentlichen Sinn ist.

Ein WennFehler würde auch einen anderen Fehler als dieses Problem unterdrücken, und dieser Fehler würde dann unerkannt bleiben, aber trotzdem zu einem falschen Ergebnis führen.
Von daher ist es sinnvoll, wenn bekannte Ursachen zu einem Ergebnis "Fehler" führen, diese auch spezifisch abzufragen und nicht mit dem "Holzhammer" WennFehler zu unterdrücken.


ein pauschales "WennFehler" ist dann sinnvoll, wenn auch unerwartete Fehlerursachen keinen Fehler erzeugen sollen oder wenn Prüfung auf die Ursache zuviel Rechenzeit kosten würde (z.B. SVerweis in grossen Datenmengen).

Gruß Daniel


  

Betrifft: AW: wäre für mich dann aber ein weitere Grund ... von: ... neopa C
Geschrieben am: 22.08.2016 10:50:07

Hallo Nils,

... den Matrixfunktion(alität)sformelvorschlag einzusetzen. Da benötigst Du keine zusätzliche Fehlerabfangung, wenn Du die Formel wie geschrieben nur bis Spalte H kopierst.

Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Leere Spalteneinträge in Zeile filtern"