Microsoft Excel

Herbers Excel/VBA-Archiv

Summenprodukt mit ODER


Betrifft: Summenprodukt mit ODER von: Heinz
Geschrieben am: 23.08.2016 10:16:56

Hallo Liebe Excellenten,

folgendes Problem:
Ich habe eine Liste mit ca. 1000 Zeilen.

In einer Spalte steht eine von 32 Marktnummern (also 1 bis 32),
d.h. jede Marktnummer kommt öfter vor.

In einer anderen Spalte steht ein Umsatzwert.

Ich würde gerne für eine bestimmte Anzahl verschiedener
Märkte (also z.B. die Märkte 3 und 5 und 7 und 32) die Summe
des Umsatzes ermitteln, d.h. einen Wert erhalten.
Die Nummern dieser ausgewählten Märkte stehen in einer eigenen Tabelle.

Also
3
5
7
32

Ich kann natürlich alle Werte für jedes Outlet einzeln erfassen
und summieren, aber ggf. gibt es da eine bessere Lösung.
Zumal ich das für andere Kombinationen von Märkten noch öfters
durchführen muss.

Sinngemäß irgendwie sowas
=Summenprodukt((Markt=Bereich_Mit_den_4Marktnummern)*(Spalte_Umsatz))

Ich freue mich auf Eure Lösungen.
und wünsche alle aus dem sonnigen Süden eine schönen Tag.

Heinz

  

Betrifft: AW: Summenprodukt mit ODER von: SF
Geschrieben am: 23.08.2016 10:18:18

Hola,

=SUMMENPRODUKT((A1:A7={3.5.7.32})*(B1:B7))
Gruß,
steve1da


  

Betrifft: AW: Summenprodukt mit ODER von: Heinz
Geschrieben am: 23.08.2016 11:35:22

Hallo Steve,

vielen Dank.
Das funktioniert schon mal.
Der Nachteil: Ich muss die Märkte immer "manuell" eintragen.

Gibt es auch eine Lösung, in welcher ich innerhalb der Formel
auf einen Bereich verweisen kann, in dem die Nummer der Märkte stehen?

Heinz


  

Betrifft: mit MTRANS von: WF
Geschrieben am: 23.08.2016 12:00:11

Hi,

die Nummern in C1:C4

folgende Arrayformel:
=SUMME(((A1:A7=MTRANS(C1:C4))*(B1:B7)))

WF


  

Betrifft: Danke WF, das hilft mir sehr owT von: Heinz
Geschrieben am: 23.08.2016 12:27:56