Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Doppelte Einträge löschen

Doppelte Einträge löschen
25.10.2016 07:36:09
Marcel
Hi,
jemand eine Idee, wie man doppelte Einträge in Excel "VON UNTEN" löschen kann?
Tabellenstruktur:
a 1
b 2
a 3
c 4
Übrig würde mit der gewohnten Excel-Funktion a 1, b 2, c 4 bleiben. Ich möchte aber b 2, a 3, c4, da meine aktuelleren Einträge unten angefügt werden und die oberen (=älteren) wegfallen sollen.
Danke!

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Doppelte Einträge löschen
25.10.2016 09:21:59
Rudi
Hallo,
Formel in Hilfsspalte:
=((ZÄHLENWENN(A:A;A1)=1)+(ZÄHLENWENN(A$1:A1;A1)=ZÄHLENWENN(A:A;A1)))*1
nach 0 filtern und Zeilen löschen.
Gruß
Rudi
AW: Doppelte Einträge löschen
25.10.2016 09:30:08
Daniel
Hi
am einfachsten, indem du die neuen Einträge oberhalb der älteren Einträge einfügst, bzw die älteren unterhalb der neueren.
sollte das aus irgendeinem Grund nicht möglich sein, müsstest du vor dem Duplikate Entfernen die Daten umsortieren und hinterher wieder zurück sortieren.
sollte deine Liste kein Sortierfähiges Kriterium enthalten, dann müsstest du temporär eines in einer Hilfsspalte einfügen, bspw 1 in Zeile 1, 2 in Zeile 2, dann beiden Zellen markieren und an der unteren rechten Ecke bis zum Tabellenende runterziehen.
wenn du nicht umsortieren möchtest, dann mit dieser Formel in einer Hilfsspalte (Formel für Zeile1, Zellbereich bitte so gut wie möglich an den genutzen Bereich anpassen):
=Wenn(ZählenWenn(A1:A$9999;A1)=1;Zeile();0)
Diese Formel nach unten ziehen und dann das Duplikate-Entfernen mit dieser Zeile als Kriterium anwenden.
Gruß Daniel
Anzeige

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige