Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Sverweis mehrere Bedingungen

Sverweis mehrere Bedingungen
16.11.2016 11:30:54
Erik
Hallo zusammen,
habe ein Problem mit dem Sverweis und bekomme die Formel einfach nicht hin.
Bin auch Anfänger in Excel, deshalb würde ich mich über Hilfe sehr freuen.
Als Anhang meine Datei, damit es verständlicher ist.
https://www.herber.de/bbs/user/109461.xlsx
Nach Eingabe des Datums in Feld A2
Soll die Matrix Tabelle4 in A überprüft nach dem Datum überprüft werden.
Wird eine Übereinstimmung gefunden soll anschliessend in der Matrix Tabelle 4 die Spalte D nach folgenden Inhalten überprüft werden: "neue*" und "eingel*"
dannach soll in Tabelle 1 alles Kunden, Kennzeichen und Arbeitsbeschreibungen aus der Matrix aufgelistet werden.
Vielleicht kann mir jemand helfen, alleine ist das zu viel für mich
Vielen Dank
und Gruß
Erik

4
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Sverweis mehrere Bedingungen
16.11.2016 11:37:08
SF
Hola,
=WENNFEHLER(INDEX(Tabelle4!$B$1:$B$20;AGGREGAT(15;6;ZEILE($A$1:$A$20)/((Tabelle4!$A$1:$A$20=$A$2) *((ISTZAHL(SUCHEN("neue";Tabelle4!$D$1:$D$20)))+(ISTZAHL(SUCHEN("eingel";Tabelle4!$D$1:$D$20))))); ZEILE(A1)));"") 
Kennzeichen und Arbeitsbeschreibung finde ich in Tabelle 4 nicht.
Gruß,
steve1da
AW: Sverweis mehrere Bedingungen
16.11.2016 11:40:42
Erik
Hallo Steve1da !
Vielen Dank für deine Antwort.
(Kennzeichen und Arbeitsbeschreibung finde ich in Tabelle 4 nicht.)
Doch das ist Spalte C und Spalte D in der Tabelle 4
Gruß
Erik
AW: Sverweis mehrere Bedingungen
16.11.2016 11:53:26
SF
Hola,
glatt übersehen :)
C2:
=WENNFEHLER(INDEX(Tabelle4!B$1:B$20;AGGREGAT(15;6;ZEILE($A$1:$A$20)/((Tabelle4!$A$1:$A$20=$A$2)* _
((ISTZAHL(SUCHEN("neue";Tabelle4!$D$1:$D$20)))+(ISTZAHL(SUCHEN("eingel";Tabelle4!$D$1:$D$20)))));ZEILE(A1)));"")

D2:
=WENNFEHLER(INDEX(Tabelle4!C$1:C$20;AGGREGAT(15;6;ZEILE($A$1:$A$20)/((Tabelle4!$A$1:$A$20=$A$2)* _
((ISTZAHL(SUCHEN("neue";Tabelle4!$D$1:$D$20)))+(ISTZAHL(SUCHEN("eingel";Tabelle4!$D$1:$D$20)))));ZEILE(B1)));"")

F2:
=WENNFEHLER(INDEX(Tabelle4!D$1:D$20;AGGREGAT(15;6;ZEILE($A$1:$A$20)/((Tabelle4!$A$1:$A$20=$A$2)* _
((ISTZAHL(SUCHEN("neue";Tabelle4!$D$1:$D$20)))+(ISTZAHL(SUCHEN("eingel";Tabelle4!$D$1:$D$20)))));ZEILE(C1)));"")

Gruß,
steve1da
Anzeige
AW: Sverweis mehrere Bedingungen
16.11.2016 12:04:10
Erik
Hallo Steve1da,
super es funktioniert. Du bist der Hammer. Danke!!!
habe noch ein kleines Problem:
Excel soll nach dem Wort neue und eingel suchen.
eingel soll im Wort zu finden sein wie bei: eingelagerte
neue findet excel nun aber auch das Ergebnis: erneuern
wie heißt der befehl das er genau nach dem Wort neue oder Neue sucht?
Vielen Dank
nochmals
Gruß
Erik

301 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige