Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

doppelte Einträge löschen

doppelte Einträge löschen
05.01.2017 18:05:54
Eugen
Doppelte, einzelne Datensätze zu löschen sind für mich kein Problem. In der beigefügten Datei sollen aber je bn Nummer (Spalte A) nur das dazu gehörige jüngste Datum (Spalte B) es kann 2-4 mal das gleiche Datum vorkommen.
A Datum id satz
1000080 01.01.2017 U1_1 70
1000080 01.01.2017 U1_2 50
1000080 01.01.2017 U2_1 100
1000080 01.11.2016 U1_1 70
1000080 01.11.2016 U1_2 50
1000080 01.11.2016 U2_1 100
1000126 01.01.2017 U1_1 70
1000126 01.01.2017 U1_2 50
1000126 01.01.2017 U2_1 100
1000126 01.11.2016 U1_1 70
1000126 01.11.2016 U1_2 50
1000126 01.11.2016 U2_1 100
1000159 01.01.2017 U1_1 65
1000159 01.01.2017 U1_2 50
1000159 01.01.2017 U2_1 100
1000159 01.01.2016 U1_1 65
1000159 01.01.2016 U1_2 50
1000159 01.01.2016 U2_1 100
Für eine Lösung wäre ich sehr dankbar
Eugen

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
manuelle Lösung
05.01.2017 18:31:16
ChrisL
Hi Eugen
Falls du es nicht regelmässig wiederholen musst, dann würde ich es so machen:
- Spezialfilter "ohne Duplikate" auf ID anwenden
- ID Liste ohne Duplikate kopieren
- Mit SVERWEIS den ersten Wert holen (vielleicht musst du vorher sortieren)
- Inhalte Einfügen "Werte"
- Alte Liste löschen
Richtig "Löschen" geht wohl nur mit VBA. Suchst du eine Makro-Lösung?
cu
Chris
AW: doppelte Einträge löschen
05.01.2017 18:34:49
Daniel
Hi
wenn die Zeilen mit dem jüngsten Datum stehen bleiben sollen, dann so:
1. sortiere nach Spalte A und nach Spalte B absteigend (jüngstes Datum oben)
2. füge in Zelle D2 diese Formel ein und ziehe sie nach unten: =WENN(A2A1;"x";WENN(B2B1;0;D1))
3. lösche alle Zeilen, die mit 0 markiert sind (autofilter)
Gruß Daniel
Anzeige

315 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige