Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

summenprodukt - Bedingung Text in Spalte

summenprodukt - Bedingung Text in Spalte
22.03.2017 09:31:08
mesut
Hallo zusammen,
ich bin auf der Suche nach einer Lösung für zwei kleine Probleme.
1)
=SUMMENPRODUKT((Input!$A$3:$A$50000=1) *(Input!$Y$3:$Y$50000={"Wind"."Photovoltaik"."Wasser"}*Input!$Z$3:$Z$50000)
Wenn in der Spalte Y Wind, Wasser oder Photovoltaik steht sollen die Werte in Spalte Z Summiert werden. Wenn ich Zahlen als Bedingung habe und in {} schreibe funktioniert es in der Summenprodukt-Formel. Mit Text anscheinend nicht. Gibt es da eine einfache Lösung?
2)
=SUMMENPRODUKT((Input!$A$3:$A$50000=1) *(Input!$Y$3:$Y$50000{"Wind"."Photovoltaik"."Wasser"}*Input!$Z$3:$Z$50000)
Wie Problem 1), nur genau umgekehrt. Diese Wörter sollen da nicht drin stehen....
Vielen Dank im Voraus

5
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: summenprodukt - Bedingung Text in Spalte
22.03.2017 09:39:37
SF
Hola,
=SUMMENPRODUKT((Input!$A$3:$A$50000=1)*(Input!$Y$3:$Y$50000={"Wind"."Photovoltaik"."Wasser"})*( _
Input!$Z$3:$Z$50000))

Gruß,
steve1da
AW: summenprodukt - Bedingung Text in Spalte
22.03.2017 09:52:45
Daniel
Hi
probier mal für 1)
=Summe(SummeWenns(Input!$Z:$Z$;Input!$A:$A;1;Input!$Y:$Y;{"Wind";"Photovoltaik";"Wasser"})
für 2) dann
=SummeWenn(Input!$A:$A;1;Input!$Z:$Z$)-Summe(SummeWenns(Input!$Z:$Z$;Input!$A:$A;1;Input!$Y:$Y;{"Wind";"Photovoltaik";"Wasser"})
wobei du, wenn du die Summe für Wind, Photovoltaik und Wasser in einer Zelle hast, anstelle der Teilformel auch einfach den Bezug auf diese Zelle setzen solltest (dann muss Excel weniger rechnen)
Gruß Daniel
Anzeige
AW: summenprodukt - Bedingung Text in Spalte
22.03.2017 11:12:52
ingoG
Hallo Mesut,
wenn es nicht an Deiner Klammersetzung liegt ;-):
bei Textvergleich musst Du darauf achten, dass alles identisch ist, also Gross-/Kleinschreibung, Blanks davor oder dahinter etc.
hast Du mal bestimmte Zellen einzeln verglichen also zB in a1 folgende Formel geschrieben:
=(Input!$Y$3="Photovoltaik") hier sollte dann WAHR herauskommen...
generell kannst Du auch den Bereich mal auf 20 Zeilen beschränken (alle Bereiche!!!) und in der Formel
(Input!$Y$3:$Y$22={"Wind"."Photovoltaik"."Wasser"})
markieren und dann F9 drücken dann siehst Du die Einzelergebnisse pro Zeile...
Ich hoffe, das hilft Dir weiter
Gruß Ingo
Anzeige
AW: summenprodukt - Bedingung Text in Spalte
22.03.2017 11:48:44
Daniel
Hi
noch ne Alternative.
Matrixberechnungen innerhalb von Matrixberechnungen sind immer kritisch.
probiere mal diese Variante:
für 1)
=SUMMENPRODUKT((Input!$A$3:$A$50000=1)*IstZahl(Finden(Input!$Y$3:$Y$50000;"Wind.Photovoltaik.Wasser"))*Input!$Z$3:$Z$50000)
für 2)
=SUMMENPRODUKT((Input!$A$3:$A$50000=1)*IstFehler(Finden(Input!$Y$3:$Y$50000;"Wind.Photovoltaik.Wasser"))*Input!$Z$3:$Z$50000)
Gruß Daniel
AW: summenprodukt - Bedingung Text in Spalte
23.03.2017 20:28:42
mesut
vielen Dank für die zahlreichen Antworten. ich habe das Problem lösen können ;)

77 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige