Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

wenn dann oder sonst

wenn dann oder sonst
06.04.2017 16:13:57
Max
Hallo Freunde
wenn ich im adressfeld den text frau oder herr eingebe
dann passt die formel in zelle D22
wie kann ich die formel so erweiten daß,
wenn ich ausser die worte "herr oder frau" etwas anderes eingebe zb. Finanzamt
das dann in zeile D22 sehr geehrte Damen und Herr angezeigt wird
Hilfszellen sind in zeile 1 (rot)
wäre sehr fro wenn mir einer oder eine helfen könnte
danke in voraus max
https://www.herber.de/bbs/user/112701.xlsx

15
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: wenn dann oder sonst
06.04.2017 16:31:57
Michael
Hallo!
=WENN(D9="Herr";C1;WENN(D9="Frau";J1;Q1)&VERKETTEN(" ";TEIL(D11;FINDEN(" ";D11)+1;LÄNGE(D11) -FINDEN(" ";D11));",")) 
LG
Michael
AW: wenn dann oder sonst
06.04.2017 16:39:26
Max
hallo michael
soweit sogut leider wird dann hinten immer noch der Familienname angezeigt
zb "sehr geehrte damen und herren, doppel,)
lg max
AW: wenn dann oder sonst
06.04.2017 16:59:27
UweD
dann so...
=WAHL((D9="Herr")+(D9="Frau")*2+(D9="Firma")*3;C1&TEIL(D11;FINDEN(" ";D11);999);J1&TEIL(D11; FINDEN(" ";D11);999);Q1) &","
Zeile 1 bleibt bestehen
LG UweD
AW: wenn dann oder sonst
06.04.2017 17:03:26
Michael
Hallo,
achso, dann
=WENN(D9="Herr";C1)&VERKETTEN(" ";TEIL(D11;FINDEN(" ";D11)+1;LÄNGE(D11) -FINDEN(" ";D11));",");WENN(D9="Frau";J1)&VERKETTEN(" ";TEIL(D11;FINDEN(" ";D11)+1;LÄNGE(D11) -FINDEN(" ";D11));",");Q1))
LG
Michael
Anzeige
AW: wenn dann oder sonst
06.04.2017 17:18:01
Max
hi michael
könnte hinhauen wenn in der formel kein fehler wäre
excel meutert und nimt die formel nicht an
lg max
AW: wenn dann oder sonst
06.04.2017 16:36:46
UweD
Hallo
Formel in D22
=VERWEIS(D9;{"Herr";"Frau";"Firma"};{"Sehr geehrter Herr ";"Sehr geehrte Frau "; "Sehr geehrte Damen und Herren "})& TEIL(D11;FINDEN(" ";D11)+1;999) &","

Dabei kannst du auf die Einträge in Zeile 1 verzichten
LG UweD
AW: wenn dann oder sonst
06.04.2017 16:45:44
Max
hallo UweD
geht nicht zeig immer den nammen an
lg Max
AW: wenn dann oder sonst
06.04.2017 18:31:23
Henner
Hallo Max,
das geht so:

=WENN(D9="Frau";"Sehr geehrte Frau "&RECHTS(D11;LÄNGE(D11)-FINDEN(" ";D11;1));WENN(D9="Herr";" _
Sehr geehrter Herr "&RECHTS(D11;LÄNGE(D11)-FINDEN(" ";D11;1));"Sehr geehrte Damen und Herren"))
Funktioniert?
Gruss Henner
Anzeige
Noch etwas kürzer...
06.04.2017 18:39:31
Henner
...ginge es auch so:

="Sehr geehrte"&WENN(D9="Frau";" Frau "&RECHTS(D11;LÄNGE(D11)-FINDEN(" ";D11;1));WENN(D9="Herr"; _
"r Herr "&RECHTS(D11;LÄNGE(D11)-FINDEN(" ";D11;1));" Damen und Herren"))
Das "_"-wird leider von der Forensoftware eingefügt und muss nach dem Kopieren entfernt werden.
Gruss Henner
AW: flutscht Danke an alle
06.04.2017 20:05:14
Max
Danke Henner
affengeil hat hingehauen
lg max
AW: Hallo Henner
06.04.2017 20:29:34
Max
wie kann ich hinter den Nachnamen bei (FINDEN) noch ein komma einfügen
soll zb so "sehr geehrte frau alexandra heuer," ausehen
lg max
Formel&","
06.04.2017 20:51:55
{Boris}
Hi Max,
aber das hätest Du auch selbst hinbekommen ;-)
Was machst Du aber z.B. mit einer Karla Maria Müller oder einem Dr. Hans Meier?
VG, Boris
Anzeige
AW: ups...
06.04.2017 21:00:57
Max
hi boris
hast recht muß formel komplet überdenken
darf ich vieleicht in den nächten tagen auf dich zurückkommen?
henner hat mich schon super weit gebracht
aber dein argument habe ich nicht bedacht
danke bis später
heut ist es genug
danke an alle und gute nacht
lg max
AW: ups...
07.04.2017 11:24:17
{Boris}
Hi Max,
Uwe hat Dir ja schon den passenden Link auf unsere Seite geschickt. Wollte Dich nur zum Nachdenken anregen ;-)
Mit der verlinkten Formel bekommst Du sicher 99,99% aller Fälle geregelt, denn die Formel sucht nach den Namenszusätzen von, zu, ob, van, de, auf, vom - wenn einer vorhanden ist, dann beginnt dort der Nachname - ist keiner vorhanden, wird nach dem LETZTEN vorkommenden Leerzeichen gesucht - und der Rest dahinter als Nachname ausgegeben.
VG, Boris
Anzeige

333 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige