Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Formel in Excel (Diff) um eine Zelle nach oben dyn

Formel in Excel (Diff) um eine Zelle nach oben dyn
07.06.2017 19:34:54
Darren
Hi,
habt Ihr eine Idee und/oder Lösung, wie ich eine dynamische Formel erstellen kann, die die letzte und vorletzte Zeile erkennen und sich somit anpassen kann? Diese muss ich manuell für sehr viele Tabellen jeden Tag anpassen, wenn neue Werte ermittelt sind (Vortag und Heute Werte).
A200 = 100 EURO (hier die Formel (= A232-231)die überall und 1000mal angepasst werden muss. Die Position der Formel ist immer gleich, aber die Berechnung der Diff. jeden Tag eine Zelle nach oben.
A232 = 240 EURO Umsatz(Tag 24)
A231 = 120 EURO Umsatz(Tag 23)
... usw.
A546 = 400 EURO
A501 = 600 EURO
A500 = 200 EURO
Grüße
Darren

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
letzte und vorletzte Zelle
07.06.2017 19:54:56
WF
Hi,
=VERWEIS(2;1/(A1:A999"");A:A)
und
=VERWEIS(2;1/(A2:A999"");A:A)
WF
AW: letzte und vorletzte Zelle
07.06.2017 20:07:09
Darren
Hi WF,
super, habs gerade ausprobiert, aber wie kann ich verhindern, dass sie das absolute letzte und vorletzte nimmt?
Da die Datei in Spalte A usw. viele dieser Diff-Berechnungen hat.
A200 = Diff von A180-A179
...
A150 = Diff von A123-A122
...
A110 = Diff von A99-A98
usw
Grüße
Darren
kapier nicht, was Du willst
07.06.2017 20:23:02
WF
da hilft wohl nur eine Beispieltabelle mit Wunschergebnis.
WF
Geht evtl. auch kürzer
07.06.2017 20:54:37
lupo1
C3:
=INDEX(C4:C8;VERGLEICH(WAHR;INDEX(C4:C8"";);))
-INDEX(C4:C8;VERGLEICH(WAHR;INDEX(C4:C8"";);)+1)
Anzeige
AW: Geht evtl. auch kürzer
07.06.2017 21:07:08
Darren
Danke lupo1! Super, werde die mal genauer testen. Darren
C3: {=MIN(WENN(C4:C7;C4:C7-C5:C8))} kürzer!
07.06.2017 21:18:14
lupo1
Falsch!
07.06.2017 21:27:49
lupo1
Die erstgenannte lange Formel geht aber.
Und die nachfolgende möglicherweise auch:
C3: {=(REST(MIN(WENN(C4:C7"";ZEILE(C4:C7)+1/2+(C4:C7-C5:C8)%%%));1)-1/2)/1%%%}
noch eine:
07.06.2017 21:39:09
lupo1
C3: =SUMMENPRODUKT(BEREICH.VERSCHIEBEN(C4:C5;ANZAHLLEEREZELLEN(C4:C8);)*{1;-1})
erlaubt jedoch nur leere Zellen ÜBER den Daten! Nicht UNTER oder ZWISCHEN.
AW: noch eine:
07.06.2017 22:07:38
Darren
Super, ich probiere mal alle aus :-) Danke

325 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige