Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Duplikate filtern mit Bedingung

Duplikate filtern mit Bedingung
07.09.2017 08:36:02
AndreasG
Hallo,
folgendes Problem, was ich mit Formeln nicht selbst lösen kann, aber eine Formellösung benötige
in Spalte R und S stehen Kostenstellen und Kontenbezeichnungen mehrfach vorkommend
ich brauche in Spalte A je Kostenstelle jedes vorkommende Konto genau einmal
Beispieldatei anbei. Kann mir jemand helfen?
https://www.herber.de/bbs/user/116059.xlsx

10
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Duplikate filtern mit Bedingung
07.09.2017 08:44:55
AndreasG
Hallo Uwe,
das kenne ich. Da bring ich aber die KST-Bedingung nicht unter :-(
AW: Duplikate filtern mit Bedingung
07.09.2017 09:39:19
SF
Hola,
in A75:
=S6
In A76:
=WENNFEHLER(INDEX($S$6:$S$66;VERGLEICH(1;(ZÄHLENWENN(A$75:A75;$S$6:$S$66)=0)*($S$6:$S$66"")*($ _
R$6:$R$66=$A$74);0));"")

Eingabe als Matrixformel.
Gruß,
steve1da
AW: Duplikate filtern mit Bedingung
07.09.2017 10:12:10
AndreasG
Hallo Steve,
die Formel mag Excel nicht. Hier wird der Fehler angezeigt "($ _R$6"
Da ich sie nicht verstehe kann ich sie auch nicht selbst korrigieren :-(
Anzeige
AW: Duplikate filtern mit Bedingung
07.09.2017 10:14:19
SF
Hola,
sorry, Darstellungfehler:
=WENNFEHLER(INDEX($S$6:$S$66;VERGLEICH(1;(ZÄHLENWENN(A$75:A75;$S$6:$S$66)=0)*($S$6:$S$66<>"") *($R$6:$R$66=$A$74);0));"")
Gruß,
steve1da
AW: Duplikate filtern mit Bedingung
07.09.2017 08:42:38
Sven
Hallo Andreas,
ich würde Dir hier vorschlagen, dass ganze über eine Pivottabelle zu lösen.
Sprich in deiner Tabelle den Bereich $R$5:$S$66 markieren und unter dem Register "einfügen" den Button "PivotTable" anklicken. In die Zeilenbeschriftung das Feld KST per DragDrop ziehen...
Die PivotTabelle kannst Du mit rechtem Mausklick immer wieder aktualisieren, falls sich Datenbasis ändert.
Grüße
Sven
Anzeige
AW: Duplikate filtern mit Bedingung
07.09.2017 08:53:53
AndreasG
Hallo Sven,
hab ich auch bereits dran gedacht, ich muss aber mit den Ergebnissen der Pivot noch weiterarbeiten und die Dateigröße ist eh schon hoch und mit PIVOTDATENZUORDNEN wirds dann zu heftig.
Aber danke für deinen Vorschlag
sortiert ist's einfach
07.09.2017 09:42:21
WF
Hi,
sollte ja egal sein.
In A75 folgende Arrayformel:
{=MIN(WENN(R$6:R$99=A$74;WENN(S$6:S$99>A74;S$6:S$99)))}
runterkopieren
Das Ende (wenn die 0 auftaucht) musst Du noch dazufummeln.
WF
AW: sortiert ist's einfach
07.09.2017 10:08:38
AndreasG
Hallo WF,
danke!
das funzt fast. Die Zeile mit den 3 ? übergeht er, weil nicht numerisch, aber damit kann ich leben weil ich die Zelle eh noch richtig füllen muss
Anzeige
AW: alternativ geht es auch ohne {} ...
07.09.2017 14:36:47
...
Hallo Andreas,
... mit folgender Matrixfunktion(alität)sformel die keines spez. Formelabschluss wie eine klassische Matrixformel benötigt.
Durch die Klammerung der AGGREGAT()-Formelteils mit WENNFEHLER() entstehen auch keine 0-Ergebniswerte. Textwerte wie Deine "?" werden damit natürlich auch nicht gefunden. Möglich wäre es, allerdings dann bedarf es einer längeren Formel.
In A75:
=WENNFEHLER(AGGREGAT(15;6;S$6:S$99/(R$6:R$99=A$74)/(S$6:S$99>A74);1);"")

Gruß Werner
.. , - ...

301 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige