Microsoft Excel

Herbers Excel/VBA-Archiv

summewenn


Betrifft: summewenn von: Herbert
Geschrieben am: 23.09.2017 16:56:33

Hallo,
Ich bräuchte bitte wieder einmal eure Hilfe für eine Formellösung.
Und zwar führe ich ein Kassabuch und möchte den Kassastand anhand der Ausgabenart in Spalte B:B getrennt in den Zellen I1;I2;I3 darstellen.(siehe Beispieldatei)
Danke im voraus für Lösungsvorschläge.
Gruss Herbert
https://www.herber.de/bbs/user/116462.xlsx

  

Betrifft: AW: summewenn von: Hajo_Zi
Geschrieben am: 23.09.2017 17:02:04

Hallo Herbert,


FF

 I
11163
2590
30
4Eingaben

verwendete Formeln
Zelle Formel Bereich N/A
I1:I3=SUMMEWENN($C$5:$C$17;H1;$E$5:$E$17)  
Excel-Inn.de
Hajo-Excel.de
XHTML-Tabelle zur Darstellung in Foren, einschl. der neuen Funktionen ab Version 2007
Add-In-Version 25.13 einschl. 64 Bit


GrußformelHomepage
Ich gebe keinen Dank für eine Rückmeldung, da ich durch solche Beiträge nicht meine Beitragszahl erhöhen muss.

Also ich schreibe keine Beiträge mit dem Betreff "Gerne u. Danke für die Rückmeldung. o.w.T."

Rückmeldung ist ja in der Heutigen Zeit nicht üblich und die wenigen die eine Rückmeldung geben, mögen mir das verzeihen, das kein Danke für eine Rückmeldung kommt.


  

Betrifft: AW: so rechnet man sich reich ;-) owT von: ... neopa C
Geschrieben am: 23.09.2017 20:10:02

Gruß Werner
.. , - ...


  

Betrifft: Es ist die Einnahmnenspalte. von: Hajo_Zi
Geschrieben am: 24.09.2017 04:59:07

in der Summenspalte stehen nur Einnahmen. Die Überschrift hatte ich nicht mit ausgelesen, da ja Spaltenname da.

Gruß Hajo


  

Betrifft: AW: aber die war doch nicht gefragt ... von: ... neopa C
Geschrieben am: 24.09.2017 11:21:30

Hallo Hajo,

... der von Herbert gefragte "Kassastand" ergibt sich aus Einnahmen und Ausgaben.

Mit SUMMEWENN() dann z.B. so: =SUMMEWENN(C:C;H1;E:E)-SUMMEWENN(C:C;H1;F:F) oder eben, wie alternativ von mir aufgezeigt, mit SUMMENPRODUKT() in I1:I2 ermittelt werden.

Wobei die von Herbert gewählte Überschrift "Kontostand" in G4 auch unzutreffend erscheint. So wie seine Formel in Spalte G definiert ist (bezieht "Handkassa-EIN/AUS" mit ein), müsste es mE da z.B. "Gesamt" lauten.

Gruß Werner
.. , - ...


  

Betrifft: AW: aber die war doch nicht gefragt ... von: Hajo_Zi
Geschrieben am: 24.09.2017 11:26:39

Hallo Wernr,
#
Der Beitrag

Ich bräuchte bitte wieder einmal eure Hilfe für eine Formellösung.
 Und zwar führe ich ein Kassabuch und möchte den Kassastand anhand der Ausgabenart in Spalte B: _
B getrennt in den Zellen I1;I2;I3 darstellen.(siehe Beispieldatei)
 Danke im voraus für Lösungsvorschläge

da steht was von Spalte B also Datum im Bereich Spalte I steht nichtas von Datum.
Also hat er uns überlassen was wir daraus interpretioeren.
Er wollte die vorgeschlagene Lösung selber an seine Bedingungen anpassen. Ansonsten hätte er die Aufgabe genauer beschrieben, Was ja in Excel einfach ist da jede Zelle eine Bezeichnung hat.

Gruß Hajo


  

Betrifft: AW: das "B" ein Schreibfehler von Herbert war ... von: ... neopa C
Geschrieben am: 24.09.2017 11:41:29

Hallo Hajo,

... war doch leicht zu erkennen. Im Text schrieb Herbert eindeutig "...anhand der Ausgabeart...". Oder sind Dir noch nie Schreibfehler unterlaufen?

Gruß Werner
.. , - ...


  

Betrifft: AW: nein, entweder je 2x SUMMEWENN() oder ... von: ... neopa C
Geschrieben am: 23.09.2017 20:08:47

Hallo Herbert,

... alternativ gleich eine SUMMEPRODUKT()-Formel.

In I1: =SUMMENPRODUKT((C$5:C$99=H1)*(E$5:E$99-F$5:F$99)) und nach I2 kopieren und in I3 einfach summieren.

Wenn Du Deine Datentabelle als eine "intelligente" Tabelle formatierst, dann kannst Du anstelle der unsicheren Zellbereichsangabe auch anstelle derer gleich die Bereichsnamen "Art", "Einnahmen" und "Ausgaben" einsetzen, die sich ja den Datenerweiterungen automatisch anpassen.

Hajo hat mit seiner Formel die Ausgaben einfach ignoriert. Wenn das real so auch möglich wäre, wären sicherlich viele viel glücklicher ;-)

Gruß Werner
.. , - ...


  

Betrifft: mit Teilergebnis und Filter ... von: Matthias L
Geschrieben am: 24.09.2017 10:00:22

Hallo

FF

 BCDEFG
3   € 1.163,00€ 411,00€ 752,00
4DatumArtBeschreibungEinnahmenAusgabenKontostand
610.01.2017Handkassa € 10,00€ 5,00€ 21.005,00
712.05.2017Handkassa € 130,00€ 21,00€ 21.114,00
913.07.2017Handkassa € 333,00 € 21.586,00
1210.09.2017Handkassa € 100,00€ 5,00€ 21.746,00
1420.09.2017Handkassa € 150,00€ 130,00€ 21.744,00
1621.09.2017Handkassa € 430,00€ 120,00€ 22.134,00
1722.09.2017Handkassa € 10,00€ 130,00€ 22.014,00
18      
19      

Formeln der Tabelle
ZelleFormel
E3=TEILERGEBNIS(9;E5:E17)
F3=TEILERGEBNIS(9;F5:F17)
G3=E3-F3
G6=WENN(E6+F6=0;"";G5+E6-F6)
G7=WENN(E7+F7=0;"";G6+E7-F7)
G9=WENN(E9+F9=0;"";G8+E9-F9)
G12=WENN(E12+F12=0;"";G11+E12-F12)
G14=WENN(E14+F14=0;"";G13+E14-F14)
G16=WENN(E16+F16=0;"";G15+E16-F16)
G17=WENN(E17+F17=0;"";G16+E17-F17)


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

Gruß Matthias


  

Betrifft: AW: summewenn von: Herbert
Geschrieben am: 24.09.2017 13:27:34

Hallo,
Ich habe mich für die Lösung mittels Summenprodukt entschieden.
Möchte mich Entschuldigen wenn ich meine Frage zu ungenau beschrieben habe.
Danke für eure Lösungsvorschläge.
Gruß Herbert


Beiträge aus den Excel-Beispielen zum Thema "summewenn"