Microsoft Excel

Herbers Excel/VBA-Archiv

Spalten abgleichen,Duplikate in 1er Spalte löschen


Betrifft: Spalten abgleichen,Duplikate in 1er Spalte löschen von: Moritz
Geschrieben am: 29.11.2017 12:30:52

Hallo zusammen,

ich möchte gerne in Excel zwei Spalten (zB. A und C) miteinander abgleichen und alle Einträge, die in beiden Spalten (in Spalte A mehrmals) vorkommen aus Spalte A löschen. Als Ergebnis sollte in der Muster-Datei in Spalte A nur der Wert "C" 3 mal übrig bleiben.

Die Muster-Datei findet ihr hier: https://www.herber.de/bbs/user/117984.xlsx

Kann mir jemand dabei helfen? Stehe leider ziemlich auf dem Schlauch.

Vielen Dank und LG,

Moritz

  

Betrifft: Doppelt - owT von: Bernd
Geschrieben am: 29.11.2017 12:37:49




  

Betrifft: AW: Spalten abgleichen,Duplikate in 1er Spalte lös von: Michael (migre)
Geschrieben am: 29.11.2017 12:41:35

Hallo!

Du hast noch nicht angegeben, wie zu Deinem Ergebnis kommen möchtest. Also etwa ob VBA (Makros) oder mit Formellösung etc.

Ein ganz einfache, manuelle Möglichkeit besteht darin, in Spalte B jeden Wert aus Spalte A daraufhin zu prüfen, ob er in C:C vorkommt. Auf diese Spalte wendest Du dann den Autofilter an und löschst alle Werte aus A, die dem Filterkriterium (=kommen mindestens einmal in Spalte C vor) entsprechen. Dann den Filter wieder aufheben, und es bleiben die einzigartigen Werte aus A:A über.

Für den Abgleich in Spalte B kannst Du bspw. =ZÄHLENWENNS($C:$C;A1) benutzen; Werte über 0 sind dann zu löschen.

LG
Michael


  

Betrifft: Oops, was vergessen... von: Michael (migre)
Geschrieben am: 29.11.2017 12:53:20

...so ist der Code richtig:

Sub a()
    
    Dim Ws As Worksheet: Set Ws = ActiveSheet
    Dim r As Range, s&, i&
    
    Application.ScreenUpdating = False
    With Ws.ListObjects(1)
        Set r = .DataBodyRange.Resize(.DataBodyRange.Rows.Count, 1)
        s = WorksheetFunction.CountA(r)
        If s < .ListRows.Count Then
            For i = .ListRows.Count To s + 1 Step -1
                .ListRows(i).Delete
            Next i
        End If
    End With
    Set Ws = Nothing: Set r = Nothing
End Sub
LG
Michael


  

Betrifft: Oops, falscher Faden, Sorry! Gehört nicht hierher! von: Michael (migre)
Geschrieben am: 29.11.2017 12:58:25




  

Betrifft: AW: Spalten abgleichen,Duplikate in 1er Spalte lös von: Moritz
Geschrieben am: 29.11.2017 16:08:56

Hallo Michael,

danke für deine Antwort! Deine Zählenwenn-Formel hat für meine Zwecke bereits gereicht! Vielen Dank!

LG Moritz


  

Betrifft: Das ist... von: Bernd
Geschrieben am: 30.11.2017 03:04:43

Moin,

der Grund warum man keinen neuen Beitrag aufmacht.

Meinen, in Deinem alten Beitrag, geposteten Lösungsvorschlag, (ist derselbe wie Michaels Lösung) hast Du ignoriert und bedanken tust Du Dich auch nicht.

Merke : bleibe bei Deinem Eröffnungsthreat!

MfG Bernd


Beiträge aus den Excel-Beispielen zum Thema "Spalten abgleichen,Duplikate in 1er Spalte löschen"