Microsoft Excel

Herbers Excel/VBA-Archiv

Zählenwenn ganze Zehner


Betrifft: Zählenwenn ganze Zehner von: soendi
Geschrieben am: 30.11.2017 10:37:36

Servus Excel-Freunde,

ich steh' aufm Schlauch... habe eine Liste in der Ganzzahlen gelistet sind, ich möchte zählen, wie viele der Ganzzahlen ganze Zehner sind.

10, 11, 12, 20, 30, 31, 32 - Ergebnis sollte hier sein: 3 (10, 20, 30 sollen gezählt werden.)

Ansatz

=zählenwenn(A1:A50; Rest(Zahl;Divisor)=0 )
=zählenwenn(A1:A50;rest(xx;10)=0)

Wie bringe ich die ZAHL da rein bei der Formel?

Danke euch
lukas

  

Betrifft: AW: Zählenwenn ganze Zehner von: SF
Geschrieben am: 30.11.2017 10:39:39

Hola,

=SUMMENPRODUKT((REST(A1:A50;10)=0)*(A1:A50<>""))

Gruß,
steve1da


  

Betrifft: =SUMMENPRODUKT((RECHTS(A1:A50)="0")*1) von: WF
Geschrieben am: 30.11.2017 10:46:57

.


  

Betrifft: AW: =SUMMENPRODUKT((RECHTS(A1:A50)="0")*1) von: soendi
Geschrieben am: 30.11.2017 10:48:41

Hey WF,

das mit dem Rechts(xx) hatte ich auch schon im Kopf - funktioniert tadellos...

Danke!!
Lukas


  

Betrifft: AW: Zählenwenn ganze Zehner von: soendi
Geschrieben am: 30.11.2017 10:47:11

Hey steve1da,

geht net... wirft mir #wert! aus... hast Du eventuell noch eine schnelle Idee? :D

Grüsse
Lukas


  

Betrifft: AW: Zählenwenn ganze Zehner von: SF
Geschrieben am: 30.11.2017 10:47:53

Hola,

dann steht irgendwo im Bereich A1:A50 TEXT.

Gruß
steve1da


  

Betrifft: AW: Zählenwenn ganze Zehner von: soendi
Geschrieben am: 30.11.2017 10:50:16

Hey,

sollte eigentlich nicht, eventuell gibt's #wert! auch bei Formel-Einträgen oder bei Zellen mit "".

Danke trotzdem, wieder ein wenig schlauer geworden. ;-)

Grüsse
Lukas


  

Betrifft: AW: Zählenwenn ganze Zehner von: SF
Geschrieben am: 30.11.2017 10:54:32

Hola,

"" ist Text.

Gruß,
steve1da


  

Betrifft: AW: Zählenwenn ganze Zehner von: Daniel
Geschrieben am: 30.11.2017 11:27:36

Wenns Ganzzahlen sind, sollte das hier funktionieren (das würde aber auch Texte zählen, die mit 0 enden, aber das sollte ja nicht vorkommen):

=SUMMENPRODUKT((RECHTS(A1:A50;1)="0")*1)

oder so, diese Formel muss aber explizit als Matrixformel mit STRG+SHIFT+ENTER eingegeben werden. Das Summenprodukt als Matrixformelauslöser reicht hier nicht aus.
=SUMMENPRODUKT(WENN(ISTZAHL(A1:A50);(REST(A1:A50;10)=0)*1))

gruß Daniel


Beiträge aus den Excel-Beispielen zum Thema "Zählenwenn ganze Zehner"