Microsoft Excel

Herbers Excel/VBA-Archiv

Formel für Liste


Betrifft: Formel für Liste von: Thomas
Geschrieben am: 05.12.2017 19:42:21

Hallo Excelfreunde,

ich habe mir ein kleinen Urlaubsplaner erstellt.

Nun möchte ich gern aus diesen Balkenplan eine Liste " Zusammenfassung"
erstellen. Im Beispiel habe ich es ein wenig besser dargestellt.

Hat jemand so eine Formel schon mal geschrieben? Falls nicht kann Sie jemand schreiben? Leider konnte ich auch nicht richtig nach der Lösung suchen denn ich weiss einfach nicht was ich als Begriff eingeben soll.

Gern könnte es auch mit vba gelöst werden, falls jemand so etwas parat hat.

Über ein link würde ich mich auch riesig freuen.

https://www.herber.de/bbs/user/118120.xlsx

habt schon mal besten dank für euer interesse

mfg thomas

  

Betrifft: AW: Formel für Liste von: onur
Geschrieben am: 05.12.2017 19:53:23

schau dir mal an, wann Test2 Urlaub hat, und was in deiner "Wunschliste" steht.
Und warum gibt es 2x test2?
Wo ist test5 geblieben?
Formel wird eh nicht klappen, da eine Formel nur die eigene Zelle beeinflussen kann.


  

Betrifft: AW: kann man mit nur einer Formel lösen ... von: ... neopa C
Geschrieben am: 05.12.2017 20:21:09

Hallo Thomas,

... wenn ich davon ausgehe, dass Du in Deinem Wunschergebnis-Liste in "Zusammenfassung" einige Zuordnungsfehler vorhanden sind. Oder?
Heute gehe ich allerdings jetzt gleich offline. Morgen kann ich Dir dann eine Matrixfunktion(alität)sformel die auch keines spez. Formelabschluss wie eine klassische Matrixformel benötigt aufzeigen.

Gruß Werner
.. , - ...


  

Betrifft: das wäre cool von: Thomas
Geschrieben am: 05.12.2017 20:36:49

Hallo neopa C,

das wäre cool

danke schön schon mal im voraus.


mfg thomas


  

Betrifft: Ups da habe ich gefuscht neues beispiel von: Thomas
Geschrieben am: 05.12.2017 20:27:19

Hallo onur,

erstmal besten dank für dein Hinweis.

und sorry da habe ich gefuscht. Aber genau deshalb suche ich nach einer fehlerfreien Möglichkeit.
ich habe das Beispiel angepasst.

https://www.herber.de/bbs/user/118124.xlsx
liebe grüsse thomas


  

Betrifft: AW: Ups da habe ich gefuscht neues beispiel von: onur
Geschrieben am: 05.12.2017 20:57:41

Einfach Button drücken:
https://www.herber.de/bbs/user/118125.xlsm


  

Betrifft: das ist cool besten dank von: Thomas
Geschrieben am: 05.12.2017 21:24:42

Hallo onur,

das ist cool hab echt vielen vielen dank.

Das spart mir viele Fehler.

liebe grüsse thomas


  

Betrifft: AW: das ist cool besten dank von: onur
Geschrieben am: 05.12.2017 21:35:15

Kein Problem - funktioniert auch für das GANZE Jahr und bis 95 Personen (ggf erhöhen in der z-Schleife).


  

Betrifft: AW: und ganz ohne "Klick" mit nur 1ner Formel ... von: ... neopa C
Geschrieben am: 06.12.2017 08:59:52

Hallo Thomas,

... wie bereits gestern Abend geschrieben, kann man Deine Zusammenfassung mit nachfolgend aufgezeigter Formel ermitteln. Vorausgesetzt ich hab Dein Anliegen richtig interpretiert, denn Du hast wieder die gleiche Datei wie zuerst eingestellt, die eine inkorrekte Wunschlistenaufstellung hat (ob onur es genau so interpretiert hat wie ich, hab ich nicht geprüft, da ich mir nur in Ausnahmefällen xlsm-Dateien aus dem Internet hole). In B4:

=WENNFEHLER(AGGREGAT(15;6;'Urlaub 01.07.18 bis 31.12.18'!$B$3:$GC$3/
(WENN(B$3="ende";'Urlaub 01.07.18 bis 31.12.18'!$C4:$GD4;'Urlaub 01.07.18 bis 31.12.18'!$A4:$GB4)<>"U")/
('Urlaub 01.07.18 bis 31.12.18'!$B4:$GC4="U");ZÄHLENWENN($B$3:B$3;B$3));"")

und Formel weit genug nach rechts und unten kopieren. Die Formel sieht nur so lang aus, weil Du Dein Tabellenblatt so lang bezeichnet hast. Derartige Blattbezeichnungen meide ich auch aus anderen Gründen.

Angenommen Deine Urlaubsliste würdest Du umbenennen in z.B.: UL_2HJ18 dann verkürzt sich die Formel in B4 (wenn oben stehende Formel schon eingetragen sein sollte, automatisch) zu:

=WENNFEHLER(AGGREGAT(15;6;UL_2HJ18!$B$3:$GC$3/(WENN(B$3="ende";UL_2HJ18!$C4:$GD4;UL_2HJ18!$A4:$GB4)<>"U")/(UL_2HJ18!$B4:$GC4="U");ZÄHLENWENN($B$3:B$3;B$3));"")

Die Eintragungen "anfang", "ende" in Zeile 3 sind weit genug eingetragen oder man kann diese soweit erforderlich aber auch nicht weiter als notwendig auch mit einer Formel, die nach rechts kopiert wird, automatisch erstellen.

Nachteil einer Formellösung: die Formel muss weit genug (nach rechts und unten) kopiert sein.
Vorteil: diese Lösung benötigt keinen Klick bei Änderung in der Urlaubsliste und nicht überall ist der Einsatz von nicht autorisierten XLSM/B-Dateien erlaubt.

Gruß Werner
.. , - ...


  

Betrifft: riesen dank an neopa C von: Thomas
Geschrieben am: 06.12.2017 18:48:53

Hallo Werner,


ich bin erst jetzt wieder am Rechner.

Hab vielen dank für deine Formellösung. Du bist für mich ein wahrer Formelkünstler. Es funktioniert
super. Ich werde mit deiner Formel ein wenig experimentieren denn ich habe noch so ein anderes Projekt auch da ist sie super einzusetzen.

Und was ich noch so an dir schätze was du versprichst das hälst Du auch.

Hab vielen vielen dank

MFG Thomas


  

Betrifft: AW: freut mich, auch Dir mein Dankeschön owT von: ... neopa C
Geschrieben am: 06.12.2017 19:09:30

Gruß Werner
.. , - ...


Beiträge aus den Excel-Beispielen zum Thema "Formel für Liste"