Microsoft Excel

Herbers Excel/VBA-Archiv

Sverweis und Durchschnitts-Marge berechnen


Betrifft: Sverweis und Durchschnitts-Marge berechnen von: Nora
Geschrieben am: 13.01.2018 00:11:05

Hallo zusammen,

ich möchte aus zwei Tabellenblättern folgendes berechnen:
Sheet1
Spalte1 Spalte2 Spalte 3 (Ergebnis soll hier rein)
1 Produktgruppenname a Durchschnittliche Marge Produktgruppe 1
2 Produktgruppenname b Durchschnittliche Marge Produktgruppe 2
3 Produktgruppennamen c
4
5
6

Sheet2
Spalte1 Spalte 2
3 Marge 2%
3 Marge 5%
3 Marge 8 %
1 Marge 10%
1 Marge 20%
1 Marge 20%

Ich möchte aus Sheet2 in Sheet1 in der Spalte 3 die durchschnittlichen Marge der Produktgruppen eintragen. Könnt ihr mir bitte weiterhelfen?

Danke und LG
Nora

  

Betrifft: AW: Sverweis und Durchschnitts-Marge berechnen von: Fritz
Geschrieben am: 13.01.2018 00:26:22

Hallo Nora

Kann deiner Erklärung nicht 100% folgen, aber benutze doch einfach die Funktion

MITTELWERTWENN


  

Betrifft: AW: Sverweis und Durchschnitts-Marge berechnen von: Nora
Geschrieben am: 13.01.2018 00:43:34

Hallo Fritz,

die Spalten sind irgendwie verschoben hier in der Ansicht. Mit Mittelwertwenn habe ich es bereits versucht, aber es wird mir dann immer der erste Wert der Marge in % wiedergegeben und nicht der Mittelwert über die gesamten Produktgruppen-Marge. Also ich versuche es mal in Schriftform zu beschreiben:)

Ich benötige aus einer zweiten Tabelle, wo die Produktgruppen eingetragen sind, die Durchschnitts-Marge. Ich habe die Produktgruppen 1-10 bereits im ersten Tabellenblatt.

Ich habe mal eine Beispieldatei angefügt. Die Zahlen sind hier überschaubar. Ich habe sonst 1000000 Artikel für die ich es machen muss:)
https://www.herber.de/bbs/user/118913.xlsx


  

Betrifft: AW: Sverweis und Durchschnitts-Marge berechnen von: Werner
Geschrieben am: 13.01.2018 00:55:54

Hallo Nora,

=WENNFEHLER(MITTELWERTWENN(Tabelle2!$A2:$A21;Tabelle1!$A2;Tabelle2!$B2:$B21);"")

Gruß Werner


  

Betrifft: AW: Sverweis und Durchschnitts-Marge berechnen von: Nora
Geschrieben am: 13.01.2018 01:04:40

Hallo Werner,

ich danke euch!!! Es funktioniert!!;))
Juhu

Eine Frage: Warum kommt das Wennfehler hinzu?

LG
Nora


  

Betrifft: AW: Sverweis und Durchschnitts-Marge berechnen von: Werner
Geschrieben am: 13.01.2018 01:07:45

Hallo Nora,

lass es mal weg, dann siehst du es. Du hast in deiner Liste mit den Projektnummern in Tabelle1 welche drin, die in Tabelle2 nicht vorhanden sind. Dann bekommst du über Mittelwertwenn den Fehler Division durch 0. Das wird durch das Wennfehler abgefangen.

Gruß Werner


  

Betrifft: AW: Sverweis und Durchschnitts-Marge berechnen von: Nora
Geschrieben am: 13.01.2018 01:15:53

Stimmt! Tausend Dank:)

LG
Nora


  

Betrifft: Gerne u. Danke für die Rückmeldung. o.w.T. von: Werner
Geschrieben am: 13.01.2018 01:17:08




Beiträge aus dem Excel-Forum zum Thema "Sverweis und Durchschnitts-Marge berechnen"