Microsoft Excel

Herbers Excel/VBA-Archiv

Dezimalstellen zählen


Betrifft: Dezimalstellen zählen von: Addi
Geschrieben am: 19.01.2018 14:47:38

Hallo Zusammen,
ich benötige ein Formel die mir die Anzahl der werthaltigen Dezimalstellen anzeigt...
damit mein ich wenn z.B. in A1 der Wert 10,0002000 steht soll als Ergebnis in B1 eine 4 stehen, da das die letzte Nachkommastelle mit einem Wert größer als 0 ist.
Vielen Dank für Eure Hilfe
VG Addi

  

Betrifft: AW: Dezimalstellen zählen von: Wolfgang
Geschrieben am: 19.01.2018 15:02:31

=LÄNGE(A1)-FINDEN(",";A1)
LÄNGE(A1) liefert die Länge der signifikanten Gesamtzahl
FINDEN(",";A1) lifert die Position des Kommas

Viele Grüße, Wolfgang


  

Betrifft: AW: Dezimalstellen zählen von: Addi
Geschrieben am: 19.01.2018 15:05:11

Klasse, vielen Dank!!


  

Betrifft: AW: Dezimalstellen zählen von: Sepp
Geschrieben am: 19.01.2018 15:12:54

Hallo Addi,,

so?

Tabelle1

 AB
1Zahlerste Werth. Kommastelle
2100,0002000000004
39,0250000000002
410,0000150000005
51,0000000030039
61,000000000000 

Formeln der Tabelle
ZelleFormel
B2{=WENNFEHLER(KKLEINSTE(WENN(RECHTS(GANZZAHL(ABS(A2)*(10^ZEILE($A$1:$A$15)))*1)*1>0;ZEILE($A$1:$A$15)); 1); "")}
Enthält Matrixformel:
Umrandende
{ } nicht miteingeben,
sondern Formel mit STRG+SHIFT+RETURN abschließen!
Matrix verstehen


Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8

http://www.excelformeln.de/formeln.html?welcher=151

Gruß Sepp



  

Betrifft: AW: wenn die Zahl als Textwert angezeigt ist ... von: ... neopa C
Geschrieben am: 19.01.2018 15:15:54

Hallo Addi,

... dann wird es komplizierter, weil die 0en nach der letzten Ziffer mit gezählt werden.
Dann z.B. so:

=VERWEIS(9;1/(--TEIL(TEIL(A11;FINDEN(",";A11)+1;15);ZEILE(A$1:A$16);1)>0);ZEILE(A$1:A$16))

Gruß Werner
.. , - ...


  

Betrifft: Da wird Wolfgang nur leicht modifiziert von: lupo1
Geschrieben am: 19.01.2018 15:21:46

=LÄNGE(--A1)-FINDEN(",";A1)


  

Betrifft: AW: hast völlig Recht, zu kompliziert gedacht owT von: ... neopa C
Geschrieben am: 19.01.2018 15:26:45

Gruß Werner
.. , - ...


  

Betrifft: Zu Sepps Bsp passt am besten folgd Fml, ... von: Luc:-?
Geschrieben am: 19.01.2018 17:49:55

…Leute:
B1[:B5]:=LÄNGE(--A1)-LÄNGE(GANZZAHL(A1))-(GANZZAHL(A1)<>--A1)
Allerdings habe ich den TextZahl-Bereich auf A1:A5 geändert. Lupos iW ebenfalls richtige Fml liefert bei letzter TextZahl -1 und Werners komplizierte Fml #NV.
Sepp hingegen muss die Aufgabe falsch verstanden haben, während Wolfgang offensichtlich nicht von TextZahlen ausging, aber echte Zahlen erfüllen nunmal nicht die anzunehmenden Bedingungen (DezimalEndNullen).
🙈 🙉 🙊 🐵 Gruß, Luc :-?

„Die Intelligenzmenge ist auf diesem Planeten eine Konstante, die Bevölkerung nimmt aber zu!“ Auch deshalb informieren mit …


  

Betrifft: =WENNFEHLER(LÄNGE(1*A1)-FINDEN(",";1*A1);0) von: WF
Geschrieben am: 19.01.2018 22:53:35

.


  

Betrifft: ...Oder eben Walters. owT von: Luc:-?
Geschrieben am: 20.01.2018 18:42:20

:-?


Beiträge aus dem Excel-Forum zum Thema "Dezimalstellen zählen"