Microsoft Excel

Herbers Excel/VBA-Archiv

Differenziert Kalendertage in markieren!?


Betrifft: Differenziert Kalendertage in markieren!? von: Juergen Bohl
Geschrieben am: 26.01.2018 09:43:13

Hallo zusammen,

mich hat hier ein "Praxisproblem" eingeholt.

Wir nutzen den in Beispieldatei beigefügten Kalender zur Eintragung von personenbezogenen Daten. I.d.R. Urlaub, Notdienst und unbezahlt. Vorgehensweise ist, dass nach eintragen der Datums-Werte in Spalten "C,D.E" (Start, Zweck, Ende) die entsprechenden Zell-Tage farbig markiert werden. passt alles.

Fragestellung:
Wie könnte ich es verwirklichen, dass bei Kennung "Urlaub" nur Tage markiert werden, welche normale Arbeitstage sind!? D.h., es wären genau die Tage, welche keine farbige Spaltenkennzeichnung als "Wochenende" oder "Feiertage" haben?

Beispiel-Datei hier:
https://www.herber.de/bbs/user/119279.xlsm

Im der Datei wäre das Beispiel dann wie folgt:
- Notdienst-Kennzeichnung: passt, es soll alles markiert werden
03.02.2018 --- 18.02.2018

- jedoch die Urlaubs-Kennzeichnung sollte ausschließlich folgendes markieren:
29.02.2018 --- 02.02.2018
05.02.2018 --- 09.02.2018
14.02.2018 --- 16.02.2018

Müssten das über die Zellformeln angepasst bekommen,

[ =WENN(UND($C6<=AH$5;$E6>=AH$5);0;"")) ]

oder nur über VBA möglich dies zu erreichen?

Danke & Gruss,
Juergen




  

Betrifft: AW: Differenziert Kalendertage in markieren!? von: SF
Geschrieben am: 26.01.2018 09:51:49

Hola,

=($D6="urlaub")*(F$5>=$C6)*(F$5<=$E6)*(WOCHENTAG(F$5;2)<6) *(ZÄHLENWENN(Feiertage!$B$1:$B$116;F$5)=0)

Gruß,
steve1da


  

Betrifft: AW: Zellformel ändert nichts? von: Juergen Bohl
Geschrieben am: 26.01.2018 10:26:21

Hallo Steve,

danke für deine Antwort.
Ich habe nun mal testweise deine Formel am 3+4.02.2018 eingegeben, doch leider bleiben die Zellen markiert. Versteh ich da was nicht richtig?

https://www.herber.de/bbs/user/119284.xlsm


Andere Frage:
wenn das mirt einer Änderung der Zellformeln klappen sollte, wie bringe ich den Austausch im kompletten Blatt zustande!?

Danke & Gruss,
Juergen


  

Betrifft: AW: Zellformel ändert nichts? von: SF
Geschrieben am: 26.01.2018 10:38:39

Hola,

meine Formel kommt in die bedingte Formatierung, jedenfalls habe ich das unter "Markieren" verstanden.

Gruß,
steve1da


  

Betrifft: AW: sorry, verpeilt. Noch ne Frage :) von: Juergen Bohl
Geschrieben am: 26.01.2018 11:30:46

Hallo Steve,

sorry, hatte ich vollkommen verpeilt angegangen. Funktioniert einwandfrei bei nun "bedingt Formatierung" hinterlegt :) Vielen Dank für die Hilfe!

Ergänzend gefragt:
könnte die die Formel noch erweitert werden, dass in den nicht markierten Zellen keine "O" zugleich stehen, ohne das die übrigen Blattmarkierungen davon betroffen sind?

Danke & Gruss,
Juergen


  

Betrifft: AW: sorry, verpeilt. Noch ne Frage :) von: SF
Geschrieben am: 26.01.2018 11:52:53

Hola,

du musst die Formeln, die du in den Zellen hast, in die bedingte Formatierung überführen und dann aus den Zellen löschen.

Gruß,
steve1da


  

Betrifft: AW: Vielen Dank für deine Hilfe! owT von: Juergen Bohl
Geschrieben am: 26.01.2018 12:44:45

.