Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Prüfen ob mehrere Strings enthalten

Prüfen ob mehrere Strings enthalten
11.07.2018 16:54:50
Kisska
Hi zusammen,
ich habe 2 Tabellen mit Artikelnummern:
Tabelle 1, Spalte A
A1: Artikelnummer
A2: A_00138769
A3: A_003
A4: A_00138769
A5: A_008
Tabelle 2, Spalte D
D1: Artikelnummer
D2: A_001
D3: A_0020
D4: A_003
Ziel: In der Tabelle 1, Spalte B prüfen, ob in den jeweiligen Zeilen der Spalte A Inhalte bzw. Strings aus der Tabelle 2 vorhanden sind.
Beispielsweise gibt es in der Tabelle 2 die Nummer A_001. In der Tabelle 1 steckt diese Nummer als String in A2 und A4 drin. In B2 und B4 sollte daher " String enthalten" stehen. Die Formel in B2 soll dann nach unten kopiert werden zur Prüfung der anderen Zellinhalte.
Mit dieser Funktion bekomme ich falsche Ergebnisse:
  • =ZÄHLENWENN(A2;Tabelle2[Artikelnummer]&"*")

  • Was fehlt in meiner Formel?
    VG
    Kisska

    9
    Beiträge zum Forumthread
    Beiträge zu diesem Forumthread

    Betreff
    Datum
    Anwender
    Anzeige
    AW: Prüfen ob mehrere Strings enthalten
    11.07.2018 17:03:14
    Steve
    Tabelle1 B2 => =WENN(ZÄHLENWENN(Tabelle2!D$2:D$4;A2&"*")>0;"enthalten";"keine Übereinstimmung")
    so in etwa?
    nope
    11.07.2018 17:24:49
    Kisska
    Hallo Steve,
    A2&"*" kann nicht stimmen, es ist ja bereits länger als D2.
    VG
    Kisska
    AW: nope
    11.07.2018 17:28:24
    Steve
    Also andersherum? die strings in tablle2 d2:d4 sollen in tabelle1 a2 gesucht werden?
    dann evtl
    =WENN(ZÄHLENWENN(A2;Tabelle2!D$2&"*")+ZÄHLENWENN(A2;Tabelle2!D$3&"*")+ZÄHLENWENN(A2;Tabelle2!D$4&"*") >0;"enthalten";"keine Übereinstimmung")
    ?
    Ja, aber
    11.07.2018 18:25:42
    Kisska
    Ganz genau! So stimmt das Ergebnis.
    Aber was mache ich bei über 10.000 Zeilen? Kann man die Suchkriterien nicht als Bereich bzw. Matrix angeben?
    Anzeige
    AW: Ja, aber
    11.07.2018 18:49:24
    Steve
    Ich glaube das geht nicht so einfach.
    AW: Prüfen ob mehrere Strings enthalten
    11.07.2018 18:48:35
    Sepp
    Hallo Kisska,
    so?
    Tabelle1

     ABC
    1ArtikelnummerEnthalten 
    2A_00138769Ja 
    3A_003Ja 
    4A_00138769Ja 
    5A_008Nein 
    6A_00201345Ja 
    7A_00212345Nein 
    8   

    Formeln der Tabelle
    ZelleFormel
    B2=WENN(SUMMENPRODUKT(ZÄHLENWENN(A2;Tabelle2!$D$2:$D$20&"*")*(Tabelle2!$D$2:$D$20<>"")); "Ja";"Nein")


    Tabelle2

     CDE
    1 Artikelnummer 
    2 A_001 
    3 A_0020 
    4 A_003 
    5   
    6   


    Excel Tabellen im Web darstellen >> Excel Jeanie HTML 4.8
     ABCDEF
    1Gruß Sepp
    2
    3

    Anzeige
    Perfekte Lösung!
    11.07.2018 19:19:49
    Kisska
    Danke Sepp, das ist die Lösung!
    Zwei Fragen noch:
    1) Kann ich den hinteren Teil *(Tabelle2!$D$2:$D$20"")); einfach durch

    >0
    ersetzen (um die Formel kürzer zu halten) ?
    2) Könntest du mich bitte aufklären, warum man überhaupt Summenprodukt bzw. den hinteren Ausdruck braucht? Wieso erkennt Excel in meiner ursprünglichen Formel nicht, dass die Zellen D1 bis D4 nicht leer sind?
    VG
    Kisska
    AW: Perfekte Lösung!
    11.07.2018 19:26:58
    Sepp
    Hallo Kisska,
    also für mich ist die Formel kurz genug!
    Den zweiten Teil brauchst du, weil A2 immer gleich "*" sein wird, deshalb muss man leere Zellen explizit ausschließen.
     ABCDEF
    1Gruß Sepp
    2
    3

    Anzeige
    danke!
    16.07.2018 21:46:18
    Kisska
    Danke Sepp!
    Anzeige

    Beliebteste Forumthreads (12 Monate)

    Anzeige

    Beliebteste Forumthreads (12 Monate)

    Anzeige
    Anzeige
    Anzeige
    Archiv - Verwandte Themen
    Forumthread
    Beiträge