Microsoft Excel

Herbers Excel/VBA-Archiv

Informationen und Beispiele zum Thema ListBox
BildScreenshot zu ListBox ListBox-Seite mit Beispielarbeitsmappe aufrufen

Datum-Zeit-Daten in MATRIX transponieren


Betrifft: Datum-Zeit-Daten in MATRIX transponieren von: Michael
Geschrieben am: 18.07.2018 09:20:52

Hallo, ich möchte gern aus einer Date-Time-Spalte mit korrespondierenden Daten eine MATRIX erzeugen, welche als x-Achse die Stunden von 00:00 bis 23:00 und als y-Achse das Datum [DD.MM.JJJJ] hat (siehe Minimalbeispiel).

Frage 1: Kann ich so eine Matrix mit Formeln aus den ROHDATEN erzeugen?
Frage 2: Wie werden die Daten dann in die richtigen Slot der Matrix transponiert?

LG
M.

https://www.herber.de/bbs/user/122749.xlsx

  

Betrifft: AW: Datum-Zeit-Daten in MATRIX transponieren von: ChrisL
Geschrieben am: 18.07.2018 09:46:44

Hi Michael

Formel F4: =INDEX($C:$C;(ZEILE(F1)-1)*24+SPALTE(F1)-3;1)

Es wird nicht "gesucht" sondern nur eine Art "Muster" erzeugt (24er Schritte). D.h. funktioniert nur, solange es pro Tag immer fix 24 Datensätze gibt.

cu
Chris


  

Betrifft: AW: Datum-Zeit-Daten in MATRIX transponieren von: PeterK
Geschrieben am: 18.07.2018 09:56:48

Hallo

Warum nicht eine Pivot Tabelle?


  

Betrifft: AW: Datum-Zeit-Daten in MATRIX transponieren von: UweD
Geschrieben am: 18.07.2018 10:09:40

Hallo




Formel in F4: =WENN($E4<>"";INDEX($C:$C;VERGLEICH($E4+F$3;$B:$B;1));"")

nach rechts und runter kopieren


LG UweD


Beiträge aus dem Excel-Forum zum Thema "Datum-Zeit-Daten in MATRIX transponieren"