Microsoft Excel

Herbers Excel/VBA-Archiv

Urlaubstage aus Tabelle in Kalender übertragen


Betrifft: Urlaubstage aus Tabelle in Kalender übertragen von: Chriss
Geschrieben am: 30.07.2018 18:06:48

Referenztabelle: https://www.herber.de/bbs/user/122993.xlsx

Ich habe...
... in Spalte A Personennamen,
... in Spalte B Startdatum,
... in Spalte C Enddatum.

Im Bereich E4:AJ13 habe ich einen Kalender erstellt.

Nun soll in Spalte A der Name geprüft werden und jeder Tag in der Zeile des Namens (Spalte E), der zwischen Startdatum (Spalte B) und Enddatum (Spalte C) liegt, rot eingefärbt werden.

In Spalte A können die Namen mehrfach auftauchen.

Hat jemand eine Idee, ggf. über Makro?!

  

Betrifft: AW: Urlaubstage aus Tabelle in Kalender übertragen von: daniel
Geschrieben am: 30.07.2018 18:32:42

Hi

eine gute Idee wäre, deinen Beitrag mit einem netten Gruß zu beginnen, das erhöht in der Regel die Hilfsbereitschaft.
Macht man im Normalen Leben ja auch, wenn man jedemanden um Hilfe oder Rat bittet, dann poltert man auch nicht gleich mit der Frage los, sondern sagt erstmal sowas wie "Guten Tag".

ansonsten, probiers mal mit ZählenWenns, z.B, als Regel für die Bedingte Formatierung.

=ZÄHLENWENNS($A$5:$A$10;$E5;$B$5:$B$10;"<="&F$4;$C$5:$C$10;">="&F$4)
gruß Daniel


  

Betrifft: AW: Urlaubstage aus Tabelle in Kalender übertragen von: Chriss
Geschrieben am: 31.07.2018 08:29:09

Hallo Daniel,
entschuldige die Unhöflichkeit... Du hast recht.
Umsomehr freut es mich, dass Du mit einer Lösung geantwortet hast. Super lieben Dank!
Gruß
Chriss


Beiträge aus dem Excel-Forum zum Thema "Urlaubstage aus Tabelle in Kalender übertragen"