Microsoft Excel

Herbers Excel/VBA-Archiv

Zellbereiche variabel machen


Betrifft: Zellbereiche variabel machen von: Christian
Geschrieben am: 07.08.2018 18:23:11

Hallo an euch alle, möchte euch mal bitten, folgende Formel anzuschauen:

=INDEX(A2:A9287;AGGREGAT(14;6;ZEILE(A1:A9287)/(D2:D9287=0);1))

und zwar in sofern, ich würde mir wünschen dass sie sich statt sich auf die Zeile 9287 festzulegen, auf die letzte Zeile mit Inhalt in Spalte A festlegt, sodass ich sie nicht ändern muss, wenn ich Zeilen zufüge oder lösche.

Mich auf A:A und D:D festlegen möchte ich nicht, da ich bewusst die erste als auch die jetzige Zeile 9288 von der Formel ausschließen möchte.
A9288 ist leer, damit ist Zeile 9287 die letzte mit Inhalt in Spalte A.

Gruß und danke
Christian

  

Betrifft: noch zur Info von: Christian
Geschrieben am: 07.08.2018 18:24:47

Im Bereich A2:A9287 gibt es keine Leerzellen, genauso wie in D2:D9287.

Gruß
Christian


  

Betrifft: AW: noch zur Info von: Luschi
Geschrieben am: 08.08.2018 09:05:44

Hallo Christian,

verwende die Tabellenformatvorlage 'Als Tabelle formatieren' (Strg+T oder Strg+L) und Du bist diese Sorgen los, oder definierten Namen und dynamischer Bereichszuordnung (z.B. Bereich.Verschieben()).

Gruß von Luschi
aus klein-Paris


  

Betrifft: AW: mit zusätzlichen INDEX() ... von: neopa C
Geschrieben am: 08.08.2018 12:40:29

Hallo Christian,

... ist Dein angestrebtes Ziel auch erreichbar. Und zwar so:

=INDEX(A:A;AGGREGAT(14;6;ZEILE(A2:INDEX(A:A;ANZAHL2(A:A)))/(D2:INDEX(D:D;ANZAHL2(A:A))=0);1))

Unabhängig davon ist der 1. Hinweis von Luschi wirklich empfehlenswert. Um Dir die Formel dafür anzupassen, müssten wir aber zumindest die beiden Überschriften der Spalte A und D kennen.

Gruß Werner
.. , - ...


  

Betrifft: AW: mit zusätzlichen INDEX() ... von: Christian
Geschrieben am: 08.08.2018 15:40:35

Hallo Werner,

ich weiß du bist jetzt nicht glücklich darüber, aber ich hoffe du beruhigst dich und hilfst mir trotzdem noch.
Ich habe nicht mehr dran gedacht, dass es in der Tabelle noch eine zweite Formel gibt, die sich auf diesen Zellbereich bezieht.

=ZÄHLENWENN(D2:D9287;"X")

Auch da wäre es hilfreich für mich, wenn man mit diesem Zellbereich dasselbe tun könnte.

Aber dein Vorschlag für die erste Formel funktioniert.

Zu den Überschriften: Spalte A: tt-Nummern Spalte D: ist

Gruß
Christian


  

Betrifft: AW: analog realisieren ... von: neopa C
Geschrieben am: 08.08.2018 16:03:49

Hallo Christian,

... und zwar so: =ZÄHLENWENN(D2:INDEX(D:D;ANZAHL2(A:A));"X")

Gruß Werner
.. , - ...


  

Betrifft: AW: analog realisieren ... von: Christian
Geschrieben am: 08.08.2018 16:13:19

Hallo Werner,

vielen Dank.

Nur eine Verständnisfrage, müsste es nicht ANZAHL2(A:A)-1 sein, da ich die erste Zeile auslassen will?

Aber da in D1 kein X steht, spielt es ja an der Stelle ja auch keine Rolle ob D1 mit einbezogen wird, hauptsache nicht D9288.


  

Betrifft: AW: wichtig wäre nur, dass in A1 etwas steht ... von: neopa C
Geschrieben am: 08.08.2018 16:41:24

Hallo Christian,

... denn ansonsten müsstest Du noch 1 addieren. Das Du mit der Auswertung in der 2. Zeile beginnen willst ist bereits durch das Formelkonstrukt berücksichtigt.

Gruß Werner
.. , - ...


  

Betrifft: AW: wichtig wäre nur, dass in A1 etwas steht ... von: Chris
Geschrieben am: 08.08.2018 17:09:06

Ok funktioniert. Danke


Beiträge aus dem Excel-Forum zum Thema "Zellbereiche variabel machen"