Live-Forum - Die aktuellen Beiträge
Datum
Titel
25.06.2024 22:07:02
25.06.2024 21:01:55
25.06.2024 19:21:44
Anzeige
Archiv - Navigation
1644to1648
Aktuelles Verzeichnis
Verzeichnis Index
Übersicht Verzeichnisse
Vorheriger Thread
Rückwärts Blättern
Nächster Thread
Vorwärts blättern
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

VBA - Formel für jede zweite Spalte anwenden

VBA - Formel für jede zweite Spalte anwenden
20.09.2018 14:04:20
Maria
Hallo zusammen :)
könnt ihr mir bei folgendem Problem weiterhelfen?
Ich würde gerne (siehe Bild anbei - Userbild
) die gelben Felder befüllen. In der Zelle B23 und B24 habe ich die =MITTELWERT(A23:A24) Formel angewandt. Diese Formel würde ich jetzt für alle weiteren gelben Zellen anwenden. Also die Zellen D23 und D24 würde ich mit der Formel =MITTELWERT(C23:C24) befüllen.
Die Exceldatei hat SEHR viele Spalten dh ich würde sehr lange brauchen, wenn ich die Formel händisch in jede betroffene (gelbe) Zelle eingebe.
Gibt es hier einen VBA Code mit dem man das lösen kann?
Ich würde mich sehr freuen :)
Vielen lieben Dank und liebe Grüße
Maria

2
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: VBA - Formel für jede zweite Spalte anwenden
20.09.2018 16:30:33
ChrisL
Hi Maria
Sub t()
Dim intSpalte As Integer
With ActiveSheet
For intSpalte = 1 To .Cells(23, Columns.Count).End(xlToLeft).Column Step 2
.Cells(23, intSpalte).Offset(0, 1).Resize(2).FormulaR1C1 = "=AVERAGE(R23C[-1]:R24C[-1])"
Next intSpalte
End With
End Sub
cu
Chris
AW: VBA - Formel für jede zweite Spalte anwenden
20.09.2018 18:17:01
Maria
Hallo Chris,
vielen vielen Dank! Hat perfekt funktioniert :)
Liebe Grüßle
Maria
Anzeige

319 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige