Live-Forum - Die aktuellen Beiträge
Anzeige
Anzeige
HERBERS
Excel-Forum (Archiv)
20+ Jahre Excel-Kompetenz: Von Anwendern, für Anwender
Inhaltsverzeichnis

Auswerten einer Liste ohne Array/VBA

Auswerten einer Liste ohne Array/VBA
19.03.2019 16:59:50
lattes
Hallo,
habe eine Tabelle mit max 500 Einträgen. Diese möchte ich ohne Array/VBA also über Formeln auswerten. Hier ist die Tabelle:
https://www.herber.de/bbs/user/128506.xlsx
In Spalte A ist das ausschlaggebende Kriterium. Wenn das leer ist, dann soll in einer neuen Spalte F eine Liste aus Kundennummern (Spalte C) erstellt werden für die diese Bedingung erfüllt ist. Die Tabelle ist dynamisch (Kollegen werden neue Einträge vornehmen oder aber Einträge löschen, ein anderer wird hin und wieder Spalte A ausfüllen) aber auf 500 Einträge begrenzt.
Bitte um Unterstützung!!! Vielen Dank
Gruß
lattes

8
Beiträge zum Forumthread
Beiträge zu diesem Forumthread

Betreff
Datum
Anwender
Anzeige
AW: Auswerten einer Liste ohne Array/VBA
19.03.2019 17:11:40
onur
Ist die Reihenfolge egal?
AW: Auswerten einer Liste ohne Array/VBA
19.03.2019 17:22:44
Herbert
Hallo,
bei mir hat es damit geklappt:
=WENNFEHLER(INDEX($C:$C;AGGREGAT(15;6;ZEILE($A$1:$A$600)/($A$1:$A$600="")/(LINKS($C$1:$C$600;4) ="nein");ZEILE($A1));SPALTE(A$1));"") 
Servus
AW: Auswerten einer Liste ohne Array/VBA
19.03.2019 17:28:47
Herbert
Allerdings hast du in Zelle A9 ein "Blank" und nicht ""! Das "Blank" musst du in deiner Tabelle noch entfernen!
Servus
AW: Auswerten einer Liste ohne Array/VBA
19.03.2019 17:29:55
onur
Und wieso schreibst du MIR das alles ? :)
AW: Auswerten einer Liste ohne Array/VBA
19.03.2019 17:34:03
Herbert
Ich habe es nicht DIR geschrieben, sondern dem Frager. Es ist völlig egal, wo in einem Thread ich antworte, da immer alle Beteiligten darin eine Antwort bekommen! ;o)=)
Anzeige
AW: "nein" ist aber nicht wirklich Bedingung ...
19.03.2019 17:53:33
neopa
Hallo Herbert,
... doch Du kannst die Formel an die wirklich vorgegebene Bedingungen leicht anpassen:

=WENNFEHLER(INDEX($C:$C;AGGREGAT(15;6;ZEILE(A$1:A$600)/(A$1:A$600="")/(B$1:B$600&gt0);ZEILE(A1)));"")

Gruß Werner
.. , - ...
AW: "nein" ist aber nicht wirklich Bedingung ...
19.03.2019 17:59:10
Herbert
Hallo Werner,
da er das nur auf die grünen Einträge bezogen hat und die eben alle mit "nein" beginnen, habe ich es eben auch mit eingebaut! Aber egal, diese "AGGREGAT"-Formel ist ja sowieso von dir! ;o)=)
Und nun habe ich schon wieder etwas dazu gelernt! Danke!
Servus
AW: "nein" ist aber nicht wirklich Bedingung ...
19.03.2019 18:08:00
lattes
Wow, VIELEN DANK!!!! Ich kann gar nicht so schnell antworten wie Ihr Lösungsvorschläge schickt. Werners ist genau die, die ich gesucht habe.
Anzeige

328 Forumthreads zu ähnlichen Themen

Anzeige
Anzeige
Anzeige
Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige

Beliebteste Forumthreads (12 Monate)

Anzeige
Anzeige
Anzeige